1. Are you ready for the Galaxy S20? Here is everything we know so far!

Galaxy Nexus GPS issue?

Discussion in 'Android Devices' started by kreamkrackers, Dec 20, 2011.

  1. kreamkrackers

    kreamkrackers Lurker
    Thread Starter

    Hey Guys!

    I have what I think is an issue with the GPS on my Galaxy Nexus that I hope someone can clarify for me.

    When I use GPS Satellites alone to pinpoint my location (meaning turning off the option to use data sources such as Wifi and mobile networks) I NEVER get a hit. The GPS icon in the top left when in Maps or Navigation or even My Tracks doesn't even flash.

    I called Samsung Support and they said that in order to use GPS you MUST have the Wifi and mobile networks feature turned on at all times.

    Surely this isn't correct. To make it even more odd, I downloaded various GPS testing apps such as GPS Status, GPS Essentials and GPS Test and they all pinpoint multiple satellites, then when I go into maps, it then works but only until the phone is switched off!! When turned back on it goes back to square one.

    Am I going mad? Surely the whole point of GPS is to pick up satellite signals itself. I totally understand that the Wifi and mobile networks feature would enhance the accuracy, but to not work without it? This would mean that If I were stuck in the desert with no Wifi or mobile mast (unlikely I know), then I would not be able to pinpoint my location.

    Do I have a GPS fault? Could anyone test this to see if it works for them?

    Thanks in advance guys.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. breadnatty08

    breadnatty08 pain rustique

    Haven't had time to really test out the GPS, but with most apps you need to pull in cell data to have an accurate location (at least with Maps) in addition to GPS.

    Just tried your settings and I believe they are correct. It won't work without using Google location services/cell towers.

    Edit: By the way, welcome to the Forums! Enjoy your time here, tons of great help and tips to be had.
     
  3. ThrottleAbuse

    ThrottleAbuse Newbie

    Are you saying that with these programs you are able to get a lock with only GPS or are you saying that once you use wifi/data and gps to get a lock with these programs then you can turn off wifi/data and only use gps until you turn the phone off?
     
  4. CharlzO

    CharlzO Android Expert

    I would guess that they use it for the aGPS to get a fix at first start, but then if you happen to go outside a coverage area, it would rely just on the straight GPS. I know I've driven out of service areas while navigating and the maps were cached in for the duration of the dead spot, and I was still being tracked.
     
  5. Dubbin1

    Dubbin1 Android Expert

    If its designed to work that way per the samsung guys I don't see what the issue here is???
     
  6. syntrix

    syntrix Android Expert

    no you don't, you just need to search harder.

    I got into 15m with my VZW SGN in about 2 seconds the very first time. Yes I had data on, but it locked IIRC 9/9 on a rainy/overcast day.
     
  7. ez12a

    ez12a Member

    You need data if you're using navigation. Maps are not cached by default. You can switch on caching but you need to cache the areas manually. You dont get built in offline world map.

    Downfall of not using a dedicated GPS unit like a Garmin.
     
  8. syntrix

    syntrix Android Expert

    VERIFIED, all data turned off.

    Launched GPS Status, and cleared agps, and turned off updates.

    Instant lock and got to 5m on a clear night under the roof on my back porch.
     
  9. syntrix

    syntrix Android Expert

    There are programs that rely on maps loaded to storage, he's talking about GPS only. See my post above.

    edit: and google maps will cache an area, that's a fairly new feature, but you can do this! It was on their dev radar for a while, and it's now there! The concern was going into areas with no data, and the ability to still use maps.

    double edit: SGN on VZW, 100% stock. OP is his first post and doesn't specify which version or region, or rom/etc.... that *might* make a difference.
     
  10. kreamkrackers

    kreamkrackers Lurker
    Thread Starter


    Basically, the programs are GPS test apps. With only GPS turned on (NO wifi/data) I open any one of the GPS test apps and get a lock, then open maps (still only having GPS active) and I am able to get a lock. If I then turn off the phone and turn it back on, this is reset and I cannot then go straight into maps and get a lock GPS only.

    The issue is that if I am in a non wifi/data coverage area, I cannot get GPS. I go hiking sometimes where there is not wifi/cell coverage, so are they saying that it won't work? If so, it's pretty poor GPS considering I was able to do this on my girlfriend's Nexus S no problem...


    By the way, I am in London with a factory unlocked Nexus untouched since by me (as far as rooting etc). I have Android version 4.0.1.
    I have put the same settings on my girfriend's Nexus S and side by side, hers gets a lock and mine does not.
    I was actually told by the Samsung person on the phone that ALL smartphones with GPS worked with Wifi on!! Even though I have personally proved that wrong with the Nexus S and an iPhone...
     
  11. dakamarko

    dakamarko Lurker

    Thanks. But so is possibile to choose if use a-gps or gps only?
    If i have an gps software with installed map like navigon or copilot?
     
  12. kreamkrackers

    kreamkrackers Lurker
    Thread Starter

    I managed to get hold of another Nexus from a work colleague. I took the the option to use data sources such as Wifi and mobile networks off and made sure that wifi was also off on both handsets (both have android 4.0.1 incidentally).

    I then turned them both off then on again to get them from cold and went to Google Maps in both and hey presto! Managed to get a fix on my colleague's phone but not mine (no matter how many times I tried).

    I called Samsung support again and explained this to the guy on the phone and he said it does seem like a fault (at last!). I have now taken it to a Samsung repair shop and they are going to re-flash the firmware. If that doesn't work, they said I can get a replacement.

    I'll keep you posted....
     
    AnotherHiggins and anitacita like this.
  13. dakamarko

    dakamarko Lurker

    I respond myself. It's possible to use GPS only. i downloded copilot with maps. and i can use it without data plan.:D:D:D
     
  14. samiusmc

    samiusmc Newbie

    One thing I noticed is that Google Navigation takes an awful long time to locate the GPS. something is definitely wrong. Has anyone else noticed this?
     
  15. pragmatous

    pragmatous Android Enthusiast

    I'l try out the GPS when I go home tonight
     
  16. ChiTownJim

    ChiTownJim Android Expert

    It's not the fastest GPS lock I've use on a phone that goes to my Incredible running CM7 that thing locks isntantly but it really hasn't ever taken more then 15 seconds to lock and usually it locks in around 5 seconds . Perfect ? no but not bad my EVO won't even lock GPS at all lol
     
  17. jbird720

    jbird720 Member

    My gps tacks forever..... droid2 took 30seconds maybe. Nexus takes several minutes and still doesnt work half the time.
     
  18. anitacita

    anitacita Lurker

    Thank you kreamkrackers! I have the same issue. Looking forward to hearing how this turned out for you.
     
  19. ChiTownJim

    ChiTownJim Android Expert

    I was having no problems with GPS lock was very fast on stock , stock rooted and Gummy 0.2.3 but when I flashed the newest Gummy (forgot the number) it works but is slightly slower and yesterday I was using GPS and it took over a minute to lock me and when it did it put me somewhere in Europe but when I exited Nav and re entered my destination it locked me accurately right away . Not sure what is up with that
     

Galaxy Nexus Forum

The Galaxy Nexus release date was November 2011. Features and Specs include a 4.65" inch screen, 5MP camera, 1GB RAM, TI OMAP 4460 processor, and 1750mAh battery.

November 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...