1. Check out our companion app, Forums for Android! Download from Google Play

Support Galaxy Portal Drivers issue

Discussion in 'Android Devices' started by zman786, Jun 20, 2010.

  1. zman786

    zman786 Member
    Thread Starter
    15

    Jun 20, 2010
    15
    0
    15
    HI, I got the i5700 yesterday. I've been trying to update it to 2.1 but with no success. Initially i had port problems but i fixed that. Now it wont go past <1> setup connection. It hasnt been bricked (thankfully) but when i checked the drivers (while in that download mode) and they showed up as Samsung Modem, USB (or something similar) but had no mention of Android in the name.
    When i connect the phone while its on, the drivers show up correctly (with Android in the name) (i hear this is necessary because it shows its connected to the OS)

    So can anyone explain to me how I can install the drivers correctly for download mode?
     

    Advertisement

  2. XplosiV

    XplosiV Master X is Watching You
    313

    Jun 10, 2010
    5,422
    1,969
    313
    Male
    UK
    Here is a checklist that might help.

    Install nps version 1.4 or 1.5, or kies, to get latest drivers installed.

    Download Odin

    Remove sim & sd card

    Put phone into download mode (press volume down, camera & power button) make sure phone is not connected to PCB to get phone into download mode.

    Once phone displays download mode screen, connect via usb to pc.

    Load Odin

    Set .tar paths in Odin and wait 1-2 minutes (for drivers to finish installing phone)

    You should now have a yellow com port. Now hit start to flash your phone.
     
  3. XplosiV

    XplosiV Master X is Watching You
    313

    Jun 10, 2010
    5,422
    1,969
    313
    Male
    UK
    After removing your sim and sd card, also remove and replace your battery, and keep your phone off, as the next step (putting phone into download mode) powers up your phone the right way.
     
  4. zman786

    zman786 Member
    Thread Starter
    15

    Jun 20, 2010
    15
    0
    15
    ok so i tried all that and it didnt work, the drivers were still missing "Android" in their title, and it was stuck on the setup connection part.
    Now heres a bigger problem, when i tried a different usb port in download mode it tried installing drivers again automatically but this time it just say Unknown Device and now it says that for all the Usb ports. However it works perfectly fine when the phone is working normally.
    Really appreciate any help
     
  5. XplosiV

    XplosiV Master X is Watching You
    313

    Jun 10, 2010
    5,422
    1,969
    313
    Male
    UK
    Check what version of kies or nps you have installed

    Make sure kies or nps is NOT running at the point when you connect your phone to pc.

    Check the system trey icons for a kies or nps icon, if there is one, ITS STILL RUNNING and flashing will not work, Unload kies or nps here too. (right click and kill connection monitoring)
     
  6. zman786

    zman786 Member
    Thread Starter
    15

    Jun 20, 2010
    15
    0
    15
    tried it with kies, this time only one driver gets installed (the usb component) and not the modem so odin wont recognise it (closed everything associated with kies)

    So guess i'll just wait for the official update
     
  7. XplosiV

    XplosiV Master X is Watching You
    313

    Jun 10, 2010
    5,422
    1,969
    313
    Male
    UK
    How long do you wait, after connecting the phone, and pressing odin's start button?
     
  8. zman786

    zman786 Member
    Thread Starter
    15

    Jun 20, 2010
    15
    0
    15
    the longest ive waited is 10 minutes. Should i have waited longer?
     
  9. XplosiV

    XplosiV Master X is Watching You
    313

    Jun 10, 2010
    5,422
    1,969
    313
    Male
    UK
    Na you only need to wait a few minutes. Still sounds like something is running that shouldn't be.
     

Share This Page

Loading...