1. Check out our companion app, Forums for Android! Download from Google Play

Support Galaxy S failed to convert to upgrade mode

Discussion in 'Android Devices' started by actionrag, Dec 6, 2010.

  1. actionrag

    actionrag New Member
    Thread Starter

    Dec 6, 2010
    Hi guys,

    Please help on this as i have spent hours on it and its driving me insane.

    So i am on uk '3' network today plugged my phone in to check if carrier had released update pretty much like i have done most days for the last month.
    Joy today as it flashed up can upgrade firmware




    Went through all the screens fine, Downloaded binary's fine moved to the next stage of starting update my screen on my phone got the little android guy with the shovel and said downloading,

    It sat at this screen for abit then comes up with the message "Failed to convert to upgrade mode, please try again later"

    i thought maybe just a glitch so tried again this time it said needs to be put in recovery mode and plugged back in, Right did that fine,

    Now in recovery mode just comes up with the box in kies waiting to connect and the thing swishing back and fourth.

    I have unplugged restarted my phone and used as normal so hasnt done anything but not updated firmware

    I am stuck i think i have tried everything

    Any help would be great




  2. dilapper

    dilapper New Member

    Dec 10, 2010
    hi actionrag

    I found your post through a google search as I am having the exact same problem.

    I did as you did, got the little green android dude and a message saying Downloading, and then it sat there for about 5 minutes before the Kies software said "Failed to convert to upgrade mode".

    I've just retried, and it looks like it worked. The only think I did differently to you is that when I did it the second time, I didn't click the Recover Firmware option. I just did a new firmware upgrade in the same way I did the first time.

    That has now worked. Don't know how reliable a solution that is - maybe I just got lucky - but hope that helps you (or anyone else searching for this problem!)
  3. pchenna

    pchenna New Member

    Dec 21, 2010
    I had exact issue with my Galaxy S.I almost tried 2-3 times to upgrade and it used to fail at the upgrade point saying "Failed to convert to upgrade mode".

    Then i reset my phone to factory settings and started the upgrade once again.It went smooth and no issues occurred.Now apps are running smooth without any issues.

    Seems some apps installed causes issues while upgrading.Try resetting to factory setting and upgrade.This might work.

    This is the solution just I tried and worked for me.

    Best luck for upgrade.
  4. simple

    simple New Member

    Feb 11, 2011
    Hi - having failed to upgrade my new Galaxy S twice - and got the message "Failed to convert to upgrade mode" from Kies. Tried the solution below - ie a factory data reset and it then upgraded fine. For newbies like me reading this post - the procedure is to go to Settings -> Privacy -> Factory data reset -> Reset phone -Erase everything. This did not erase pictures and music on the internal SD card - but it would be a wise to do a backup first. Following the upgrade everything seemed a bit slow, so I removed the battery, re-inserted it, and did a reset by pressing the volume, home and then power key simultaneously. Since then - everything has worked fine and some apps seem to work better. By the way, to get the Galaxy going again following a failed upgrade, pull the battery out and restart it.
  5. ezytalk

    ezytalk New Member

    Jul 5, 2011
    Dead Easy people - turn off your anti-virus - it's that simple.... Galaxy S2 now downloading updates as it should.... also check your firewall and maybe turn it off while you are updating firmware..... easy

Share This Page