1. Are you ready for the Galaxy S20? Here is everything we know so far!

Galaxy S II Won't Turn On!!! Only beeps!!!

Discussion in 'Android Devices' started by sluchy523, Jun 26, 2013.

  1. sluchy523

    sluchy523 Lurker
    Thread Starter

    My T-Mobile Galaxy SII has had some issues recently regarding booting and turning off.

    BACKGROUND:

    At first, it just started turning off for no reason.

    Then this past couple of weeks, it would turn off, and start vibrating constantly when charged. After fiddling with the buttons, it would eventually find itself into download mode and then later turn itself on.

    NOW:

    Yesterday morning, after several days of draining the battery to 0% (due to me solely charging it for an hour a day), the phone went dead. Then, that night, upon trying to charge it and turn it on, it remained stuck on a black screen. After taking out the battery, it would continuously beep. As soon as I put in the battery, it would become COMPLETELY unresponsive. After fiddling with it for over an hour, I put it down and slept.

    The next morning, I clicked the power button, and the phone flashed to the lock screen. It displayed 0%, but I think it showed a charging sign. I was thrilled, and used it for almost 2 minutes, before it again went completely black. This time the continuous beeping stopped, and it would only beep after holding the power button for around 5 seconds. It could beep regardless of whether the battery was out or not.

    After charging it all day, I found I could make it flash the Samsung logo for a fraction of a second after holding down both volume buttons and the power button. I looked it up, and supposedly it brings you to recovery mode, but I believe my phone is switching off immediately after bringing up the logo.

    I am going to leave it charging with my desktop, and would check back tomorrow morning.

    What I've Done:

    • Tried putting into Recovery Mode (unresponsive)
    • Tried putting into Download Mode (unresponsive)
    • Switched chargers (unresponsive)
    • Held power button (beeps)
    • Held both volume buttons and power button (beeps then quickly flashes samsung logo)
    • Cleaned off some of the micro usb lint with a tooth pick (coincided with the stopping of continuous beeping, not sure if it caused it)

    HELP WOULD BE GREATLY APPRECIATED!!!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. dontpanicbobby

    dontpanicbobby 100% That Guy
    VIP Member

    Welcome to the forums sluchy523. Try holding both volume buttons and the home button to do a factory reset. If that works but your still not getting past the Samsung logo try running ODIN on your PC to restore your S2 to a Stock ROM. Atma has posted a very useful guide which has helped a lot of people in situations similar to yours'; myself included. http://androidforums.com/samsung-galaxy-s2-t-mobile/628449-how-odin-any-stock-rom.html. I know you cannot get to your settings in the state your S2 is in but try it anyway. It worked on mine when I couldn't get past the Samsung logo.
     
    sluchy523 likes this.
  3. sluchy523

    sluchy523 Lurker
    Thread Starter

    Thanks dontpanicbobby for responding so fast.

    UPDATE: I was starting the process of the guide you linked to, and decided to hold down the power button (just to reassure myself of it still somewhat functioning), and it powered on for around ten seconds (!!!) . It got all the way to the end of the pink loading bar screen, but then beeped and restarted. The second time, it lasted only around three seconds, without even getting to the loading bar screen, before powering off. It is now completely unresponsive (very similar to this morning).

    It's not being detected by the computer. I'm going to go to sleep, and check back in the morning.

    P.S I've tried the factory reset, to no avail.
     
  4. dontpanicbobby

    dontpanicbobby 100% That Guy
    VIP Member

    Getting to factory reset is good. When you get the chance do the ODIN thing . Good luck, good night and sleep well.
     
  5. sluchy523

    sluchy523 Lurker
    Thread Starter

    It's still completely unresponsive, I'm going to switch it to a different charger (i.e not the pc).

    At this point I'm still not sure whether it's a

    - Power button issue
    - Micro USB Charging issue
    - Battery issue
    - Motherboard issue

    :(
     
  6. awoolf

    awoolf Newbie

    Your problem is almost certainly a bad power switch. See these threads:

    samsung galaxy s II won't turn on-vibrates | Support
    Blank Screen, Will not do anything except pulse... | Support
    http://androidforums.com/samsung-ga...nstant-reboot-vibrates-every-two-seconds.html
    http://androidforums.com/samsung-epic-4g-touch/720544-galaxy-sii-sph-d710-power-button-issues.html

    It's a VERY common problem on several Galaxy S2 models. (You can simulate the issue on a good T989 by holding down the power switch when you turn it on - it will sit there and vibrate every few seconds with a blank screen, until you release the power button)

    If you don't have insurance coverage and are out of warranty, you can replace the switch yourself. Several ebay sellers offer replacement power switches for the SGH-T989 Galaxy S2. (about ten bucks)

    Or, if you don't have mad soldering skills, you can ship it out to get fixed. Several sellers offer mail-in repair service:

    - $39 service & switch: Power Switch Repair Service T Mobile Galaxy S2 SGH T989 Samsung Fix Bad Button | eBay
    - $30 service only (switch sold separately): Galaxy SII S2 SGH T989 Tmobile Exclusive Repair Service for My Customers | eBay
    - $45 service & switch: Power Button Repair Samsung Galaxy s Galaxy s II Galaxy Note More | eBay
     
    chexny, sluchy523, Atma and 1 other person like this.
  7. dontpanicbobby

    dontpanicbobby 100% That Guy
    VIP Member

    Great research job awoolf! In your search did you come to a conclusion about a cause for the Power switch problem; That is to say were they shipped that way or was some type of physical accident usually involved? I know one of my co-workers whose an S2 user had that buzzing/restarting problem. He had banged his phone on a table trying to get a circuit board to set into place he told me. That cracked his screen and caused the buzzing/restarting problem. He just got a new phone instead of trying to fix the broken one. I have no idea what he thought he was doing.
     
  8. awoolf

    awoolf Newbie

    I believe they just wear out. I think my Sprint GS2's power button failed because of all the custom ROMs I was installing. (Which involved LOTS of "hold the button down while powering on") And my case was thick, requiring a lot of force to press the button.

    On some of the Sprint GS2 forums (on XDA, I think) they talk about cleaning the switch with contact cleaner, compressed air, and poking/squeezing it. I went ahead and just bought and soldered in a new switch, and I haven't had a problem since.
     
  9. sluchy523

    sluchy523 Lurker
    Thread Starter

    Bought a new power switch, going to try to replace it when it comes. Thanks guys.
     
  10. awoolf

    awoolf Newbie

    Be carefully while soldering. There are some TINY little resistors/capacitors right next to the power switch. Be sure to not knock them loose while you're replacing the switch.

    Good luck, and let us know how it turns out!
     
  11. gonesideways

    gonesideways Lurker

    Speaking as someone who was not careful, and did knock two of them out... Does anyone know what values these resistors / capacitors are?
     
  12. chexny

    chexny Newbie

    Has anyone used one of the repair services on Ebay? Any recommendations? My phone is have the exact same issue. I have never soldered anything before so I looking for a service.
     
  13. chexny

    chexny Newbie

  14. Bucove

    Bucove Lurker

    I suddenly acquired this problem today when I used a new HDMI adapter for the T989. I think it may be power related. The phone started working again when I booted it WITHOUT the 64gb micro-XD card. The power button still seems a little unstable, and I only just got it booted successfully about 30 minutes ago .. oops. there it goes again. I've already ordered the power switch from eBay. I've got the skills: I just hope it's not one of them little resistors of the three colors.
     

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...