1. Are you ready for the Galaxy S20? Here is everything we know so far!

Galaxy S phone won't connect to home wifi - intermittant

Discussion in 'Android Devices' started by Catfish, Feb 7, 2011.

  1. Catfish

    Catfish Well-Known Member
    Thread Starter

    Hi people,

    I have a Galaxy S I9000 in Australia running Froyo and it has a strange problem. Sometimes it will connect to my router's wifi fine, and then other times it refuses to connect. I have lived with it for about a month and found usually turning the router off and on fixes it, but recently this hasn't been and this morning I had the phone working on the wifi then suddenly it dropped off and couldn't connect on.

    All other wireless devices use the same router's wifi stably at all times.

    I have played with the settings on both the router and phone to try to correct it but nothing seems to help. I've tried:

    DHCP assigned IP
    Static IP
    Setting lease time on DHCP server on router to allow 1 week
    Added the phone's MAC address and gave it an IP in the DHCP server with a lease time of 1 week
    Removing network configuration from the phone and re-entering it
    Retyping (verifying) the password into the phone settings
    Security encryption types are the same on router and phone

    The strange part I don't get is that sometimes it works, sometimes it doesn't! Sometimes I can go a whole evening with wifi working, or even from late afternoon through to the next morning. Then other times it won't connect, it will drop the wifi off unexpectedly and not let it back on.

    My cousin's iPhone never has these issues, so I'm pretty sure its nothing to do with it being a phone and the router not liking it. I also have a laptop and Wii that connect through wifi flawlessly.

    Are there any known issues with Froyo and wifi that I don't know about? I am using a Billion BiPac 7402VGO router.

    PS: Another thing, I tell the phone to connect to the router, then it says "Obtain an IP address..." when it has this, I check the router's status for the DHCP or IP tables and I can see the router is acknowledging and assigning an IP for the phone because it's got an entry in it's status tables. So I am wondering if this is like an authorization acknowledgement failure the phone's side?

    1. Download the Forums for Android™ app!


  2. Catfish

    Catfish Well-Known Member
    Thread Starter

    all I get are *crickets chirping*?
  3. droid416

    droid416 Member

    I get this problem too and when I go to the wi-fi settings in the phone it says "error". I find that rebooting the phone helps.
  4. Catfish

    Catfish Well-Known Member
    Thread Starter

    i have also tried rebooting the phone and I don't thikn that has been working either. I was wondering if there have been any reports of problems with the wifi in 2.2 with certain routers or something. It seems strange to me that an entry appears in my router for the phone but the phone doesn't connect.
  5. alsterac

    alsterac Lurker

    I had a similar problem with my wifi until I downloaded the app "wifi fixer" and now it works like a charm. Give it a try.

Samsung Galaxy S Forum

Features and specs are not yet known.

Release Date

Share This Page