1. Download our Official Android App: Forums for Android!

Galaxy S2 - Can't type "I'm" in predictive text!

Discussion in 'Android Lounge' started by steve5312, Dec 8, 2011.

  1. steve5312

    steve5312 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 8, 2011

    Dec 8, 2011
    3
    0
    5
    Hi

    I use predictive texting and I have a load of custom words saved in the dictionary, as you do.

    However, no matter what I do I can't get it to recognise the word "I'm". I've hit "Add word", typed "I", gone to the symbols and typed an apostrophe, then typed "m", in the way you would expect to add a new word.

    Except the bloody thing won't recognise it! If I type "I'm" it doesn't offer it as an option.

    Anyone else have this issue? It's driving me insane, and it looks odd typing "I am" every time.

    cheers

    Steve
     

    Advertisement

  2. chanchan05

    chanchan05 The Doctor
    Rank:
     #25
    Points:
    1,108
    Posts:
    15,163
    Joined:
    Jun 30, 2011

    Jun 30, 2011
    15,163
    4,832
    1,108
    Male
    What keyboard are you using? In the built in Swype it should be no problem.
     
  3. steve5312

    steve5312 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 8, 2011

    Dec 8, 2011
    3
    0
    5
    I'm using the numeric keypad thing. force of habit...
     
  4. jerofld

    jerofld Fixing stuff is not easy
    Rank:
    None
    Points:
    313
    Posts:
    7,687
    Joined:
    May 10, 2011

    May 10, 2011
    7,687
    4,270
    313
    Male
    I fix stuff
    Over there <points>
    I don't have a GS2, but this should be pretty standard across the board:

    Push Menu button > Settings > Language & Keyboard > Select your keyboard > Edit personal dictionary.

    Or something along those lines. Make sure "I'm" is in there.
     
    mikedt likes this.
  5. 1873dave

    1873dave Lurker
    Rank:
    None
    Points:
    6
    Posts:
    1
    Joined:
    Dec 19, 2011

    Dec 19, 2011
    1
    1
    6
    I had the same problem mate, it was driving me insane as well. What to do is go to Settings > Language & Keyboard > Samsung Keypad > XT9 Advanced Settings > and make sure you tick the box next to Auto - Substitution. Scroll down to the bottom of the screen to XT9 auto-substitution, press that and you will see all your substitution words which are now active. You can also add more words to substitute if you want to. Hope this helps.
     
    Granite1 likes this.
  6. Granite1

    Granite1 Zercron Encrusted Tweezer
    Rank:
    None
    Points:
    833
    Posts:
    7,159
    Joined:
    Dec 27, 2010

    Dec 27, 2010
    7,159
    7,180
    833
    Male
    Highway Construction Inspection
    Pittsburgh, PA
    I have this same problem with "it's" on my OG evo. I get all kinds of weird things all the time! No matter how many times I edit my user dictionary it screws up. :mad::rolleyes:
     
  7. steve5312

    steve5312 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 8, 2011

    Dec 8, 2011
    3
    0
    5
    Hi

    Sorry, forget to ever check this after a week, and just found it again. I did what you suggested (auto-complete thingy) and it worked, so you have my eternal gratitude in the event you ever read this!

    Thanks

    Steve
     
  8. PsychoJim

    PsychoJim Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 26, 2012

    Apr 26, 2012
    1
    0
    5
    This was driving me nuts as well. Tried the proposed solution and it worked! Many thanks 1873dave!
     
  9. zuben el genub

    zuben el genub Android Expert
    Rank:
    None
    Points:
    443
    Posts:
    7,413
    Joined:
    Jan 24, 2011

    Jan 24, 2011
    7,413
    2,654
    443
    I use Super Keyboard, and it will do the same thing. In one case it was I'd and yesterday it simply had a fit with gmx. GMX is a mail service that I use and I was trying to type in my email addy. Super Keyboard insisted on GMC! I don't mind the suggestions, but don't correct unless I tell you to! (I don't have autocorrect enabled)
    I am also not making a custom dictionary just to suit an app.
     
  10. topteacher

    topteacher Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 15, 2012

    Nov 15, 2012
    1
    0
    5

    Thank you - thank you thank you:):):):):)
     

Share This Page

Loading...