1. Are you ready for the Galaxy S20? Here is everything we know so far!

Galaxy S2 wont communicate with ODIN

Discussion in 'Android Devices' started by cooket3, Dec 19, 2013.

  1. cooket3

    cooket3 Newbie
    Thread Starter

    Hi

    My Phone got stuck in a boot loop and needs to be fixed with a new Firmwire.

    I have downloaded the latest firmware but ODIN wont connect to my phone. I have tried the following versions of ODIN:

    Odin 1.83, 1.85, 3.04, 3.06, 3.07, 3.09 and they all can see the phone (where it is highlighted either blue or yellow. But when it comes to trying to put the new software on, ODIN gets stuck at the "Setup Connection" then fails. Below is an extract from ODIN

    <ID:0/007> Added!!
    <OSM> Enter CS for MD5..
    <OSM> Check MD5.. Do not unplug the cable..
    <OSM> Please wait..
    <OSM> I9100XWLSW_I9100XXMS2_I9100CPWLS4_HOME.tar.md5 is valid.
    <OSM> Checking MD5 finished Sucessfully..
    <OSM> Leave CS..
    <ID:0/007> Odin v.3 engine (ID:7)..
    <ID:0/007> File analysis..
    <ID:0/007> SetupConnection..
    <ID:0/007> Can't open the serial(COM) port.
    <OSM> All threads completed. (succeed 0 / failed 1)

    I have tried with the latest Kies installed and I have also tried with Kies uninstalled, as I have read some posts that it interferes.

    Is there another option I can use to try get ODIN to connect? Would it help If i uninstalled the Samsung USB Drivers?

    I have been trying for months to get my phone fixed. The battery is also fully charged and in download mode
     


  2. immortalneo

    immortalneo Member

    Start over from square one. Uninstall Kies and any Samsung USB drivers first. Reboot your system.

    Then either install Kies or Samsung USB drivers. If you are installing Kies, make sure you exit Kies from the task manager. Disable any antivirus or firewall too. Then fire up Odin, connect your phone in Download mode and flash.
     
  3. cooket3

    cooket3 Newbie
    Thread Starter

    Thanks

    Sorry its been a while, but ive been trying for ages every other day with out much success.

    Odin has since completed the first bit after connection but took hours, and started the cache.img or the next stage, however this took many hours before anything happened and I had to leave the PC on over night, which when I woke it had failed!

    Im assuming this process should not take hours like this. How long should it really be taking?
     
  4. lunatic59

    lunatic59 Moderati ergo sum
    Moderator


    10 ~ 15 minutes.

    Dodgy connections or failing USB ports can cause this sort of problem. Just to be clear, you are able to get your phone into download mode and when you plug it into your PC Odin will recognize that it's connected?

    I would try a.) a different cable; b.) a different USB port; c.) a different PC.
     
  5. ironass

    ironass Extreme Android User

    Extract from the Dummies Guide...

     
    lunatic59 likes this.
  6. cooket3

    cooket3 Newbie
    Thread Starter

    Yes I can get it into download mode and ODIN recognises it. Ive tried a few different cables and the USB Ports. My PC is old enough to be a grandad now, and i think all the USB ports are 1.0! Plus its super slow. I am hopefuly getting a new PC soon so will try it on there too. I have also tried it on my works PC
     
  7. cooket3

    cooket3 Newbie
    Thread Starter

    Thanks Ironass, but cannot even access my phone go into debugging mode. The rest I can do
     
  8. cooket3

    cooket3 Newbie
    Thread Starter

    Just retried ODIN and now i got a result back within seconds!

    Just a shame its the fail

    <ID:0/004> File analysis..
    <ID:0/004> SetupConnection..
    <ID:0/004> Initialzation..
    <ID:0/004> Get PIT for mapping..
    <ID:0/004> Firmware update start..
    <ID:0/004> SingleDownload.
    <ID:0/004> boot.bin
    <ID:0/004> NAND Write Start!!
    <ID:0/004> cache.img
    <ID:0/004>
    <ID:0/004> Complete(Write) operation failed.
    <OSM> All threads completed. (succeed 0 / failed 1)
    <ID:0/004> Removed!!

    When I first plugged in the phone the PC recognised it and said it was installed ready for use, but straight after the fail my pc said my phone was unrecognisable and not installed properly.

    Any more suggestions? Ill keep trying too
     
  9. ironass

    ironass Extreme Android User

    I'm afraid that unless debugging mode is enabled, you will not be able to flash using Odin.
     
  10. cooket3

    cooket3 Newbie
    Thread Starter

    Oh dear thats not good news!

    Do I have any options to fix this boot loop or issue?

    Thanks
     
  11. ironass

    ironass Extreme Android User

    If you can boot into Recovery mode you could select to Wipe cache partition. Alternatively, you could do a Factory Reset to see if that helps.
     
  12. cooket3

    cooket3 Newbie
    Thread Starter

    Assuming boot recovery is volume up, home and power this doesnt work. How do you factory reset the phone?

    Volume down + power, and volume down + home + power puts my phone into download mode, which is different to youtube vids ive seen.

    I miss the good old days when you just needed something pointy to press a hidden button to reset things!

    Thanks
     

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...