Andarthiel

Lurker
Feb 14, 2011
9
0
5
Have an annoying problem with my S3 and it has to do with the 4.3 update as a quick Google Search reveals. Randomly it just loses all signal and gives me the "No Service" error especially when I activate mobile data. Also it drains the battery way quicker than what it used to. I've tried the solutions that have worked for some people like turning off account sync and removing Google Services app(which wasn't installed on my phone in the first place) but nothing worked. I realise that I can just go back to previous versions using ROMs and Clockword Mod etc but I got this phone with a plan and am still paying it off so I don't want to break any warranties with my phone company. Anyone got any solutions that can fix it without ROMs?
 
Didn't work :/
I'm starting to think that it could be an issue with the phone itself or the battery because the screen keeps flickering, keeps trying to shut itself down and when it's on charge it comes off charge randomly and I have to jiggle the cable to get it to charge it again.