1. Are you ready for the Galaxy S20? Here is everything we know so far!

Gallery - Unable to share with Picasa - Keeps asking to sign in?

Discussion in 'Android Apps & Games' started by victorhooi, May 31, 2010.

  1. victorhooi

    victorhooi Lurker
    Thread Starter

    heya,

    I have a Nexus One, with Android 2.2. I'm trying to use the inbuilt Gallery app to upload photos to Picasa.


    However, when I select a photo to share with Picasa, it flashes quickly past a Picasa screen (I think it said something about names, and albums), and goes directly to a "Add a Google Account" page.


    After that I'm presented with an option to create a google account, or sign in to an existing account. However, if I try to sign in, it reports I'm already signed in to that account (since I've already added and synced to that account on my phone).


    I'm able to upload photos to Picasa on my normal desktop computer quite well via my browser.


    Has anybody else experienced any problems with the Gallery and Picasa on Android? Any tips?


    Thanks,
    Victor
     


  2. Mr Sworld

    Mr Sworld Newbie

    I'm getting the same problem. Can anyone help?
     
  3. bluenova

    bluenova OK Computer

    Are you using a Google apps for your domain account and a normal Google account with the same email address? That can cause problems, I'd suggest setting up a standard @gmail.com account for use with Picasa and other normal Google services that cannot be used with GAFYD.
     
  4. Mr Sworld

    Mr Sworld Newbie

    I run a gmail account as my standard account for everything. What do you mean by Google apps for your domain account?

    I'm trying this on a Desire BTW.
     
  5. applejosh

    applejosh Newbie

    Google Apps account is normally where you host a personal/business domain's email service (and other services) on Google. So your Google logon would be something like user@personaldomain.com instead of user123@gmail.com. The former has issues with some services (Picasa may be one of them, and Voice is another - Google has not made all of it's "cloud" services available using a Google Apps logon). I think bluenova was alluding to this.
     
  6. Mr Sworld

    Mr Sworld Newbie

    Ah... I get it.

    No, I'm not using anything else but a gmail account. When I go to the 'accounts and sync' section there is only options to sync the calender, contacts and mail under the google sync, there isn't an option for picasa.

    I've heard that a hard reset may help here but I'd prefer not to have to do this if possible.
     
  7. Zmydust

    Zmydust Newbie

    Same problem on my nexus. I have to setup a seperate gmail account just to use picasa????
     
  8. andrej2k

    andrej2k Lurker

    Have the same issue with HTC Desire
     
  9. Mr.Shaky

    Mr.Shaky Lurker

    Same issue on HTC EVO. Using a standard @gmail.com account, and only can sync contacts, calendar and mail.
     
  10. carakdae

    carakdae Lurker

    Same issue here on HTC EVO. Anytime I try to share using Picasa it shows a screen to add a caption and other Picasa info for a split second and then goes to the Adding an Account wizard. If I choose Already have a Google Account and sign in it just takes me to the Sync screen. Going back just takes me back to the gallery and I can never get to the Picasa upload page. I even created a second Google account and it still does the same thing. Picasa is the only one that does this. Facebook, Flickr, etc all work fine.
     
  11. Braaainz

    Braaainz Android Enthusiast

    Yup same thing here with my Evo. Can't upload to Picasa. Very frustrating.
     
  12. J.Stone

    J.Stone Newbie

    Same issue here... still no fix?

    I have found a workaround: the Picasa Tool Pro app. It's a bit of a pain to have to upload using a separate app, but at least now I can get my geotagged photos uploaded and into Google Earth.
     
  13. adamspt2

    adamspt2 Lurker

    I understand that there's a bug with the single photo upload. However, is there no way to tell the Gallery (HTC Evo) to automatically sync with Picasa? That seems a huge oversight unless I'm just missing something.
     
  14. BBuff

    BBuff Lurker

    I have the same problem too. Droid X
     
  15. elegante

    elegante Lurker

    I have the same problem too on mytouch slide. any ideas or any help would be greatly appreciated.
     
  16. BBuff

    BBuff Lurker

    This problem was fixed for me with the Motorola update on the 19th.
     
  17. apsen03

    apsen03 Lurker

    I was able to get this fixed on my Droid running Froyo 2.2.

    1. Change Google account password from PC, and ensure you have a secondary email listed on your account (other than primary gmail account)
    2. Settings -> Acount -> select Google account and choose sync now from menu (a notification should appear that account needs to be updated)
    3. open gallery, choose picture and select share -> Picasa
    4. When prompted, enter alternate email and Google account password, follow prompts to finish syncing (it will appear like nothing happened)
    5. Select update account form notification window, and update with new password
    6. open gallery and share picture to picassa again, when prompted enter alternate email and password again, and then you will be able to upload pictures.

    You can change your password back once you are able to upload.
     
  18. cassandraj

    cassandraj Lurker

    Aspen, that didn't work for me.

    When I try to upload from the Gallery, it will take me to "Upload Details" and I can enter my username (choose from a drop-down that only has one choice) and the album (from a drop-down that never seems to load..?). Then when I click Upload, the message I see says, "Failed to Retrieve Account Information".
     
  19. idcool

    idcool Lurker

    Same problem here too using HTC Desire Android 2.2

    I am using the default xxxx@gmail.com account as my main account on the phone.

    Any fixes yet?
     
  20. bfaridnia

    bfaridnia Newbie

    bump please. same issue on Droid X and NO WHERE is there a fix that works!?!

    Comon, there has to be something out there.
     
  21. OC Taco Lover

    OC Taco Lover Lurker

    Any updates 1 month later? This previously worked on my Fascinate but now I have the same issue as the rest of you. Frustrating...
     
  22. uribees

    uribees Lurker

    Root your phone. Use program like Root Explorer, go to root, open Data folder, then System folder. Delete the file "Accounts.db". Then reboot your phone. It will have you reinput your account info, this goes for all different accounts on your phone. You should have no problems with your picasa after that. It worked for me.
     
  23. ohadfreund

    ohadfreund Member

    Try picasaweb.google.com log in with the same gmail account you use on your phone.
    Then try to share from your phone.
     
  24. taochok

    taochok Lurker

    Same problem in xoom android 3.01
    Working in galaxy s i9000 android 2.3.4
     
  25. newguy05

    newguy05 Lurker

    Same problem on verizon droid charge running 2.2

    Comeon google, it's been 1 year already, do something wtf....
     
Loading...

Share This Page

Loading...