1. Are you ready for the Galaxy S20? Here is everything we know so far!

Getting an error when running the android "Hello World" tutorial

Discussion in 'Android Development' started by pransome, Dec 30, 2009.

  1. pransome

    pransome Lurker
    Thread Starter

    I have followed the instructions for the "Hello World" tutorial at
    Hello, World | Android Developers
    It all builds as expected, but when I run the application I get ...

    [2009-12-30 14:26:09 - Android Hello World]Waiting for HOME
    ('android.process.acore') to be launched...
    [2009-12-30 14:26:11 - Emulator]
    [2009-12-30 14:26:11 - Emulator]This application has requested the
    Runtime to terminate it in an unusual way.
    [2009-12-30 14:26:11 - Emulator]Please contact the application's
    support team for more information.
    [2009-12-30 14:26:11 - Android Hello World]emulator-5554 disconnected!
    Cancelling 'rnt.android.learning.hello activity launch'!

    I am using the Eclipse IDE with the ADT plugin, etc.
    I am doing this on a laptop running MS Windows XP Professional OS

    I have done some google searches on this problem and haven't found a
    solution for my particular circumstances.
    Can anyone suggest what might be going on?


  2. pransome

    pransome Lurker
    Thread Starter

    I went back and went through the "Hello World" tutorial again, this time selecting the most recent target and a corresponding AVD and everything worked as expected. I have no idea why. :thinking:
  3. drollins

    drollins Lurker

    OK - I also had the dreaded "emulator-5554 disconnected" issue and have confirmed, at least on my set up (XP Pro etc) that the Android 1.5 emulator with Eclipse simply does not work.

    I can successfully target any Android platform as long as my emulator is V2.0 or greater.
  4. ttaylor0024

    ttaylor0024 Android Enthusiast

    I have a problem when running the "Hello, World" tutorial as well...

    I get this
    or this
    When I should get this

    I am getting really frustrated... Help?
  5. KeithG

    KeithG Well-Known Member

    start the AVD and wait for it to finish booting before doing anything.

    Once you get to the android desktop on the virtual device. Switch back to eclipse and "run"
  6. ttaylor0024

    ttaylor0024 Android Enthusiast

    Ok. I just created a new AVD, now how do i open it? I just downloaded this stuff the other day, got frustrated and quit. Now I would like to start again...

    Thanks for the help!
  7. KeithG

    KeithG Well-Known Member

    Run the Avd manager from eclipse. Its an icon on the tool bar, or you can get at it from a drop down menu (window maybe? I'm on my phone so I can't check).

    After the avd manager is running create a virtual machine that matches the sdk level of your application.

    Select the vm and then hit the start button. Wait for the vm to fully load before continuing. Once its loaded switch back to eclipse and run your app.
    Oaff likes this.
  8. ttaylor0024

    ttaylor0024 Android Enthusiast

    Ok. I open the AVD manager, click on my AVD and press start and still the same screen with "Android" written on it...
  9. KeithG

    KeithG Well-Known Member

    how long are you waiting?

    The emulator can take quite a long time to boot up. Especially on older hardware.

    The other solution is to run adb logcat during the emulator boot process to see how its progressing and if its had a fatal error.

    You may want to delete that AVD and recreate a new one.
  10. imrdy

    imrdy Lurker

    >>The other solution is to run adb logcat during the emulator boot process to see how its progressing and if its had a fatal error.

    My problem was not waiting long enough for the emulator to start up. Watching the adb logcat showed that stuff was happening in there, I just needed to be a little more patient.:eek:

    In my case I started the emulator from the Eclise Android SDK and AVD manager, then when it was loaded I ran the hello world app.
  11. Alonski

    Alonski Newbie

    Yea its pretty annoying having to wait so long for it to load up but... Try starting up your android phone... It probably takes a long time too =D Anyways if you have your own phone then just debug on it I find that easier.
  12. swiftwood

    swiftwood Lurker

    Been getting my Droid to work with Eclipse on Ubuntu this weekend

    I've tried using the emulator, but unfortunately it takes FOREVER to come up, like 6 hours

    fortunately I can get it to upload and run directly onto my phone, so it's not really a problem.

    The funny part is that the phone doesn't show up under file manager like a regular USB device
  13. ddentrec

    ddentrec Lurker

    Hello everyone,

    My first post on behalf of my 10 year old son: He too is getting the 'emulator-5554 disconnected! Cancelling' error after following the Eclipse/SDK/Android installation on XP to the letter.

    What is appararent to me is that the Eclipse/SDK/Android installation has not been fully tested before release to the public: this is unacceptable in my view. Its like running buggy Slackware Linux from the 1990s! Has Google really invested so much in something that cannot even run 'Hello World!' in Eclipse!??

    Can someone please advise how to fix this error permanantly before my son gives up on Android before he has even started? Sorry to sound so frustrated but you should see how disappointed he is after spending 5 hours trying to get it to work!!
  14. psalm1975

    psalm1975 Lurker

    okay I am new to this.. but it did take me a while to figure.
    first, the AVD (Virtual device) does takes quite a while to boot up.
    during bootup, all you see is an android logo/world (Depending on the API you are using).

    But with API 8, following the hello world guide.
    It took the AVD about 5min on my machine to bootup.
    then you can see the hello world demo working.

    Good luck
  15. Oaff

    Oaff Lurker

    It took about 10 min to load up the hello android program on my laptop. Thanks for the help. I was getting a little frustrated with it.
Similar Threads - Getting error running
  1. anwartan
  2. Ahmed Hisham
  3. Mikul Patel
  4. Mikul Patel
  5. nagamothu
  6. iacoposk8
  7. Dronzzy
  8. Neha badole
  9. Evan McClure
  10. zz77

Share This Page