1. Download our Official Android App: Forums for Android!

Root Getting Flash Player to work on CM7

Discussion in 'Android Devices' started by Fruban, Sep 15, 2011.

  1. Fruban

    Fruban Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    78
    Joined:
    Mar 16, 2011

    Mar 16, 2011
    78
    7
    16
    Male
    So I've read some people have no issue with Flash Player 10.3 on their CM7. I installed CM7 yesterday after some trouble, and once I fixed the issue with Yeahha's help (thanks again!) it was working fine. Even my GPS picked up quickly! However, the only gripe I have so far is that my Flash Player isn't working.

    I just need some help implementing this fix: Fix for Flash 10.3 on CM7 - CyanogenMod Forum

    I'm not sure where to start, really. Using File Manager I couldn't find the specified path, nevermind figure out how to adjust permissions. Some (patronizingly detailed) help would be appreciated! :D


    PS - I'd like to get it to work with Dolphin HD browser and Skyfire as well.
     

    Advertisement

  2. Yeahha

    Yeahha Usually off topic
    Rank:
    None
    Points:
    813
    Posts:
    10,472
    Joined:
    Jul 29, 2010

    Jul 29, 2010
    10,472
    4,693
    813
    ...
    FG
    Get root explorer from the market and you will be able to find the path and change permissions in root explorer with a long press on the file then choose permissions.

    Edit: I think skyfire is highly based on the stock browser and reliant on it so I would think it will also work for skyfire, if you want flash video with skyfire press menu while on the page and then press video it will scan the page and load the video that is there and give a popup, press the popup and it will launch the video full screen.
     
  3. WormDoes

    WormDoes Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    3,199
    Joined:
    Aug 8, 2010

    Aug 8, 2010
    3,199
    1,270
    313
    Sales
    Massachusetts
    I wasn't able to get it to work on CM7, but I'm running a CM based ROM right now and got it to work on Dolphin. If you go into Dolphin settings and change "user agent" to desktop flash will work.
     
    Fruban likes this.
  4. Yeahha

    Yeahha Usually off topic
    Rank:
    None
    Points:
    813
    Posts:
    10,472
    Joined:
    Jul 29, 2010

    Jul 29, 2010
    10,472
    4,693
    813
    ...
    FG
    You should be able to change the user agent in the stock browser too, not sure if it will have any effect but it is something you could try.
     
  5. Fruban

    Fruban Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    78
    Joined:
    Mar 16, 2011

    Mar 16, 2011
    78
    7
    16
    Male

    I'm seeing that Root Explorer is a paid app... Until I find a job I can't spend any money right now, is there a free app that essentially does the same thing?


    And Wormdoes, thanks for that tip, because I knew skyfire had settings for websites to detect my device as a desktopm but I didn't realize dolphin did too. I guess I just need to get flash working for Dolphin then. Previously, some websites (like Colbert Report and Daily Show) did not allow themselves to play on a mobile device, so I used the skyfire browser with its ability to switch at the top between android and desktop mode to play full episodes from there.

    Now on Dolphin, while I can see the flash player plugin icon, when I tap it I still get a black screen where the video should be, but I can hear the sound.
     
  6. Yeahha

    Yeahha Usually off topic
    Rank:
    None
    Points:
    813
    Posts:
    10,472
    Joined:
    Jul 29, 2010

    Jul 29, 2010
    10,472
    4,693
    813
    ...
    FG
    ...I am not sure about other root file explorers I think super manager has a file explorer in it but I don't know how it works or if it can change permissions. You may also be able to chmod the file in terminal emulator (free on market)

    open terminal and type the following without the quotes
    "su"
    "chmod 000 /data/data/com.android.browser/app_plugins/com.adobe.flashplayer/.macromedia/Flash_Player/config.data"

    then press back to exit terminal
    press enter after su and it will prompt for superuser access, the second command is removing all permissions from the file press enter after the second command
     
    Fruban likes this.
  7. WormDoes

    WormDoes Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    3,199
    Joined:
    Aug 8, 2010

    Aug 8, 2010
    3,199
    1,270
    313
    Sales
    Massachusetts
    Amazon App Store has Root Explorer for $0.99 right now. I know you can afford that :)
     
    Fruban likes this.
  8. Fruban

    Fruban Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    78
    Joined:
    Mar 16, 2011

    Mar 16, 2011
    78
    7
    16
    Male

    To fix Dolphin Browser HD, I ended up downloading "File Expert" (for free) which had root access and the ability to change permissions, and navigated with that file manager to /data/data/mobi.mgeek.TunnyBrowser/app_plugins/com.adobe.flashplayer/.macromedia/Flash_Player/config.data

    Edit: Wormdoes, thanks anyway for finding that deal, but I had already found File Expert, fixed the issue, and started a post about it before seeing your post! :p

    For anyone else who reads this to find a fix:

    I just had to go into the file manager's settings and enable root access stuff (Menu>More>File Explorer Settings>Check the box at the bottom for Root Explorer), hit the "back" button in the app itself a few times (not the phone's back button) to get to the first "data" folder, navigated to the config file as per the file address above, long pressed the config.data file to bring up options, then went to File Operations>Permission and then unchecked all the permission boxes. Loaded up Dolphin HD (after following Wormdoes' advice about changing the user agent) and was able to watch flash videos without a hassle! :D

    Edit2: Could this be added to a sticky as a HOW TO for people with this issue? Seem to be fairly common, and flash 10.3 is acknowledged as an issue on the CM7 OP... just a suggestion.

    Just a side note, I could not find the path for the stock browser as indicated above because app_plugin was missing. I'm not sure why it didn't create this directory when I tried to access flash on the default browser. Anyway, it works for Dolphin HD which is a great browser.
     
  9. WormDoes

    WormDoes Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    3,199
    Joined:
    Aug 8, 2010

    Aug 8, 2010
    3,199
    1,270
    313
    Sales
    Massachusetts
    Crap, now Flash Player isn't working for me. I installed the modded 10.3 apk floating around xda and have Dolphin settings changed to desktop. I also removed the permissions from the data/data file, but the video I'm trying to watch on espn doesn't play. It doesn't even start it just sits at a black screen stuck on 0:01 :thinking:
     
  10. Yeahha

    Yeahha Usually off topic
    Rank:
    None
    Points:
    813
    Posts:
    10,472
    Joined:
    Jul 29, 2010

    Jul 29, 2010
    10,472
    4,693
    813
    ...
    FG
    Have you tried 10.2? Or a reboot after changing permissions, I don't think you normally need a reboot when changing something in /data but it couldn't hurt
     
  11. WormDoes

    WormDoes Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    3,199
    Joined:
    Aug 8, 2010

    Aug 8, 2010
    3,199
    1,270
    313
    Sales
    Massachusetts
    Tried 10.3 after a reboot, nothing. Same with 10.2. I don't even use Flash that often, but just the fact that it's not working gets under my skin. I know it's going to bother me until I figure this out :mad:
     
  12. Yeahha

    Yeahha Usually off topic
    Rank:
    None
    Points:
    813
    Posts:
    10,472
    Joined:
    Jul 29, 2010

    Jul 29, 2010
    10,472
    4,693
    813
    ...
    FG
    This is the reason I hate flash
     
  13. Fruban

    Fruban Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    78
    Joined:
    Mar 16, 2011

    Mar 16, 2011
    78
    7
    16
    Male
    I'm actually just using the 10.3 downloaded from the market. Just because I haven't seen you mention it, though I'm guessing you have, have you tried playing a variety of flash vids? Some sites seem to work better than others, and the longer the video the more finicky it may be.

    Although I can play flash now, when I watch something with intermittent commercials, sometimes the video gets messed up.
     
  14. mudking

    mudking Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    136
    Joined:
    Mar 12, 2011

    Mar 12, 2011
    136
    6
    36
    I just updated to RC1.8 and no flash!!!! I tried to follow the two paths recommended here to find the files to change permissions on, and I don't have either files at those paths. Is there somewhere else I can find these files?

    Edit to be more specific:
    I can navigate to
    /data/data/com.android.browser then there is no /app_plugins
    and
    /data/data/mobi.mgeek.TunnyBrowser/app_plugins but then no com.adobe.flashplayer

    I do have /data/data/com.adobe.flashplayer but then nothing in there except /lib

    Am I missing something here? I just bought root explorer specifically for this purpose, so maybe I don't know how to use it, but it seems pretty straight forward for navigating directories.
     
  15. Yeahha

    Yeahha Usually off topic
    Rank:
    None
    Points:
    813
    Posts:
    10,472
    Joined:
    Jul 29, 2010

    Jul 29, 2010
    10,472
    4,693
    813
    ...
    FG
    You need to use a file explorer such as root explorer to access those, non-root file explorers will not have permission to view those paths.
     
  16. mudking

    mudking Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    136
    Joined:
    Mar 12, 2011

    Mar 12, 2011
    136
    6
    36
    Edited to add that I am using root explorer. See edit
     
  17. Yeahha

    Yeahha Usually off topic
    Rank:
    None
    Points:
    813
    Posts:
    10,472
    Joined:
    Jul 29, 2010

    Jul 29, 2010
    10,472
    4,693
    813
    ...
    FG
    I don't have 1.8 downloaded on my phone or flashed currently so I can't check it currently. I've got the rom on my PC at home I can look into it later tonight if you can't get it fixed by then. Have you tried a different version of flash??
     
    mudking likes this.
  18. Ibrick

    Ibrick Android Expert
    Rank:
    None
    Points:
    93
    Posts:
    983
    Joined:
    Feb 21, 2011

    Feb 21, 2011
    983
    208
    93
    Banking
    Milwaukee

    Weird, I just tried 10.3, with and without changing permissions and it worked fine both ways.

    Did you wipe browser cache? Then force close it?

    I ran every flash test I could find and it plays fine, sound is fine.

    I did format system, wiped cache, and dalvik before flashing 1.8. Not sure if that has anything to do with it?
     
    mudking likes this.
  19. mudking

    mudking Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    136
    Joined:
    Mar 12, 2011

    Mar 12, 2011
    136
    6
    36
    FIXED!!!

    Ibrick, thanks for telling me to clear browser cache. I was force stopping dolphin through settings>applications>manage applications>force stop. When you said to clear the cache, I looked looked around because I didn't actually know how to clear the dolphin cache! So, I learned that you must long hold the back button while in dolphin and the force exit/empty cache menu comes up. This was the trick to it! As soon as I properly stopped the browser, the file was at the correct path. I did both the one in the fix and the TunnyBrowser. Flash is working in dolphin now!

    Thanks so much for the help Yeahha and Ibrick!
     
  20. mudking

    mudking Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    136
    Joined:
    Mar 12, 2011

    Mar 12, 2011
    136
    6
    36
    Oh crap, now I am trying to do the same thing on my wife's phone and I can't find the directories again. I cleared the cache in dolphin like I did before, but I guess that wasn't the trick. It must have been something else that made it work. I have done everything the same as I did on mine and the directories just aren't there. This is really annoying.
     
  21. Familyguy1

    Familyguy1 Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    580
    Joined:
    May 9, 2010

    May 9, 2010
    580
    21
    63
    Gallatin, TN
    Flash has been working fine for me. Using DB HD
     

Share This Page

Loading...