1. Download our Official Android App: Forums for Android!

Root Gingerbread OTA/Leak dropping wifi

Discussion in 'Android Devices' started by lexluthor, Apr 20, 2011.

  1. lexluthor

    lexluthor Android Expert
    Thread Starter
    Rank:
    None
    Points:
    283
    Posts:
    4,161
    Joined:
    May 15, 2010

    May 15, 2010
    4,161
    402
    283
    Long Island, NY
    I'm running the 2nd gingerbread leak.

    I find that my internet connection on wifi sites dies occasionally. Wifi still shows as on and connected, but I cant ping anything. If I cycle wifi off and back on, I'm good again.

    I did have a data wipe in the process of installing, but wifi settings did get automatically reloaded through the google cloud backup.

    One of the wifi points that's I'm dropping from is totally new to my device (never had before gb).

    Definitely not a router issue as it happens at 3 different locations.

    Does the happen to anyone else. Any ideas on thing I can try?
     

    Advertisement

  2. PACAnesFan

    PACAnesFan Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    201
    Joined:
    Nov 22, 2010

    Nov 22, 2010
    201
    12
    38
    Happens to me as well. This happened on the first GB leak too. I did have the occasional Froyo drop as well.

    I've concluded it is probably my old as time router. My X is rock solid at work. Motorola is aware of these problems in the X from the Froyo days and has pushed fixes out with subsequent updates. When I got Froyo, my X did run very well on WiFi.

    Interestingly enough, my Xoom has the exact same problems. Fine at work; bad at home.

    I guess we will have to wait and see if the true OTA fixes it, or someone else comes up with a fix in a ROM. Or else I will just have to buy a new router. It's probably about time anyway.
     
  3. alprazolam

    alprazolam Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,722
    Joined:
    Dec 31, 2009

    Dec 31, 2009
    1,722
    194
    143
    Same problem here though sometimes it just flat out won't connect to the router. Everything else in my house will connect to it and retain a connection.
     
  4. lexluthor

    lexluthor Android Expert
    Thread Starter
    Rank:
    None
    Points:
    283
    Posts:
    4,161
    Joined:
    May 15, 2010

    May 15, 2010
    4,161
    402
    283
    Long Island, NY
    Well I never dropped on froyo and I have the issue on 3 different routers, so sounds different than your issue. Anyone else seeing what I am?

    Is there a wa, using titanium, to just wipe out my wireless settings? I doubt it would help, but couldn't her.
     
  5. lexluthor

    lexluthor Android Expert
    Thread Starter
    Rank:
    None
    Points:
    283
    Posts:
    4,161
    Joined:
    May 15, 2010

    May 15, 2010
    4,161
    402
    283
    Long Island, NY
    Did this only start on gb for you? If not, probably a different issue.
     
  6. alprazolam

    alprazolam Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,722
    Joined:
    Dec 31, 2009

    Dec 31, 2009
    1,722
    194
    143
    You know, I use another router and don't lose connection so it probably is my home router. I think that my phone just flat out doesn't get along with my old POS Dlink router. I left my super solid netgear with my ex.
     
  7. PACAnesFan

    PACAnesFan Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    201
    Joined:
    Nov 22, 2010

    Nov 22, 2010
    201
    12
    38
    As an aside, for any that are reading this thread, has anyone ever flashed DD-WRT? My router is an ancient Linksys WRT54G. I wonder if new and improved firmware would fix some of the issues? The router has long been out of support (around 2007 I believe).
     
  8. lexluthor

    lexluthor Android Expert
    Thread Starter
    Rank:
    None
    Points:
    283
    Posts:
    4,161
    Joined:
    May 15, 2010

    May 15, 2010
    4,161
    402
    283
    Long Island, NY
    Can you please start a new thread for that?

    Any further comments on my issue are appreciated.
     
  9. kastleberg

    kastleberg Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    577
    Joined:
    Jul 15, 2010

    Jul 15, 2010
    577
    207
    93
    Richmond, VA
    I have this issue as well, both at home and work. I have resigned myself to not using wifi waiting for a fix. Googled it a few times, not a lot of it out there, but notice there seems to be a fair amount of people who have this issue too.

    Is there any way to port the wifi from froyo to work with GB?
     
  10. lexluthor

    lexluthor Android Expert
    Thread Starter
    Rank:
    None
    Points:
    283
    Posts:
    4,161
    Joined:
    May 15, 2010

    May 15, 2010
    4,161
    402
    283
    Long Island, NY
    Is there maybe some way to clear wifi data using titanium and then rebuild it all?
     
  11. jimmy_r

    jimmy_r Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 29, 2011

    Apr 29, 2011
    1
    0
    5
    I'm having the same problem. Droid X, rooted GB. Froyo was rock solid on this handset. GB wifi icon turns from blue to white and drops the connection as often as once per minute. Downloading files causes the most trouble. The browser seems slightly more stable. I'm not convinced that changing router settings to WEP is a real solution since Froyo had no issue with WPA.

    Mad props to anyone with a fix.
     
  12. lexluthor

    lexluthor Android Expert
    Thread Starter
    Rank:
    None
    Points:
    283
    Posts:
    4,161
    Joined:
    May 15, 2010

    May 15, 2010
    4,161
    402
    283
    Long Island, NY
    I sure hope this is something that gets fixed in final. It's a really bad problem.
     

Share This Page

Loading...