1. Check out our app, Forums for Android! Download and leave feedback here!

Support GMail app refuses to send mail.

Discussion in 'Android Devices' started by mrk, Jun 26, 2010.

  1. mrk

    mrk Well-Known Member
    Thread Starter
    68

    Apr 20, 2010
    475
    135
    68
    Intern w/ UTeach
    Austin, TX.
    I've already cleared application data and cache. What the hell? :\

    This is a huge deal for me.
     

    Advertisement

  2. htcevolee

    htcevolee Well-Known Member
    73

    Jun 10, 2010
    255
    56
    73
    IT Engineer
    Cali
    Delete the account and remake it? Did you change any settings that could have caused it? Was it working before? Possibly settings on your GMAIL account you might have to change via the web interface.
     
  3. mrk

    mrk Well-Known Member
    Thread Starter
    68

    Apr 20, 2010
    475
    135
    68
    Intern w/ UTeach
    Austin, TX.
    Can't delete the account without completely wiping all personal data from the phone, unfortunately (and stupidly). It worked before--the only change I made was nandroid-restoring to Fresh .3 from NonSense. It had worked at the time of backup, and I believe that it worked while using NonSense. Didn't change anything on the desktop client.

    Further, when I say that it refuses to send, I mean to say that it just says, "Sending..." and then never does.
     
  4. htcevolee

    htcevolee Well-Known Member
    73

    Jun 10, 2010
    255
    56
    73
    IT Engineer
    Cali
  5. mrk

    mrk Well-Known Member
    Thread Starter
    68

    Apr 20, 2010
    475
    135
    68
    Intern w/ UTeach
    Austin, TX.
    Yes, I understand how to remove an account. As I said, the account "is required by some applications" and I "can only remove it by resetting the phone to factory defaults (which deletes all [my] data."
     
  6. mrk

    mrk Well-Known Member
    Thread Starter
    68

    Apr 20, 2010
    475
    135
    68
    Intern w/ UTeach
    Austin, TX.
    Can anybody think of anything else? I'm probably going to wind up completely wiping all personal data and potentially trying DC... but I don't really have the time to play with that right now :\.
     
  7. dahray02

    dahray02 Member
    16

    May 30, 2010
    21
    3
    16
    do you have auto sync check....i had it uncheck and i couldnt send emails...once i checked it all was good
     
  8. mrk

    mrk Well-Known Member
    Thread Starter
    68

    Apr 20, 2010
    475
    135
    68
    Intern w/ UTeach
    Austin, TX.
    It was on, and I turned it off and on to check. Still no dice. however, it may be related, because mail that I've read on my phone doesn't show as read on my desktop.
     
  9. htcevolee

    htcevolee Well-Known Member
    73

    Jun 10, 2010
    255
    56
    73
    IT Engineer
    Cali
    go to Settings
    Accounts and sync
    unchckec Auto-sync
    uncheck Background data

    then re-check backgroun data
    recheck auto-sync
    then press sync all at the bottom

    and test again
     
  10. mrk

    mrk Well-Known Member
    Thread Starter
    68

    Apr 20, 2010
    475
    135
    68
    Intern w/ UTeach
    Austin, TX.
    That is exactly what I did before, but this time it worked. Interesting, thanks much.
     
  11. mrk

    mrk Well-Known Member
    Thread Starter
    68

    Apr 20, 2010
    475
    135
    68
    Intern w/ UTeach
    Austin, TX.
    Aaaaand, it's happened again. Aforementioned fix won't solve it, now. This really, really pisses me off :\.

    EDIT: Nevermind. Force stopped gmail and gmail storage, cleared cache and data, turned sync off, rebooted, turned sync on, good as new.
     
    swc2001 likes this.
  12. swc2001

    swc2001 Well-Known Member
    143

    Aug 28, 2010
    1,005
    234
    143
    Rubber Duck Salesman
    Chattanooga, TN
    Hey Bro I have been having this problem for about 6 months now

    How do you force stop gmail and Gmail storage and Clear Cache and data?

    **update**
    I figured out what you meant by force stopping and clearing cache and data
    I also did the autosync off and then back on without Rebooting. It worked.

    Thanks so Much.

    One more thing. Just as a test I reloaded my nandroid and it Stopped working again. However I repeated the above steps and it began working again. I rebooted several times. Each time I sent an email succesfully. Then I reloaded the Nandroid. It then Stopped working until I applied the Remedy.

    So my conclusion is you Have to do this EVERY time you reload your Nandroid in order to be able to use the Gmail app.

    Well I learned somthin new today.... Can I go home now?

    Thanks MRK
     
  13. isaemm

    isaemm Well-Known Member
    63

    Jun 3, 2010
    331
    41
    63
    Male
    NorCal
    Seems like this is the right thread to ask this question since its about my Gmail problem. My Gmail doesnt get sent to my phone automatically. When I open the Gmail app it does the usual loading thing and then it will show how many emails I have at the top of the app but wont show the emails. I then have to refresh the app and then the emails will populate. Once they populate I can see that the emails are a couple hours old depending on how often I check the app. I have auto sync on but cant figure what else may be causing this. It used to work fine. Any ideas on how to get this working properly?
     
  14. swc2001

    swc2001 Well-Known Member
    143

    Aug 28, 2010
    1,005
    234
    143
    Rubber Duck Salesman
    Chattanooga, TN
    I bet you if you do what MRK said it will clear it all up.
    Try it. Lemme know how it goes.
    It sure worked for me.
     
  15. shantytownbrown

    shantytownbrown Well-Known Member
    63

    Jul 25, 2010
    305
    37
    63
    Medicine
    Connecticut
    Are you guys having this problem with the stock mail app or the gmail app...

    my stock mail app wont send from my gmail acct. all other accts send/receive fine...(two others are yahoo mail accts)

    i will try the above advice but will be back if it doesnt work...
     
  16. shantytownbrown

    shantytownbrown Well-Known Member
    63

    Jul 25, 2010
    305
    37
    63
    Medicine
    Connecticut
    fixed...deleted/re-added acct...

    still curious if o/p's prob was with stock or gmail app
     
Tags:

Share This Page

Loading...