1. Download our Official Android App: Forums for Android!

Support GMail not auto-syncing

Discussion in 'Android Devices' started by GunmetalX, Feb 20, 2012.

  1. GunmetalX

    GunmetalX Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Feb 20, 2012

    Feb 20, 2012
    7
    2
    6
    Hi, I just got an Atrix 2 on AT&T about a week ago. I'm running the Gingerbread update and have not rooted the phone, I've just installed a handful of apps and widgets and that's it.

    I'm having a problem with my GMail not syncing. I am using the current version of the GMail app from the Market.

    If I'm on Wi-Fi and the phone's been idle for maybe 20-30 mins, it won't sync (i.e., I won't get notified on a new e-mail) unless I press a button on the phone.

    If I'm on cellular data (Wi-Fi disabled, or no Wi-Fi available), it won't sync *at all* unless I actually go into the GMail app or if I go into Settings/Accounts and force a sync.

    I've tried multiple combinations of the following settings and I still can't get it to change behavior:

    - WiFi Sleep Policy
    - Battery Saver/Nighttime saver vs. Performance mode
    - Battery & data manager/Data Saver/Enabled vs. Disabled

    Background data and Data are enabled. I've got "Sync over Wi-Fi only" disabled, and Data delivery frequency set to "Automatic (Push)."

    I've also tried toggling off-then-on the Sync settings for my Google account.

    Can anyone help? Not sure what else I can try. I don't think it should be too much to ask for the phone to notify me when I get new e-mails, but sometimes I don't find out until hours later.

    Thanks.
     

    Advertisement

  2. Andima

    Andima Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    449
    Joined:
    Jul 31, 2011

    Jul 31, 2011
    449
    42
    43
    Male
    Undergraduate.
    Are you enable gmail sync? check it "Setting>Account and Sync" now under the your Google account check its "Checked or Not".

    Thanks!
     
  3. GunmetalX

    GunmetalX Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Feb 20, 2012

    Feb 20, 2012
    7
    2
    6
    Hi, thanks for responding. Yes, when I mentioned "I've also tried toggling off-then-on the Sync settings for my Google account" that's what I was referring to. It was already checked; I tried unchecking it and then checking it again, but the behavior has not changed. FWIW, I don't have "Accounts and Sync" under Settings, just "Accounts" but I believe the "Accounts" setting I have is probably the same one you're talking about. Please let me know if there's something else I should be looking at.
     
  4. Andima

    Andima Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    449
    Joined:
    Jul 31, 2011

    Jul 31, 2011
    449
    42
    43
    Male
    Undergraduate.
    >>>don't have "Accounts and Sync" under Settings, just "Accounts" but I believe the "Accounts" setting I have is probably the same one you're talking about.
    Yes i mention same thing.

    I'm not sure this one 100% correct. First log-out your Google account ( Account and Sync) then again log-in. Sometime it may be temporary issue.
     
  5. 916x10

    916x10 Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    491
    Joined:
    Nov 13, 2010

    Nov 13, 2010
    491
    65
    73
    IIRC, it won't notify you immediately unless the app is running, I believe the fastest sync schedule is every 15 minutes.

    Make sure your phone is still set on Data Push and not a Fetch Schedule.


    Go to: Settings/Data Manager/Data Delivery/Email and Corporate Sync/Email Delivery

    Make sure Data Push is checked. You may also want to look at the Sync over Wi-Fi only option to make sure it is not activated.
     
  6. Jesyka

    Jesyka Lurker
    Rank:
    None
    Points:
    6
    Posts:
    1
    Joined:
    Jun 14, 2012

    Jun 14, 2012
    1
    3
    6
    I have a Motorola Photon that I got about a month ago. I have spent ALL that time trying to figure out why my Gmail wouldn't synch (and why I didn't have the "check boxes" under my accounts tab that people were referring to. After searching the web I found this solution that worked for me:

    press the center of your screen or anywhere for a longer pause till the "add to screen" box pops up.
    click the "widget" icon.
    Scroll down to "power tool".
    Tap power tool to bring it to your home screen.
    From here just tap the fourth icon from the left....when you do it will display a green line under it.
    Your ability to sync should be restored as well as the check boxes (under accounts).

    Hope this helps save someone else the headache. Once you do that procedure above you can then remove the widget from your screen if you want to. (just make sure you don't accidentally un-check it)
     
    scanman, miji2 and cherbear1145 like this.
  7. SprintTDI

    SprintTDI Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jan 9, 2012

    Jan 9, 2012
    2
    0
    5
    Thanks for the Motorola Photon sync trick! The power tool widget and toggling the sync, 4th icon from the left worked! Been looking for this little fix for some time!-) Thx!
     
  8. SprintTDI

    SprintTDI Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jan 9, 2012

    Jan 9, 2012
    2
    0
    5
    If you are looking for gmail notifications, it is also important to note: you must have notifications properly selected here:

    All apps > gmail > MENU (four squares button) > more > settings > youremail@gmail.com > Scroll to the bottom > labels to notify > Inbox

    NOW ALAS!-) Select the notifications you prefer for this INBOX.

    Hope that helps someone else also.
    Enjoy.
     
  9. miji2

    miji2 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Jun 15, 2011

    Jun 15, 2011
    6
    0
    5
    It did, and so I just wanted to say thanks.
     
  10. dhonielg

    dhonielg Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jul 17, 2010

    Jul 17, 2010
    2
    0
    5


    Thanks, this fixed my issue
     
  11. brakan

    brakan Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 8, 2013

    Feb 8, 2013
    1
    0
    5
    Another trick I've got to work is, going to settings, data usage and then click on your left button and from the popup box select auto sync data if it is unchecked
     
  12. androidboffin

    androidboffin Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 19, 2015

    Mar 19, 2015
    1
    0
    5
    SOLVED. If your Gmail app has stopped automatically syncing but you can still get mail by manually refreshing your inbox there is an Android app that will solve all your problems:

    "Force Gmail Sync"
    https://play.google.com/store/apps/details?id=forcegmailsync.com

    The app simulates a manual refresh at regular intervals and is the only solution known to work 100% reliably for all varieties of Gmail auto sync fail including the broken Lollipop update.
     

Share This Page

Loading...