1. Download our Official Android App: Forums for Android!

Support gmail not sync'ing properly

Discussion in 'Android Devices' started by MtnbikerChk, Jan 13, 2012.

  1. MtnbikerChk

    MtnbikerChk Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    253
    Joined:
    Nov 23, 2009

    Nov 23, 2009
    253
    25
    58
    Over the last two days or so my email has not been syncing correctly. It's so odd. Some emails that show on my phone are old or some which are in my inbox just don't show up.

    Anybody else seeing this?

    I also seem to be dropping data more frequently.....
     

    Advertisement

  2. Thom

    Thom  
    VIP Member
    Rank:
     #21
    Points:
    1,318
    Posts:
    12,006
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    12,006
    4,973
    1,318
    Male
    Software Developer
    Keene, NH USA
    My Gmail seems to be behaving properly. I have seen a large number of data drops over the last 24 hours. In each case switch Airplane mode on/off corrected it. I was hoping it was a good sign. This is when 4G is supposed to be coming to our area.

    Still 3G-only.

    ... Thom
     
  3. doogald

    doogald Android Expert
    Rank:
    None
    Points:
    483
    Posts:
    6,699
    Joined:
    Jan 7, 2010

    Jan 7, 2010
    6,699
    1,931
    483
    If you go into (from home) settings->accounts, tap your gmail account, is Sync Gmail checked? That's the first place that I would look. If there are no checkmarks showing in that screen, then it could be that background sync has been turned off.

    The easiest way to check is to find a homescreen with enough room for the power control widget (it takes one rom of icons) and add that to the screen. The background sync control is second from the right - it looks like a circle that contains two arrows pointing to each other's tails. If that it turned off, turn it on by tapping it and that should allow syncing to continue.

    If that's not it, you can always try settings->applications->manage applications. Find and tap Gmail and then tap the "clear data" button. Go back into gmail (it should tell you that it is syncing) and then reset all of your settings for notifications, labels to sync, etc.
     
  4. MtnbikerChk

    MtnbikerChk Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    253
    Joined:
    Nov 23, 2009

    Nov 23, 2009
    253
    25
    58
    I've done the airplane mode trick and it doesn't work :( I'm going to FL tomorrow for a few days so that'll definitely tell me if it's my area or the phone.

    Thanks doogald, I've done all that except clearing the data. I'll try that.

    Can I uninstall and reinstall gmail?
     
  5. Thom

    Thom  
    VIP Member
    Rank:
     #21
    Points:
    1,318
    Posts:
    12,006
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    12,006
    4,973
    1,318
    Male
    Software Developer
    Keene, NH USA
    For data drops ... are you running 5.5.893 with a new SIM card? That is the best anyone has seen for a production solution.

    If you are of a mind to play you could try the leaked 5.9.901 but that has no support and no guarantees. It does have lots of good reports on the data drop problem though.

    There was ONE rumor that it was going to be released today. (I'm not holding my breath.)

    ... Thom
     
  6. doogald

    doogald Android Expert
    Rank:
    None
    Points:
    483
    Posts:
    6,699
    Joined:
    Jan 7, 2010

    Jan 7, 2010
    6,699
    1,931
    483
    I don't think that you can, actually - you can uninstall updates that have hit the market, though.

    In the past, the clear data trick has worked for me. My guess was that sync was stuck on a particular messages, and this lets Gmail start again from scratch.
     
  7. MtnbikerChk

    MtnbikerChk Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    253
    Joined:
    Nov 23, 2009

    Nov 23, 2009
    253
    25
    58

    I did that last night and so far....**knockonwood** it seems to be ok.

    thanks for the help!!
     

Share This Page

Loading...