1. Are you ready for the Galaxy S20? Here is everything we know so far!

Gmail stuck "Sending" in outbox!

Discussion in 'Android Devices' started by binaryboy, Apr 7, 2012.

  1. binaryboy

    binaryboy Lurker
    Thread Starter

    I have a problem where all my Gmail gets stuck "Sending" in the outbox and never sends!

    I have used the standard Gmail outgoing mail server as per Gmail's instructions and thought maybe I might need to use my service providers outgoing mail server instead. However I can't seem to find out how to check/change the outgoing mail server for this email account as the LG manual is useless and the android guide doesn't seem to match the screen menu options!

    Does anyone have a solution as to why email gets stuck "Sending" in the outbox and also how to check/change the outgoing mail server for an email account!

    Please help.


    1. Download the Forums for Android™ app!


  2. binaryboy

    binaryboy Lurker
    Thread Starter

    Doesn't anyone have any suggestions on how to resolve this issue? :(
  3. wolftickets

    wolftickets Newbie

    Alas this isn't a problem Google seems concerned about. I wish there was an answer but to work around i set an alarm to remind me to clear data from the gmail app every three days. That keeps it from happening. I noticed that this also happens in the new ics gmail and when I was using an ics rom i could set up a widget to show the outbox so I would notice more quickly if anything was stuck in there.

  4. binaryboy

    binaryboy Lurker
    Thread Starter

    Wow! So this is an issue with Google's mail servers?

    I thought it was an issue with the App or settings on the phone.

    BTW: Do you know how to check/change the outgoing mail server for an email account on the phone! I still can't seem to do this!


  5. mldiroff

    mldiroff Lurker

    I have had this issue happen on my Galaxy Nexus and my DInc at times, including right now, and the only thing I've been able to do is clear cache and data. It wipes out your messages, but at least 'resets' the ability to get outgoing messages through. I also tried changing the sync to 'sync all' instead of 30 days, but that didn't help.
  6. jonhjonh3000

    jonhjonh3000 Lurker

    Hello, good news I have a solution! B-)
    Well let's say a workaround.
    I've had the same issue as described above ever since I got my HTC Desire with Android 2.2, and it happened already with the factory version of Gmail app, and continued to happen after I updated the Gmail app to latet version on Android Market(Google Play).

    Here is a way to *send the messages that are stuck* in the Outbox. It's working every time for me; try to follow very precisely those steps:

    1) in Gmail app, open conversation where the latest email is marked as "sending..."

    2) Click on the *previous* email in the conversation, so that it will open and you will have an option to *reply* to that *previous* email.

    3) on that previosu email, click *reply*

    4) a text field for a new email shows; type in anything, just a few random letters

    5) DO NOT SEND that email with text you just typed; instead click on "Save as draft", or hit the "back" button of your android, which should bring the same result, ie supposedly save a draft with the random letter you typed in

    6) Navigate in your gmail app and open the "Draft" label/folder

    7) click on the most recent conversation... instead of seeing your "stuck" email followed by your random draft, you should now see your stuck message as a draft, and you now have a chance to send it again. Typically, if you do this when you are connected to the internet, it should go right away :)

    Let me know if it works for you! anyone got a way to forward this to google?

    minimal909, Gimcrack3, shanen and 3 others like this.
  7. kais

    kais Lurker

    and helped me save a long and important e-mail. Thank you so much!
  8. sbi

    sbi Newbie

    I have this issue too all the time and the solution above is totally unacceptable. Way to lengthy and there is no reason for us to go through this, let along remember to check if the freaking email went or not. Not happy with this, to say the least.
  9. thanks jonhjonh3000! i appreciate knowing that a message that is stuck sending can be saved, will try it next time it happens.
  10. I finally had this bug happen again just now, and the trick worked! Thanks a bunch, this fix was WAY better than losing the whole long draft I had typed!
  11. wornways

    wornways Lurker

    I found the solution to this problem. Install K-9 Mail and set it up with your gmail account. It will sync with both remote and local information. Then, if your emails get stuck in Gmail, K-9 Mail will do what Gmail doesn't and send the emails. I've tested this out by writing a bunch of emails offline and then going online, K-9 gets them out the door whereas Gmail only sends the first one and leaves the rest stuck "sending" indefinitely.
    YrrchSebor0000 likes this.
  12. I love K9 Mail and would use it exclusively, if only it would implment threaded messaging already!!
  13. After reading forums and googling every possible solution and getting very frustrated because I had 1 email stuck in the outbox of my yahoo mail. I finally came across the 1 and simplest that worked. Turn your phone to airplane mode (that stops your email program from being able to send) then go to the message and it will finally open and allow you to delete it..... It worked and I tried EVERYTHING listed on this thread and none of them worked.
    EarlyMon likes this.
  14. Mattjd68

    Mattjd68 Lurker

    Airplane Mode!

    That worked perfectly on my Motorola Razor M.

    Thank you
  15. jokergrin

    jokergrin Lurker

    Go to manage applications, go to gmail, clear data, clear cache, and uninstall updates. Worked for me...
  16. shanen

    shanen Newbie

    This was helpful for 1 of the 3 stuck messages, but I suspect the real problem with the other two involves their attached files.

    I've given up expecting any help from the EVIL formerly known as the google. If that company gets any more control over Android, I'll have to dump it, even though I've mostly been satisfied with the non-google parts of Android...

    Various beefs with google, but I'll just go ahead and note the one that is most troublesome and specific to Android. Anyone else noticed the google Contacts losing some? I actually think there was joint responsibility there, but I think HTC is simple incompetence, while google is the source of all the EVIL here... At least HTC attempted to answer the questions--before I stopped using their phone. The problem continues, but I think it's because something on the Gmail side has been corrupted--and the google doesn't care enough even to look at it. Too busy trying to handle Samsung?
  17. thomger

    thomger Lurker

    @ jonhjonh3000: you're a genius! thanks for that great explanation!
  18. MSP_1

    MSP_1 Lurker

    You can have the latest version of Gmail, does time matter. I did.

    1. Make sure your account is backed up/synced with your current Gmail account.

    2. Go to your Google account in settings, and remove it.

    3. Now add the account like you did the first time you got the phone.

    What happened to me was that my password had changed but didn't sync with Gmail servers. It still allowed me to receive but not send. Every message sent via my gmail address was stuck in the outbox.
  19. uzetaab

    uzetaab Android Enthusiast

    I just had this issue and what solved it for me was to disable and re-enable gmail sync.

    On my Jellybean Samsung Galaxy S4 it is:
    settings>accounts>google>***@gmail.com>sync gmail check box.

    It had an error next to it, and when I turned it off and on it tried again. I knew it had to sent 9mb (photos), so I just waited patiently.
  20. Al Frowiss

    Al Frowiss Lurker

    :) Thanks walmartcowboys - This approach is WAY better than the above and easy to execute. After being a Crackberry person for last 5 years, everyday is a learning moment for my Droid!
  21. Gimcrack3

    Gimcrack3 Lurker

    Google is frying my brain. Why should I need to be on this forum? Just send my mail!!! Have a Google Nexus tablet that can't even do fundamental requirement. Important email not sent. Thank you!!!!!
  22. minimal909

    minimal909 Newbie

    That helped, greatly!

    Thank you
  23. CojonesDeToro

    CojonesDeToro Lurker

    Indeed. It seems that this happens whenever I had large-ish attachments like pictures and document scans. I also installed the K9 mail client and it doesn't seem to choke on large mail. It's also a pretty good mail client so I use it as my primary now.
  24. shahreaux

    shahreaux Lurker

    I've had this issue for years on all my android devices. The one thing I noticed was it only happened when I was using Wifi... So 2 options...
    1.. copy the text from the email... delete the email from the outbox.. and resend it with wifi turned off.. I use ATT 4G LTE but I have seen this work on sprint as well as Verizon. So just turn wifi off and rewrite the email and send it.. and it will send right away.. guaranteed...

    2.. If you cant copy and paste and just wanted to turn off wifi while sending.. that sometimes works for me.. Instead of it saying sending it will say retrying and it eventually sends...

    BUT the fastest and easiest solution I've found is just redoing the email and sending it via my cell phone network...

    I'm sorry this won't really work for any wifi only android users... I'm curious to see if anyone else on this forum benefits from this..
    DimBulb likes this.
  25. DimBulb

    DimBulb Android Enthusiast

    Yea, that helps a lot. Went to the Boost store yesterday, the guy didn't have any idea, but when I left, found that the WI-FI was ON????

    So, apparently I had left Wi-Fi on for day's.

    Couldn't remember all the sequences needed from the first posts in this thread, glad you gave us this one.


LG Optimus One Forum

The LG Optimus One release date was October 2010. Features and Specs include a 3.2" inch screen, 3MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

October 2010
Release Date

Share This Page