1. Are you ready for the Galaxy S20? Here is everything we know so far!

GNEX as a Mass Storage Drive (Windows)

Discussion in 'Android Devices' started by KE4NYV, Jul 16, 2012.

  1. KE4NYV

    KE4NYV Member
    Thread Starter

    This might have been covered already, but a search did not turn up any thread directly related to the problem I am seeing.

    When I first got my GNEX, I could plug my phone into a USB port on any of my Windows machines (regardless of version) and get a mass storage drive icon. I could then open it, view files on the phone, copy, move, ect. No problem, just like plugging in a thumb drive. Since the last update, I can't do any of this. XP and Vista will see the phone and may even give me a little phone icon, but that is it. I can't open it, copy files from/to, ect. This is really frustrating since this was the easiest way for me to dump files (especially large video files) from the phone. Also, it was the easiest way to dump files to it. With my old HTC's, I could pull the card and pop it into my external card reader (if it wanted to give me problems), but I don't have that option with this phone. Everything is held hostage on the phone.

    I have not had any luck with installing any of the drivers, so I don't think that is the issue. Besides, I never needed any driver before, except the built-in Windows driver to read a mass storage device. When I plug the phone in, I only get a couple of options. One is for media transfer, but that doesn't seem to do anything. I miss the old "USB Drive" option.

    My GNEX is running stock ICS with the latest update and I am UNROOTED.

    Any help would be great! Thanks!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. macprv

    macprv Android Enthusiast

    I don't have a definitive solution for you.. but a temp solution would be airdroid ..

    Now as far as i know mass storage was drop and only "media" was left for the gnex, but i might be wrong :eek:
     
  3. KE4NYV

    KE4NYV Member
    Thread Starter

    Thanks, mac! Since I posted this, I have been doing some more reading and it looks like I am SOL as far as mass storage. I'm trying to get on the Kies bandwagon, but I can't get the phone to connect. Windows sees it and loads a driver. Kies sees when I plug it in, but just keeps churning until I unplug it and then it returns to the home screen.

    I think the most frustrating thing about this now is, my Acer A500 has a USB socket and now it won't recognize my phone.
     
  4. macprv

    macprv Android Enthusiast

    well good luck sir.. I tried everything and i just was not able to transfer any type of files between my pc and gnex via usb; drivers from the windows site, from samsung site, installing kies, pdnet, and what not .. i finally gave up and started using airdroid
     
  5. SlyFerret

    SlyFerret Android Enthusiast

    I've been using dropbox to get files to and from my computer/Galaxy Nexus/Galaxy Tab.

    Since I already used dropbox for other things, it was pretty convenient for me. I just cant stand the idea of physically connecting up a wire to my device to move data anymore, day to day at least.

    Although, when I moved from my Epic 4G to my Galaxy Nexus, I did use a cable to move all my files at once, so I do still see the need for such a thing.

    -SF
     
  6. MachDelta

    MachDelta Member

    You've tried rebooting the phone? Btw the Gnex can't actually be mounted as a mass storage drive (since it's memory is one solid partition, and cannot dual mount) so it uses MTP (media transfer protocol) to shuffle files. Sometimes this takes a minute to initialize but every version of Windows from Vista on should support MTP out of the box (XP requires Windows media player for the drivers). So it sounds like your phone isn't getting MTP set up right, though I'm honestly at a loss as to why. Maybe try opening it as a camera (PTP - picture transfer protocol) and see if you can at least access the albums. If not, try a different usb cable too.
    Good luck!
     
  7. KE4NYV

    KE4NYV Member
    Thread Starter

    Thanks! I did find that out after reading more. I guess I should have done more research before posting, but it used to work, so I was assuming something was wrong. Apparently it's "broken by design".

    However, I tried mac's suggestion of AirDroid and I have to say "Where has this been the whole time??". I am instantly satisfied with it's function. Everything I want to do with syncing. My only hang up was getting it connected via AdHoc. I couldn't figure that out, but I found a way around it. I started up SVTP, connected to the phone as a hot spot through my laptop and now I had an IP to point my laptop's browser at. Worked like a charm!
     
  8. trophynuts

    trophynuts Extreme Android User

  9. dhworph

    dhworph Android Enthusiast

    My favorite is Samba Filesharing. You can toggle on tethering with widgetsoid even if data is turned off and use the samba filesharing app.

    Forever I couldn't get MTP to work, I tried all the methods, pdanet, WMP11, samsung drivers, google drivers... until one day I went to windows update with my phone plugged in usb and windows saw that I needed a driver, and it has been working perfectly ever since. I've suggested that to others and they said it didn't work... dunno, maybe try it if you haven't.
     
  10. Demache

    Demache Android Expert

    Yeah, on XP I noticed you need let it look for the driver. Windows 7 has them built in.
     
  11. dhworph

    dhworph Android Enthusiast

    and btw... samba filesharing (and maybe other wifi sharing apps too) is waaaaay faster than mtp...
     
  12. Petrah

    Petrah Psychotic Female

  13. Demache

    Demache Android Expert

    Eh, in my case I disagree. I get maybe 1 MB/s over wifi, whereas I get about 10 MB/s over MTP. But that might be because you guys have fancy pants Wireless N routers.
     
  14. iowabowtech

    iowabowtech root@android:/ #

    The disparity in success rates is interesting. I've had great luck with MTP on my Win7 machine.
     
  15. Demache

    Demache Android Expert

    Yeah, I've wondered why there has been all this hate for MTP. Its not really that much slower if at all (for me) and the basic file management is there which is good enough for me. It works great for me on both Win7 and WinXP.

    Plus I'm loving the absence of "Preparing SD card..." and the ability for the phone and PC using the file system at the same time. To me that seems a lot smarter than turning your phone into a card reader.

    From what I've heard though, MTP in Linux is a small nightmare though which is sort of off putting.
     
  16. UncleMike

    UncleMike Android Expert

    I was just about to mention that. I've read articles saying how easy it is in Windows, and that "unfortunately it's not that easy in Linux". I'm running Ubuntu 12.04, and all I had to do was plug in the USB cable. It takes what seems like forever to become usable (less than 1 minute though), and then it works as I would expect. I did notice when copying several large files (350MB+ each) that the progress bar stalled around 400MB, but then I went and did something else (on the same machine), and when I came back to the copy operation everything was done.
     
  17. Bren S.

    Bren S. Android Expert

    I use swiFTP to get into my Nexus and add and delete files.
    It works great. :)
    ps swiFTP works on Macs and Windows
     
  18. Demache

    Demache Android Expert

    Just a pro-tip. swiFTP is just a pretty standard FTP server application. My AST Ascentia 910n laptop from 1994 could connect up to my Galaxy Nexus perfectly fine.

    Granted, the Galaxy Nexus could back up the entire hard drive of the AST several times over and still have loads of space. :D
     
  19. Bren S.

    Bren S. Android Expert

    Well I'm not a pro but thought it might be something someone else could find helpful.
     
  20. I am having similar problem and am at a lost as what to do? I am not sure if my upgrade to jb 4.2.1 was the cause or what, but two weeks ago when I plug phone into pc usb it would show GNexus as a connected device and I could open it up and view all files and folders, copy pics and movies to pc etc...Now when I hook up my device computer does not recognize it at all and nothing is showing under My Computer as connected device? I have tried everything and I do have samsung driver installed to pc? it is weird.
     
  21. Tim K

    Tim K Android Expert

    Try installing pdanet on that PC. The USB drivers are the only ones that seem to work on every windows OS. Its how many of us were originally able to connect our phones in order to root. The Samsung provided drivers are crap. Once the drivers are up and running you can uninstall the pdanet software.
     

Galaxy Nexus Forum

The Galaxy Nexus release date was November 2011. Features and Specs include a 4.65" inch screen, 5MP camera, 1GB RAM, TI OMAP 4460 processor, and 1750mAh battery.

November 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...