Help Google Apps won't connect to network after rooting phone (Galaxy s4 mini)


Android Question

I'm having problems with my Google Apps like Youtube, Play Store, Chrome, and others that need a network connection. When I try to open them they say "server error" or a similar message.
I recently rooted my phone using Kingo Root, and uninstalled a few of the stock apps (mostly verizon bloatware) so I suspect I may have deleted something I shouldn't have, but I was careful not to delete anything that was important (I thought).
I have tried:
-Checking my date & time (duh)
-Deleting cache & data for the apps
-Rebooting phone
-re-installing Gapps, which I thought would work, but every time I try through "Install update from sdcard" I get verification failed errors. I have tried using three or four different packages from different sources.

The phone is a Galaxy S4 Mini (i435) with stock android 4.4.2

James L

Android Expert
Without knowing the specific error code... It sounds like you uninstalled Google play services.
You could backup whatever files, pictures etc. Then flash the stock firmware for your device, and re root.


I do see Google Play Services in the application manager, but I will try that, do you know of any good sources for the firmware?