1. Are you ready for the Galaxy S20? Here is everything we know so far!

Google Location Service WAYYYY off!

Discussion in 'Android Devices' started by Boomstk, Aug 3, 2010.

  1. Boomstk

    Boomstk Well-Known Member
    Thread Starter

    Two days ago I noticed my time zone changed to London time zone. I live in Connecticut. So I turn off the Automatic time/date and manually set the time zone. Soon as I turn the Automatic it jumps back to London time. So since then I have been using on manual.

    Now today I notice when I goto Maps, my location shows me in London. This also happens in other weather location apps as well. If I turn off google location, the weather apps pick up my current location via the mobile network. However for Maps to work it needs the google location turned on.

    I know this could be far fetched, but is there a way someone hacked my google account and using the location service? Or am I missing something completely obvious?


    Ok so the plot thickens. It's not just my phone. It's also happening with other coworkers who have Blackberries. So obviously it stems to relate to Verizon and not my phone.

    1. Download the Forums for Android™ app!


  2. yojoe600

    yojoe600 Android Expert

    so you are saying you have GPS on and its doing that?
  3. Dmark

    Dmark Member

    That happened to me a couple of weeks ago, but it only affected me that one time. Hasn't occurred again. My location was set to Singapore. With the 12 hour time difference, my clock set itself to PM instead of AM. I noticed when I set an alarm and the phone said was set to go off a lot later than I expected!
  4. Boomstk

    Boomstk Well-Known Member
    Thread Starter

    This is without GPS on. I have never had a problem problem prior using it with GPS off. Turning GPS fixes the problem. But being indoors most of the day I have no clear view of the sky.
  5. Crashumbc

    Crashumbc Android Expert

    When you don't have GPS turned on, my understanding is google uses a "database" of wifi locations to figure out where you are. There's probably a bad location in the table...
  6. yojoe600

    yojoe600 Android Expert

    you can use gps inside... just leave it on... it doesnt hurt battery unless some program keeps it on all the time but none do unless they are not working right...

    and if its using wifi then thats your problem ive had my home one but me in the ocean so use gps
  7. kyler13

    kyler13 Android Expert

    This. My wifi router got fried in a lightning storm a few weeks back. Had to have Verizon (FIOS) send me a new one, er, refurb as it ended up being. Well, I know where the last owner of this router lived: Tiverton, RI. As long as I was on wifi, it recognized my location as this. I did some digging and you can submit your wifi MAC address to Google (and one other major provider) to update their database. Otherwise, they roam the streets of the country constantly searching for wifi locations to update their database, and you'll have to wait until they come down your street again which could be a year or more. The only caveat is that I still get Tiverton, RI as my location sporadically. I haven't investigated why, and I haven't yet tried to resubmit.
  8. Boomstk

    Boomstk Well-Known Member
    Thread Starter

    I could understand this if I had my WIFI on.. however it's off and I am using 3g.
  9. drdoom

    drdoom Android Expert

    Just leave GPS on. It sounds like a problem when finding location based on the cell tower since others have the same problem/location.
  10. Jim Chapman

    Jim Chapman Member

    I thought the time/timezone setting was provided by the Verizon network, the same for all phones, smart or otherwise. Google has some additional tricks to support the location services API, but time setting is separate.
  11. heffe2001

    heffe2001 Well-Known Member

    I'm also of the opinion that Verizon is sending out some bad data. It shows me in Charlote, NC when I'm at home on my wireless, where up until maybe Friday or Saturday it showed me in the correct location, Conover, NC.

    This coincidentally happened when I loaded the first 2.2 leak, so I'm wondering if it's not getting good data back. Anybody else out there who's getting wrong location using the 2.2 leak?
  12. aepihupe

    aepihupe Lurker

    Is this something to worry about with regard to being hacked?

    I've only had my Android (HTC Desire HD) for about a week now, and it's shown my location perfectly up until this morning (Limburg region of both the Netherlands and Belgium). I downloaded and installed about 10 free apps (all from the "top apps" list in the Android market, mostly Google apps like translate; sky map; streetview) yesterday, and since this morning my location is listed as Jihan (China) and all of my location-related services report about this location now. I've tried GPS on/off, mobile data on/off, the location remains fixed. In the maps app, turning my phone turns the arrow correctly, so is this just a software or data bug? Is there a program out to check if somebody else is streaming through my phone/connection?
  13. AnotherHiggins

    AnotherHiggins Android Enthusiast

    I had this problem several months ago (pre-froyo) and was able to fix it. There's no way some of you trying to answer would know this, but this is a fairly common problem - at least on HTC phones. Unfortunately I can't find the thread where it was discussed.

    But from memory here are some of the things I remember doing (I might have missed or added steps).

    This is definitely a shotgun approach and may be overkill, but I think it will fix the problem. And having just done quite a bit of Googling, I don't see any other solutions posted, so hopefully this will help someone.

    NOTE: when it happened to me what I first noticed is that my HTC Sense Clock/Weather Widget was stuck on a particular city and wouldn't change when I went home (a different city).

    1) In the Weather Clock Widget, delete all cities. Go into the Weather > Menu > Delete and delete them all

    2) Go back to the home screen and delete the widget (Long Press > Drag to Trashcan)

    Go to Menu > Settings > Accounts & Sync - make sure the first two options (Background Data and Auto-Sync) are checked

    4) Go to Menu > Settings > Location - make sure all three options (VZW Location Services; Standalone GPS Services; Google Location Services) are checked

    5) On your desktop/laptop, sign into your google account and go to maps.google.com. Change your Default location (if needed) and see what it shows when you click on Show My Location (that's the little circle above the StreetView guy - above the Zoom Slider)

    6) Update your roaming by dialing *228 > 2 (You must disable Call Confirm if you use that app). Your phone will reboot itself.

    7) On your phone, open the Maps application. Click on My Location to see if that's right

    8) If you're using HTC's clock widget, add it back at this point. On the home screen, long press > Widget > Clock. It's the third one. When you select it, it will ask you for a default city. Select Current Location. It probably automatically added one or two additional cities. You can repeat step 1 if you want to delete them.

    Let me know if that helps or if anything needs further clarification.

HTC Droid Incredible Forum

The HTC Droid Incredible release date was April 2010. Features and Specs include a 3.7" inch screen, 8MP camera, Snapdragon S1 processor, and 1300mAh battery.

April 2010
Release Date

Share This Page