1. Download our Official Android App: Forums for Android!

Google maps navigation Droid X

Discussion in 'Android Apps & Games' started by dnbreaks, May 19, 2011.

  1. dnbreaks

    dnbreaks Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    28
    Joined:
    Oct 1, 2010

    Oct 1, 2010
    28
    0
    15
    Monticello, MN
    I have the Droid X and recently the voice in the turn by turn directions in navigation has not been working properly. After I enter the destination a computerized voice starts speaking, but it's not even close to the voice it used to be. And it says something like xml version equals 1.0, state version equals 1.0, www(dot)wfree(dot)org/2001/10/synthassist... It seems to repeat this a couple times for about 30 seconds and then finally gives the next turn direction. Any ideas what could be causing this?
     

    Advertisement

  2. Hrethgir

    Hrethgir Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,684
    Joined:
    Feb 16, 2010

    Feb 16, 2010
    1,684
    225
    163
    Male
    Intel fab tech
    Salem, OR
    I've had that exact problem before, it's you TTS (text to speech) library. Try installing eSpeak TTS, then go to Menu>Settings>Voice input and output>Text-to-speech settings and pick eSpeak TTS under the Engines title. Hope this works for you!
     
    dnbreaks likes this.
  3. dnbreaks

    dnbreaks Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    28
    Joined:
    Oct 1, 2010

    Oct 1, 2010
    28
    0
    15
    Monticello, MN
    I did have eSpeak installed and it was my default engine. I uninstalled and reinstalled it. The computer voice went away, but only briefly. The regular voice would be there, but then if I clicked the menu button -> more -> set destination and changed the destination, the computer voice would come back. Sometimes the regular voice would come back if I exited navigation and opened it up again. And then sometimes the computer voice would still be there. This doesn't happen at all if I pick Pico TTS as my default engine so I think I'll stick with that unless there are any other suggestions. Thanks for your help Hrethgir.
     
  4. takeshi

    takeshi Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    3,354
    Joined:
    Dec 6, 2009

    Dec 6, 2009
    3,354
    283
    163
    Sounds like an issue with eSpeak then. Have you contacted the developer? I haven't had such problems using SVOX Classic.

    Subject should be TTS engine. It's not Google Maps/Nav.
     
  5. dnbreaks

    dnbreaks Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    28
    Joined:
    Oct 1, 2010

    Oct 1, 2010
    28
    0
    15
    Monticello, MN
    Thx takeshi, I will try SVOX and contact the developer of eSpeak. And you're probably right that the subject should be TTS engine, however at the time things weren't working properly with Nav I wasn't aware that TTS could be the issue as Nav is the only app, that I know of, I use this with.
     

Share This Page

Loading...