1. Are you ready for the Galaxy S20? Here is everything we know so far!

Google maps not working on rooted Eris 2.1

Discussion in 'Android Devices' started by Not techie, May 24, 2010.

  1. Not techie

    Not techie Newbie
    Thread Starter

    So as the handle suggests I need step by step directions to do anything involving a computer.

    I took a jump by rooting my eris, and now I have a problem and don't know how to fix it! which is frustrating, but it is exactly the reason why I rooted in the first place! To have a reason to learn this stuff!

    So here I am reaching for help.

    The problem with my phone is that when I open google maps and type two or three characters on it it force closes on me. 50% of the reason to get this phone was for google maps. It could replace a gps with longer battery life than 4 hours which means I can leave the house and ride all day without having to plug it in.

    Any way I have tried turning off the phone, turning it back on, and clearing the settings on the application then turning it off again. still I get a force close message.

    It is using 2.1, but I am not sure which version it is using. would updating to a newer rom like 2.1 v3 help? if so how would I go about it?

    1. Download the Forums for Android™ app!


  2. A User Name

    A User Name Well-Known Member

    Go to the ROOT Section on top of the board. Look for a Custom ROM to load to the phone which has a functioning Google Maps.
  3. Not techie

    Not techie Newbie
    Thread Starter

    So is this a simple issue with the rom I have?

    I get a message saying that there is an update for maps, but when I down load it it wont install because of... a bad signature? I think it says...
  4. Kevkelsar

    Kevkelsar Android Enthusiast

    You will have to bring up any issues with the creator of whatever ROM you are running.
  5. jreed2560

    jreed2560 Android Expert

    2.1 v3 IS NOT A CUSTOM ROM! IF YOU ARE ROOTED DO NOT FLASH THIS AS IT WILL UNROOT YOUR PHONE! Go to the root section and check out all the roms listed there. Most have maps working. Just out of curiosity, which rom did you initially flash? The process of flashing a new rom is simple.
    Just dl it from either the first post of thread you found the rom in, or go to android.grdlock.net and download it from there. Those would be the only trusted sources.
    second, place the rom on your sd card by itself (not in any other folder) Next power down the phone.
    Now power it up by pressing power and volume up. This will boot you to the recovery console.
    Now select wipe from the menu.
    Next select factory data. It will ask you to press the trackball to continue. Press it. It will take a second,
    Next select dalvik/cache. again press the trackball to continue. Now you are in a factory default state.
    Press volume down to go back to the main menu.
    Now select flash from sd card. scroll down to the rom you just put on the card and select it. confirm by pressing the trackball again. Sit back and wait.
    When its down you will be back and the main menu. Select reboot and viola! You should be good to go!
  6. Not techie

    Not techie Newbie
    Thread Starter

    thanks... I have been battling with trying to follow a guide step by step today but it seems it was written for either xp or vista users and some steps were different for win 7.

    now does the rom have to be on the zipped file in the sd card or does it have to be extracted?
  7. jreed2560

    jreed2560 Android Expert

    Just leave it as is.
  8. erisuser1

    erisuser1 Android Expert

    Reading between the lines, it seems that "Not techie" might have only applied the root ROM, and never installed either the (Amon_RA v 1.6.2) recovery, or a custom ROM after that.

    That would could explain his trouble with Google Nav - a really old test version of 2.1.

    Not techie : When you power the phone off, and then re-start it by holding down the Vol-up and End/Power buttons simultaneously (keep holding them down until the 3 skating androids appear), what do you see on the screen after 60 seconds or so?
  9. Not techie

    Not techie Newbie
    Thread Starter

    so.. is there any other way to get to the recovery console? when I press those two buttons an exclamation mark inside a triangle comes up along with the little green android. the phone does not progress from that screen. I then have to take the battery out and restart the phone again. Once it restarts it functions as normal.

    I followed the steps from this forum which took me to theunlockr. I might be misspelling it. if this helps at all.
  10. Not techie

    Not techie Newbie
    Thread Starter

    I am having that "hm.. I think I have bitten more than I can chew" feeling...
  11. Not techie

    Not techie Newbie
    Thread Starter

    So while checking the steps needed to take from start to finish shown here(by finish I mean having the ability to flash a custom root) I did not take them all, and so I do have the old version 2.1 which you suggested., but that is as far as I got.
  12. erisuser1

    erisuser1 Android Expert

    I had you run that step to confirm my suspicion - which is that you do not have the Amon_RA recovery installed.

    You ran the test, and it seems to confirm that indeed, you don't have it installed. The key sequence you used would have taken you there. (Instead, your phone gave a behavior which is consistent with the recovery boot for either the original phone or the "root" ROM recovery boot.

    Now let's check to see if you even have the S-OFF bootloader installed.

    1) Power down your phone.
    2) Remove the SD card from it's slot (because PB00IMG.ZIP is still there, right?)
    3) Power up the phone by pressing Vol-down and End/Power simultaneously. (Keep holding them down until the screen lights up).

    Take a look at the first two lines in the display; does the first line say "S-ON" in it, or "S-OFF" ?

    What version number is reported in the second line?

  13. erisuser1

    erisuser1 Android Expert

    Well, follow the instructions in my prior post to confirm that steps 1-4 from the XDA instructions worked correctly, and we'll take it from there.

    Just about nobody uses the O/S that comes with that "root" ROM - they install it for one reason, and one reason only: the bootloader that gets installed unlocks the phone completely for new software. So it only is a stepping stone to getting a ROM that you will like.

    Report back whether you have achieved an "S-OFF" bootloader install (steps 1-4 in the XDA instructions)

  14. Not techie

    Not techie Newbie
    Thread Starter

    Thanks first of all for your help.

    My phone says S-OFF in the first two lines.

    Here is another question I thought I was doing something wrong because my computer was not recognizing the phone, however when my g/f got home I pluged her eris in and the computer found it instantly...

    I am having trouble with parts 2 steps 10 and 11 of the walkthrough, and part 3 step 2.

    For part 3 step 2, Am I supposed to transfer the file to the tools folder? because when I am in the SDK program there is no tools option within the window.

    Again not being very techie (or at all for that matter) means that if the instructions say "press the green button" and there is no green button I freak out, and don't have the know how to work around that....

    I am running windows 7 and the instructions are designed/written out for xp users some things tend to be a little different.
  15. erisuser1

    erisuser1 Android Expert

    OK, that means that you succeeded with steps 1-4. You have the beginnings of root on your phone. That's the good news.

    The bad news - as you found out - is that the version of the OS that comes with the ROM that gives you a S-OFF bootloader is full of bugs - nobody uses it. It is possible to go back to 1.5, or go forward to a nice root ROM - but both of those paths are full of "techie". There isn't a click-one-button solution for getting you out of where you are. Since the effort is about the same, I recommend that you go forward (to root working well).

    Uh Oh.

    Have you ever "mounted" the SD card onto your PC while attached with the USB cable?

    Forget about root for a moment - I am just asking about whether or not you have evidence that your hardware is working.

    Let's talk about Part II, steps 9-10.

    What might be a little confusing is that the way USB works, you can have lots of individual software drivers to support different functions on a hardware device. So, even though your GF's Eris can "talk" to your computer, what these instructions are trying to do is install a separate driver which will be used by the "adb" program that comes with the SDK.

    - Plug the phone in to the computer, enable Debugging on the phone (Settings -> Applications -> Development -> USB Debugging), and while you are there, turn on Stay awake (Settings -> Applications -> Development -> Stay awake)

    - Re-read step 9. Do you see a yellow exclamation mark, (or equivalent for Windows 7)?

    The "tools" folder is a folder inside the folder that all of the SDK files get installed to on your C: drive. I don't have a windows install in front of me, but I think that top-level folder starts right at the top of the C: drive, and has "Android" in the name. The "tools" folder will be either directly underneath this one, or one more folder down - on your PC, use a Windows file browser to locate this directory.

    Yes, you should extract the zip file into the "tools" folder once you have located it. Strictly speaking, it is not necessary to put your data files in here, if you are able to add the SDK tools folder to your PATH (step #11). but it causes no harm, and makes it possible to skip the part about modifying your PATH.

    NOTE! I went and checked the Zip file (recovery.zip) that is in the XDA post you referenced. It will work correctly, but I notice that it uses an older version of Amon_RA's recovery image (the file called "recovery.img" in the Zip file). You might want to grab Amon_RA's most current recovery image directly from the download link in his post on XDA (about 2/3rds of the way down the page under Download). His newer version (v 1.6.2) will be named "recovery-RA-eris-v1.6.2.img" and has a MD5 checksum of e3932991f097993602af3c7a4b61a4f8.

    After unzipping "recovery.zip", delete the old "recovery.img" file that comes with that zip file, copy recovery-RA-eris-v1.6.2.img to the same (tools) folder, and rename it to just "recovery.img" so that it is compatible with the other instructions which follow.

    Tell yourself, "I can do this." Don't defeat yourself before you begin. There are lots of people with exactly your skills, that can work through stuff like this - the only difference is that they don't give up, and also try to have a relaxed mind about it. No, you won't understand everything at first, but that's OK.

    I believe that, and I have noticed that Windows 7 users seem to have more trouble with this particular step (driver installation) than other users. I'm no expert here, but I have noticed a few other people claiming "I just installed the HTC Sync Application, and it took care of the driver install for me". You might give that a shot.

    At this point, what you should work on is getting your device driver installed correctly on the phone, and concentrate on that alone.

    How will you know if it is working? First, you probably won't see any of those yellow exclamation marks inside the device manager on Windows. Second, you can run a test with adb itself to see if it is "talking" to the phone. From windows,

    Start... Run... (type into box) CMD (and hit enter)

    (this is an example of using the "cd" command to get to the tools folder)

    Code (Text):
    2. C:\Big Long Path Including Your User Name> cd \
    4. C:\> cd \Android-something-or-other\tools
    6. C:\Android-something-or-other\tools> adb devices
    7. * daemon not running. starting it now *
    8. * daemon started successfully *
    9. List of devices attached
    10. HT9AAAAnnnn    device                
    That last line is what you are looking for - the adb program reports that it found a phone on the other end of the USB cable.

    Let me know how it goes

  16. Not techie

    Not techie Newbie
    Thread Starter

    so I have gotten through part 2. This morning after dealing with this stuff for a few hours, I was able to have the phone communicate with the computer. I moved on to part 3.

    At step 3 of part three at the end, after the command prompt is opened and the following is typed,

    adb shell mount -o rw,remount /dev/block/mtdblock3 /system
    adb push recovery.img /sdcard
    adb push flash_image /system/bin
    adb shell chmod 755 /system/bin/flash_image
    adb shell flash_image recovery /sdcard/recovery.img

    I get a message which makes me think that it did not work.

    It says "flash_image: not found"

    So does this mean that I don't have a recovery partition? I am guessing that moving on to part 4 with that message is risky. Or.. is this what I am supposed to get?
  17. Not techie

    Not techie Newbie
    Thread Starter

    So a whole week later, the issue is fixed!

    my abd was not working, which made everything else just busy work!

    THANK YOU ERISUSER1 for all the encouraging posts Not to mention the patience you had with me!

    Thanks to all who came by and chimed in!

    I am now fully rooted, and running Evil Eris ROM and I am even more hooked!

HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date
Similar Threads - Google maps working
  1. Samwisegamjee
  2. Steve Singleton
  3. TheOneGuy
  4. haniya
  5. Novice App User
  6. Ivanlc
  7. Wax Bean Tycoon
  8. Wax Bean Tycoon
  9. cpper
  10. NSD Teja

Share This Page