1. Are you ready for the Galaxy S20? Here is everything we know so far!

Google Messages - Issue with MMS images S10 on AT&T to iPhone 11 on Verizon

Discussion in 'Android Apps & Games' started by CrazySaguaro, Mar 26, 2020.

  1. CrazySaguaro

    CrazySaguaro Lurker
    Thread Starter

    Hello, I've had an issue with my MMS messages for quite some time. I send images via text from my S10 on AT&T with Google Messages client to my friend on Verizon with an iPhone 11. He gets all the images I send, but a lot are very delayed - some by 2-12 hours. On my end after sending, it looks like they just go right out (no messages about not sent, etc).

    I have uninstalled and reinstalled Google Messages and cleared the app cache. Anything else I can try? It's a VERY annoying issue.

    Thank you for any help,

    1. Download the Forums for Android™ app!


  2. Dannydet

    Dannydet Extreme Android User

    The issue lies with Apple and iPhones, not Android....
  3. svim

    svim Extreme Android User

    Do regular text messages (SMS) go through in a timely manner and it's just MMS messages that are a problem? Or are both a problem?

    If the latter, the problem would appear to more with some kind of carrier issue (i.e. how your messages are being transferred between AT&T and Verizon) than your phone or the Google Messages app.
    If the former, it might not be a matter of messing with your phone so much a matter of Google's push to have its own RCS protocol take the place of SMS/MMS. Granted both SMS and MMS are very dated protocols and because of that are not able to keep up with current technology but at this point they are still the only two standards that all text messaging services still include at least some support for. The problem being Apple has made it clear about not allowing its iMessage platform to support RCS so that goes back the issue of SMS/MMS still being the tenuous link between Android and iPhone users. It could just be some carrier-based glitch issue with on-the-fly file conversion of the attached file.
    If there's an option to disable RCS in the Google Messages app try that, or think about switching to a different texting messaging app that isn't forcing one to always use RCS
    Dannydet likes this.

Share This Page