1. Are you ready for the Galaxy S20? Here is everything we know so far!

Google Play is still not working.

Discussion in 'Android Lounge' started by Sheep, Jul 29, 2017.

  1. Sheep

    Sheep Newbie
    Thread Starter

    I dont usually do things like post in forums but I need help.
    Whenever I go to download an app, this happens. Screenshot_2017-07-29-14-55-56.png

    I am unable to download it and it just says downloading until it times out. In the top left corner about every ten seconds the download symbol flashes then stops quickly.
    This has been happening since I got the phone. The only way I have been able to get any new applications is by downloading the Apk off the internet.
    I have tried all of the troubleshooting tips and called google support and my phone carrier several times. Clearing the cache and data, uninstalling updates, even completely uninstalling google play has not fixed it.
    Very, very rarely I can download an app by going into play games and installing it there, without opening Google Play. I have only been able to do that twice. I have an LG K7 and ZTE Grand X Max + and am having this issue with both phones. I talked to my brother who has a ZTE and he is having the same issue. I have looked into it online and for how widespread the issue is, it seems to be uncommen apparently as I can not find much about it.
    All Im asking is for a helping hand. This is driving me insane as certain applications have to be installed from Google Play. Thanks for reading. - Sheep
     


    sweetndreemy73 likes this.

    1. Download the Forums for Android™ app!


      Download

       
  2. Mikestony

    Mikestony ~30% Carbon Black ±
    VIP Member

    #2 Mikestony, Jul 29, 2017
    Last edited: Jul 29, 2017
    IsaacGuti likes this.
  3. IsaacGuti

    IsaacGuti Well-Known Member

    I had this happen to me long ago but I don't know why it happened.

    You could try downloading apps using the play store website https://play.google.com/store

    If the link keeps opening up the play store app just try googling "play store" and try one of those links, the one that says "My apps - Google Play" doesn't open the app
     
    #3 IsaacGuti, Jul 30, 2017
    Last edited: Jul 30, 2017
  4. Sheep

    Sheep Newbie
    Thread Starter

    I am not connected to wifi, but when I do I can usually download apps. I have done all the troubleshooting tips several times each. I have tried downloading from the website as well already, and it just begins the download from google play, but wont actually start downloading anything.
     
  5. Dannydet

    Dannydet Extreme Android User

    Clear your cache on the device. Or FDR it.
     
    david nist and Mikestony like this.
  6. svim

    svim Extreme Android User

    Since that game install appears to be problematic during the download step and you've already tried different fixes with the Google Play app itself (clearing cache, uninstalling update, etc), maybe the issue isn't with the Play app but at a lower level with Android itself. There are two different and separate caches with Android, the app caches that can be wiped in a general way (that reside in the user data partition) and the system cache that can be wiped only through the device's Recovery Mode (that resides in its own dedicated system cache partition). Try booting one of your phones into its Recovery Mode
    http://www.hardreset.info/devices/lg/lg-k7/recovery-mode/
    or
    http://www.hardreset.info/devices/zte/zte-grand-x-max/recovery-mode/
    and select the 'wipe cache partition' option and see if that makes any difference in the download process. I could be incorrect on this but when Google Play is installing an app it downloads the installer files into the system cache (the temporary dumping cache for such things) before actually installing the app into the user's partition. In any case it won't hurt to try, wiping the system cache partition won't affect your data and the OS doesn't store anything vital in the cache either.
     
    david nist, Mikestony and Dannydet like this.
  7. Sheep

    Sheep Newbie
    Thread Starter

    I just did a hard reset on both phones and the issue still occurs. Like you said, it may be an issue with Android. Im running 5.1.1 and dont have many issues other than the keyboard which is bugged. Sometimes when I go to edit a sentence it deletes a couple letters before those and replaces and adds the words after. Kind of difficult to really explain that bug.
     
  8. david nist

    david nist Newbie

    Two units experiencing the same issue at the same time is rare, but three units makes it a party, so let's get you fixed and on your way.

    At least one of the fixes already offered should have worked for you. These guys are all wizards, so we need to go a bit deeper.

    Looking up the specs, I found these:

    K7
    http://www.gsmarena.com/lg_k7-7848.php
    Android 5.1

    ZTE Grand Max X Max +
    http://www.gsmarena.com/zte_grand_x_max+-6915.php
    Android 4.4.4

    Last Day on Earth
    .apk: 94.20MB Download

    After reading through the entire thread,

    I understand the following to be true:

    1.both phones are stock / never 'been rooted

    2. you've cleared the cache several times on both phones

    3. you've performed a hard reset at least once on both phones
    (A great thread on factory/hard reset differences can be found here)

    4. you've wiped the cache using the method above as outlined by svim

    5. your keyboard lags at times

    6. The issue is more than intermittent than persistent

    7. You've called both Google and Carrier support for help


    Some questions:

    Have you tried downloading the app on both phones simultaneously?

    If yes, what were the results?

    Have you accepted and installed the OTA updates from your carrier?

    Is the ZTE Max + now Android 5.5.1?

    Who is your carrier?

    unlimited data plan?

    If yes, are you throttled back after a certain data amount?

    Any SD memory cards?

    Have you checked for available space through file manager?

    A hard reset and 'wiping' cache is a bit different than a factory restore. Have you tried both methods?

    Have you tried downloading a small app from the store as a benchmark, then working your way toward larger apps?

    Is your keyboard stock?

    Can you download the app in a 'wi-fi' only environment?

    finally, two silly questions:

    have you visually checked to ensure the 'download' over wi-fi only' is off, and have disengaged / engaged the download booster if it's installed on your model?

    I've included a few screenshots for reference, but they may not be relevant to your issue.

    Once you've outlined your smartphones for us, it's only a matter of time before we get you a fix.
     

    Attached Files:

    #8 david nist, Aug 9, 2017
    Last edited: Aug 9, 2017
  9. Clarence02

    Clarence02 Newbie

    Maybe someone can help me here.
    My Google Play Store and Google Play Services weren't working. I cleared data and caches, uninstalled it and reinstalled it.
    Now I'm unable to add my Google account back into my Huawei Y5 11.
    I get the message "There was a problem communicating with Google server, please try again later"

    Someone must have a solution to this without rooting or factory resetting my phone?
     
  10. david nist

    david nist Newbie

    Clarence -

    When you say cleared the caches and data, I'm assuming you mean under the apps section in settings. One thing you can try without having to go all commando or force a ROOT you don't want is to boot up into 'Recovery Mode' and selecting the non-destructive 'wipe cache' option.

    To enter recovery on the Y5 11:
    1. Turn off the device
    2. Press and hold Volume UP key + Power Key about 10 seconds
    3. Release all keys when you see Android System Recovery
    4. Use Volume +/- key to select Menu options
    5. Select wipe cache or wipe cache / Dalvik
    6. Confirm selection with the power key
    7. Wait until unit returns to the menu options screen
    8. Select reboot
    9. Select system or normal if given boot options
    10. Check the results

    If you're still having issues after completing the above steps, jet me a reply.

    There are a couple of next steps for us to run with, all non-destructive.

    Permissions issues with Google seems to be the issue here, not a huge deal to overcome.

    Good luck!

    David
     
  11. Sheep

    Sheep Newbie
    Thread Starter

    I have not downloaded the app on both phones simoultaneously and cant since the other one doesnt have an internet connection. I believe I do have the latest update, at least what is released for me. My carrier is Metro PCS and I do have an unlimited plan but am throttled after 32 gigs (but they usually just throttle me at 28...) I am not throttled. I keep most everything I can on an Sd card but it doesnt really make a difference whether I do or dont since everything is installed internally. I have plenty of free space. It does not allow you to download applications if you do not have enough space. I refuse to factory reset and doubt it will make any difference if I did. Now heres where it gets a little weird, when I attempt to download an app it wont. But sometimes when Im really lucky if I try again the next day it will. But nothing else will. Sometimes I get lucky and can download two apps I never have before. But then afterwards cant download anything for weeks. Even as I am typing this now that annoying download symbol is still flashing every 30 seconds for a split second. I can usually download over Wifi. But since I dont have the luxury of Wifi I cant rely on it. And as I said earlier I am rarely able to download so it is not a manuel issue. Trust me, Ive done most everything I can in my power and am still having this issue. I am sure that I am not the only one. A fellow friend and Android enthusiast like me got an Lg K10 and even he is having issues downloading apps. I know it may be difficult to believe but this is fairly widespread for me. Mostly because everyone I know uses Lg and Zte. I posted screenshots of what is happening with my keyboard. When I go back to edit something and backspace is copys some words and shifts them in from of where I was typing. Makes it very frustrating to edit anything.
     

    Attached Files:

    #11 Sheep, Aug 16, 2017
    Last edited: Aug 16, 2017
  12. svim

    svim Extreme Android User

    This is more esoteric than anything but keep in mind when you're interpreting free storage space that your mobile device and you yourself are looking at things differently. The internal storage memory is divided up into different partitions, most are protected system partitions that are dedicated to the operating system and one is the general data partition, where all your data and things reside. You only have full access to that data partition and only very limited access to those system partitions.
    Also keep in mind that there are two completely different 'caches' -- there are app caches and there's the system cache. The two types don't interact with each other, both serve different purposes, and both are stored in separate places. Your user installed apps and their related caches reside in that user data partition, the system cache has its own, dedicated partition.
     
  13. Sheep

    Sheep Newbie
    Thread Starter

    I think that it may only be a local problem from the Metro Pcs store where a these phones were purchased from.
     
    #13 Sheep, Aug 17, 2017
    Last edited: Aug 17, 2017
  14. Sheep

    Sheep Newbie
    Thread Starter



    This pretty much sums of what is happening to me except none of the tips work.
     
  15. Sheep

    Sheep Newbie
    Thread Starter

    Ok, after wasting an entire day I found a solution. After finding a thread deep in the internet one person held the answer. I have a metropcs phone. He said that if I change my apn to fast.metropcs.com and the mmsc to https://metropcs .mmsmvno .com/mms/wapen. it would resolve the issue. Sure enough, it did. I hope this works for any of you who are having the same issue. Good luck!
     
    mikedt likes this.
  16. david nist

    david nist Newbie

    Congratulations!

    APN issue?
    took you less than 5 mins to fix, didn't it?

    Since you've already wasted an entire day, it would be a shame for me 'not' to waste a few more of your minutes.

    :)

    Below, you'll find a few handy tidbits of advice that'll help expedite the resolution of your next issue:

    include as much information as possible
    For a speedier fix, take as much time as necessary to include ancillary information such as: 'when did you first recognize the condition to be an issue?' 'what actions did you take when you first noticed the issue, your thoughts regarding cause, and any fixes you have already applied, etc. -be proactive.

    Screenshots are an anytime welcome addition.

    reply back to questions as soon as possible
    the faster you pass back information, the faster the issue gets resolved, and the less likely it is your thread contributors wind up barking at the wrong tree or chase after the wrong rabbit.
    (case in point, APN settings)

    recommended fixes are thought out well in advance
    before posting to your thread, a contributor does a thorough walk-through of any proposed fix, restricted to information read in the thread.

    An accurate recounting of processes related to the issue will always win the day.

    a quick note of thanks goes a long way
    every response seen in every thread across the globe represents a living, breathing, real person, alive in real-time somewhere on planet Earth.

    I'm truly humbled when I realize that somewhere, someone cares enough to give up their own personal time just to help out little ol' me.

    Common courtesy aside, i think you'll agree that besides it not 'just' being a great way to make new friends, sending an after fix 'note of gratitude' is the right thing to do.


    In closing

    It's a rare occurrence indeed, for even the most novice contributor 'not' to have the knowledge to quickly resolve ANY APN issue at first glance... that is, so long as the body of the posted issue contains the right information.

    P.S.

    the above information tips are in no way meant as a criticism toward anyone.

    On the contrary, I hope the time it took to scribble it all down will help to expedite 'future issue' closure rates, and to have a positive impact with site moderators when they hunker down and lower the accruing technical debt seen creeping around the forums.



    Cheers!
    David Nist
    aging programmer
    http://www.davidnist.com
     
    #16 david nist, Sep 3, 2017
    Last edited: Sep 3, 2017
  17. Sheep

    Sheep Newbie
    Thread Starter

    Cant figure out how to delete this so it will just be here.
     
    #17 Sheep, Sep 8, 2017
    Last edited: Sep 8, 2017
  18. Sheep

    Sheep Newbie
    Thread Starter

    Thank you. All of you. Especially you, David for your words. I apologize if I acted arrogent or rude. I have no excuses but I see now that not everybody is like the people I meet on the street. You do care. So once again, thanks for the help. Next time I have any issues Ill calm down first and then describe it. Farewell.
     
Loading...
Similar Threads - Google Play still
  1. LewiH
    Replies:
    4
    Views:
    323
  2. justamel
    Replies:
    3
    Views:
    481
  3. Happy App Lab
    Replies:
    1
    Views:
    672
  4. Gerard van Beek
    Replies:
    11
    Views:
    1,181
  5. Tobbe237
    Replies:
    3
    Views:
    906
  6. Scadica
    Replies:
    0
    Views:
    637
  7. CJ Melhorn
    Replies:
    2
    Views:
    938
  8. Valeriev
    Replies:
    0
    Views:
    878
  9. ozonetrooper
    Replies:
    5
    Views:
    993
  10. samaspotion
    Replies:
    4
    Views:
    1,312

Share This Page

Loading...