1. Are you ready for the Galaxy S20? Here is everything we know so far!

Google Playstore is not showing icons of apps on Wifi only

Discussion in 'Android Apps & Games' started by Muhammad Uzair 712, Aug 16, 2019.

  1. Muhammad Uzair 712

    Thread Starter

    I'm using Motorola Droid Turbo and when i open play store for downloading apps it does not shows the icons of apps that are installed and that are on store for download but it only happens when i'm on Wi-fi but when i'm using mobile data it works fine all icons are displayed.And when i use Vpn on Wi-fi it displays icons.Recently i have switched to new ISP after that it started to happen on all mobile phones in my house.
    WhatsApp Image 2019-08-17 at 12.50.08 AM.jpeg WhatsApp Image 2019-08-17 at 12.50.09 AM (1).jpeg WhatsApp Image 2019-08-17 at 12.50.09 AM.jpeg WhatsApp Image 2019-08-17 at 12.50.10 AM (1).jpeg WhatsApp Image 2019-08-17 at 12.50.10 AM.jpeg

     


  2. Best Answer:
    Post #7 by MoodyBlues, Aug 19, 2019 (1 points)

    1. Download the Forums for Android™ app!


      Download

       
  3. Dannydet

    Dannydet Extreme Android User

    I think it's a bug with your vpn, and Google servers
     
    ocnbrze, mikedt and MoodyBlues like this.
  4. svim

    svim Extreme Android User

    Wow, that is odd. Try all the basic steps first, restart your phone and your router. Since this missing icon issue does appear to be tied to your home WiFi network, focus on that. You should also try wiping the cache for the Google Play Store app and the Google Play Services app.

    If after all that the problem is still occurring, you should look into your router's settings menu. What kind of router do you have, is it an ISP-supplied modem/router unit or do you have your own separate router?
     
    mikedt and MoodyBlues like this.
  5. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member

    This seems very suspicious. It could, of course, simply be a coincidence, but... *shrug*
     
    ocnbrze and mikedt like this.
  6. mikedt

    mikedt 你好

    Actually it sounds to me like the VPN and Google is working correctly, as the icons are showing with the VPN. Because I know if I don't use a VPN, I see absolutely nothing from Google Play.

    I suggest the problem is almost certainly with the new ISP as all connected devices are affected. Maybe a problem with their routing or local caching? A misconfigured firewall?

    OP did you reset your router after switching ISP?
     
    #5 mikedt, Aug 16, 2019
    Last edited: Aug 16, 2019
    MoodyBlues, Dannydet and ocnbrze like this.
  7. Muhammad Uzair 712

    Thread Starter

    i have tried everything resetting router to factory defaults and even updated the Firmware but nothing seems to be working.And i am using TP-Link WR740N router. I have also factory reset my phone but still the problem continues.
     
    #6 Muhammad Uzair 712, Aug 19, 2019
    Last edited: Aug 19, 2019
  8. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member

    Since all your devices are affected, AND this problem began after changing ISPs, my advice is to contact the ISP. They should be able to do some troubleshooting, but more likely they'll need to send a technician out to diagnose the problem.
     
    Muhammad Uzair 712 and Dannydet like this.
  9. Muhammad Uzair 712

    Thread Starter

    I'll ask them to look into this problem.Thank you all for giving smart suggestions.
     

Play Store

Play Store Forum

com.android.vending

READ MORE
Last Updated
Rating
Installs
Loading...

Share This Page

Loading...