1. Are you ready for the Galaxy S20? Here is everything we know so far!

Google seems to be randomly refusing non google game log in to google play games

Discussion in 'Android Apps & Games' started by uno111, Jan 23, 2020.

  1. uno111

    uno111 Newbie
    Thread Starter

    And the cause is mysterious. {NOTICE: Just because this is a non google play store game, does not make it bad}

    I have an android game (uno 1.1.1) that I've had for years and which is still available from many safe apk download sites, just not from the google play store anymore (I think the big money owner of Uno threw a fit and wants people to use their awful app full of ads).

    Merely not being in the google play store does not mean an app or game is bad and there are lots of good things you can't find on the google play store and this is becoming more and more the case as google enacts bad rules only designed to maximize profit (while telling people it's about "security"). As most people know, google behaves like an exclusive club for its own profit. Most games that google allows on its play store, seem to be forced to allow very intrusive and time consuming ads.

    Anyway, If I use a google account that has already been given the permission screen to log into google play games/games services for this particular game I enjoy, I can still play this game with anyone in the world on some devices. BUT, I have had zero success when a device gives me "license check failed" after some mysterious and seemingly random failure to log into google games services by the game itself. I can't find a rhyme or reason to this and I can't find anyone willing to do a little effort to help.

    I can't find any consistency with this problem. For example, some devices allow me to play this game with players around the world and some devices, even if I'm using a google account I've already played this game with on another device, still give me "license check failed" gray box and can't log into games services. I can't figure out if this is related to the device because I have a new device that thankfully allows my wife and I to play.

    I've followed various online theories that it has something to do with a particular version of the google play store, but as I said, I can play this game with a year old device with a fully current version of the play store and other google apps. What I need is someone willing to go to a little effort to dissect this problem.

    Google is just awful and only wants us using things IT approves of on its little play store. Any helpful advice with this would be appreciated.

    Please, I would greatly appreciate it if a few people would take the time to test the game I'm talking about with their google account and help me out. In the past I've had people just be dismissive and say "too bad, just stick to the google play store."
     

    Advertisement

  2. mikedt

    mikedt 你好

    FYI game publishers can lockout old and unsupported versions of their games from online play. So I guess Mattel has done this for Uno version 1.1.1. And quite frankly I don't think there's much you can do, except update. Did you pay any money for it originally?
     
  3. uno111

    uno111 Newbie
    Thread Starter

    Sir I already said I can continue to play the game on some devices. One thing that is making this so difficult is that people aren't listening to what I'm saying.
     
  4. Rob

    Rob I'm tellin' mommy on you!
    Administrator

    Which devices CAN you play on properly?
    Which devices can you NOT play on properly?
    What versions of Android are these devices running?

    @mikedt has a valid point... the developer could have made the game refuse connections to certain device types with certain specs that fall below their minimum threshhold.

    Developers need to make games that work with THOUSANDS of different devices which is nearly impossible. Rather than try to make it work perfectly on all of these devices, they will often intentionally prevent specific categories of devices so that they don't offer a bad experience.

    Examples would be your screen size is too small, your Android OS version is too old, the device is rooted, etc...

    Knowing what devices you are trying the game on, which devices it's working on, and which devices it's not working on is fundamentally important to figuring it out. Nobody can magically know why. You're asking for people to take the time to help you out... I don't think it's ridiculous to answer a few simple questions that will help them help you.

    I also don't think you're going to find anybody to download the app if it isn't on the Google Play Store unless it's on a proven and trusted 3rd party app market. Personally, I wouldn't touch it... but that's just me.

    Best of luck!
     
    Milo Willamson and mikedt like this.
  5. puppykickr

    puppykickr Android Enthusiast

    Have you tried an app store like ApkPure or UpToDown, where you can download old versions of apps?

    Google won't let you do this on mobile devices, but the two I mention will.

    This won't ensure that you can play online, but it could help by getting the app from somewhere else.

    Google swears up and down that Narcos, Cartel Wars is incompatible with my device.
    I check, and my device meets all the requirements.
    Google responds with crickets (typical) and so I contact the game developers.
    They also say that my device is incompatible, but cannot (willnot?) tell me why.

    But I look on ApkPure, and there is the game and I download it and it works just fine.
    It goes through Google Play Games, and it works flawlessly.

    Like I said, there are no guarantees, but it might work.
     
  6. uno111

    uno111 Newbie
    Thread Starter

    I'm not having a problem getting uno 1.1.1. Does this game play on your device for playing random players?

    The problem is getting it to work on my Samsung android 8 device that it USED to work on.

    I can play uno 1.1.1 on my Samsung android 4 and Samsung android 9 devices.

    EDIT: I tried to start as a developer on apkpure but couldn't figure out how to make a valid "package ID"
     
    #6 uno111, Jan 24, 2020
    Last edited: Jan 24, 2020
  7. Rob

    Rob I'm tellin' mommy on you!
    Administrator

    Can you tell us exactly what devices they are?
    • Which device is running Android 4?
    • Which device is running Android 8?
    • Which device is running Android 9?
     
  8. uno111

    uno111 Newbie
    Thread Starter

    I have three Samsungs, one running android 4 (allows me to play people this game)

    a Samsung running android 8 that used to allow me to play this game but now the game can't sign into games services for some unknown reason (the core of why I need help).

    And a Samsung running android 9 that plays this fine.
     
  9. puppykickr

    puppykickr Android Enthusiast

    I knew what you meant.
    My suggestion was rooted in my belief that there may be a slight difference in the app itself if you got it from a different source.

    For instance, if I get an apk of Narcos, Cartel Wars from Google Play Store, it will not install onto my device.

    If I get the apk from Apk Pure or UpToDown, it installs and works just fine.

    This issue may or may not also be caused if you don't have the most recent version of Google Play Services installed on that particular device.

    After all, you said that it works on some devices and not others, and used to work on the one in question.
    A difference in Play Services (newer or older) could be the problem here.

    Also, I checked the version history on both of the other app stores, and neither of them go back to version 1.1.1

    So my guess is that version is being phased out and you will either need to pick another online UNO game you can live with, or update the one you have (I would suggest using an older update- the oldest one that will work- I do the same thing to avoid ads).
     
    mikedt likes this.
  10. mikedt

    mikedt 你好

    puppykickr likes this.
  11. puppykickr

    puppykickr Android Enthusiast

    That was the oldest version on the other two as well.
     
    mikedt likes this.
  12. uno111

    uno111 Newbie
    Thread Starter


    Those are different "versions" of the game with the same name but they aren't different versions of the app I've used for years. Those are entirely different apps.

    I've downloaded my 1.1.1 for years from these sites for various devices:

    https://www.apkmirrordownload.com/apk/classic-uno-1-1-1-5-apk/

    https://apkfab.com/classic-uno/in.prateekchandan.classicUno

    https://classic-uno.en.aptoide.com/?store_name=paul-julian-gould&app_id=34305674 (I avoid this version so as to not be stuck with the aptoide app)


    I didn't start having problems on android 8 devices until a "security" update about a year ago.

    apkmirror.com doesn't have my version that I play with many friends. I have no way of telling them to switch versions.
     
    #12 uno111, Jan 25, 2020
    Last edited: Jan 25, 2020
  13. mikedt

    mikedt 你好

    FWIW out of the kindness of my heart, I just tried the 1.1.1 version you posted on my Huawei with Android 10. Yeh "License check failed" and it's locked out. So apart from using a supported version of Uno, I can't see there's much else you can do. And any gripes should be addressed to Mattel and/or Netease Games. Good luck.
     
    #13 mikedt, Jan 25, 2020
    Last edited: Jan 25, 2020
    puppykickr likes this.
  14. puppykickr

    puppykickr Android Enthusiast


    Well, other than the version number, you didn't give us much to go on considering the number of 'Uno' games available.

    So it was a shot in the dark to figure out which one it was.

    Anyway, perhaps if it is that important you can find an older (or whatever makes it compatible) device to play the game with. This could even become your dedicated gaming device- freeing up memory and resources on your other devices.

    Of course, if you were willing to invest that much cash into it, maybe updating to the newest version and paying the developer(s) for an ad-free version might be in order.
    (You did say that you have enjoyed the game for years- for free- correct?)
    This is the delima we all face over time:
    Apps get updated, and either we adapt one way or another or move on to other apps.

    Eventually either our devices give out or the apps become unuseable.

    To lose contact with people that you have played with for years can be disheartening, almost like losing a long term friend.

    If there is no chat feature in your version, there probably is in the newest. This would be a way to contact your game mates.

    And it is common for a 'security' update to have nothing to do with your security. (My opinion.) It could be anybody's security, or nothing about security at all. (Again, my opinion.)

    You did say that certain devices can still use your version, though, right?

    You could do some device rearrangement, even as annoying as this can/would be.
     
    mikedt likes this.
  15. uno111

    uno111 Newbie
    Thread Starter

    I sincerely thank you for doing that. Now you see what I'm talking about and if you figure it out, you will become a hero of mine. I'm still playing the same game on 3 devices (an old Kindle android 4, relatively new google account, a samsung android 4, old google account, and an android 10 samsung, old google account)

    Today I bought a new android 9 tablet and it still gives me license check failed while using a newish google account. In the past when I've tried it with a google account that I CAN play this game with other players with, it still gives me license check failed. So I think it's something obnoxious with google. Like an "old accounts only" situation.
     
    #15 uno111, Feb 4, 2020
    Last edited: Feb 4, 2020
  16. uno111

    uno111 Newbie
    Thread Starter


    You're right on all counts throughout your post except we have a samsung android 10 device with an older google account where this game works with other players.

    I've tried to get ahold of Pradeek Chandan (the original developer) to no avail. There is no ad-free version of this version.

    I was hoping that someone here who understood apps could maybe either figure out the problem or even update the apk and either give it to me or put it on google play again or one of the other apk sites.

    Today I bought a new android 9 tablet and it still gives me license check failed while using a newish google account. In the past when I've tried it with a google account that I CAN play this game with other players with, it still gives me license check failed. So I think it's something obnoxious with google. Like an "old accounts only" situation.

    I'm basically presenting a situation for someone who is REALLY up for a challenge.
     
  17. uno111

    uno111 Newbie
    Thread Starter

    One more thing everybody, I've already tried lucky patcher on the samsung android 8 device (newer google account) and still got license check failed.
     
  18. uno111

    uno111 Newbie
    Thread Starter

    UPDATE: Used an old account and got it to work on the brand new android 9 device, and google lets me select from the older account or the newer google accounts I tried on that device and ONLY the older google account works, so do you know what that means? That means google is purposely blocking newer accounts from using this game. Disgusting. How google.
     
  19. puppykickr

    puppykickr Android Enthusiast


    It sounds like some older accounts have been 'grandfathered' in for some reason- possibly some rule changes that have transpired over time that for one reason or other could not be retroactive.

    I would just keep the old account, and use it for this game.
    At least until they figure out a way to make that not work anymore.

    Trust me, I know all about Google trying to force unwanted updates for apps.
    It is one reason that I dislike and distrust Google so much.
     
    mikedt likes this.
  20. mikedt

    mikedt 你好

    Now is it actually Google doing this, or Mattel, or Netease. Do we know which servers is Uno 1.1.1 actually trying to communicate with, Google, Mattel, or Netease? Mattel is the rights holder to Uno, and Netease is the developer.
     
  21. mikedt

    mikedt 你好

    Yeh, you, me, and the govt of China. All dislike and distrust Google.
     
    puppykickr likes this.
  22. uno111

    uno111 Newbie
    Thread Starter

    PROBLEM PARTIALLY SOLVED!!!! MIKEDT PLEASE COME PLAY ME!!

    OK, no surprise it is all google's fault and their desire to bury settings in a way that favor their own pet apps.

    1. You must go into your google account and specifically push the selector to allow "less secure apps." Be patient because they BURIED it in the "security" section. It should be in google play games settings but it's not.

    2. You also must watch your gmail account connected to you google play account. Once you've allowed less secure apps, you MUST go to the security email about changing that setting and acknowledge that you changed the setting. Google REALLY doesn't want you changing that setting so they send you an alert that this has been changed.

    3. Mikedt, google probably sent you a notice to your gmail connected to whatever google account you tried to use when you tested this game, informing you of a blocked log in attempt. "License check failed" is a notice of a blocked log in attempt. I didn't always get this notice via gmail for other accounts.

    I am right now using a new google account on a device that I thought was hopeless (my samsung android 8).
     
    puppykickr likes this.
  23. puppykickr

    puppykickr Android Enthusiast

    I have had much difficulty with this same setting.

    Not only is it well hidden, but like all of my Google settings it likes to turn itself back off.

    That means that whatever apps that I may be using that require this setting to be on will just stop working.

    I have even received notice that if I dont respond to an e-mail that is periodically sent regarding this setting that Google will automatically turn it off.
     
  24. puppykickr

    puppykickr Android Enthusiast

    I dont know if I should be happy that I agree with the government of China on something, but ok. :)

    Isnt it true that they used Google's help to build their internet security and monitoring set-up?
     
  25. mikedt

    mikedt 你好

    I didn't get any notice of that. I do get email notifications if an unknown device is logging in.
     
Loading...

Share This Page

Loading...