1. Download our Official Android App: Forums for Android!

Support Google Services Framework force close

Discussion in 'Android Devices' started by broken1i, Aug 9, 2010.

  1. broken1i

    broken1i Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    70
    Joined:
    Jun 11, 2010

    Jun 11, 2010
    70
    7
    16
    "The application Google services Framework(process com.google.process.gapps) has stopped unexpectedly."

    Has anyone experienced this error message at all. It happens randomly and I get it at least 5-10 times a day.
     

    Advertisement

  2. SMC333

    SMC333 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    19
    Joined:
    May 18, 2010

    May 18, 2010
    19
    1
    16
    Mine is doing the same thing. really annoying. Anyone know how to fix this?
     
  3. SMC333

    SMC333 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    19
    Joined:
    May 18, 2010

    May 18, 2010
    19
    1
    16
    Trying another factory reset... I'll let you know if it works
     
  4. broken1i

    broken1i Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    70
    Joined:
    Jun 11, 2010

    Jun 11, 2010
    70
    7
    16
    Thanks smc, I did one and I still get it -__-
     
  5. SMC333

    SMC333 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    19
    Joined:
    May 18, 2010

    May 18, 2010
    19
    1
    16
    I think the problem was with mybackup and restoring contacts when they were already syned with google. this time I didnt restore contacts and just let google do it and Im not getting the pop up anymore. give it a try
     
  6. broken1i

    broken1i Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    70
    Joined:
    Jun 11, 2010

    Jun 11, 2010
    70
    7
    16
    ya but then I'd lose all my contacts -__-, there has to be another way I can back them up without using mybackup
     
  7. EarlyMon

    EarlyMon The PearlyMon
    Rank:
     #1
    Points:
    5,218
    Posts:
    57,632
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    57,632
    70,424
    5,218
    New Mexico, USA
    I'm confused - are your contacts not being saved by google?
     
  8. broken1i

    broken1i Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    70
    Joined:
    Jun 11, 2010

    Jun 11, 2010
    70
    7
    16
    They are but when you reload them using mybackuppro we receive this error. After googling I was able to find a solution. We had to delete contacts storage.

    So basically go to Settings > Applications > Manage Applications > Running tab > and delete Contacts Storage. Haven't gotten the error since.

    Here's the actual solution.

    Depending on what you get the error on (either contacts, gmail, or calendar), clear its data by going to Manage Applications/Running tab and deleting its storage. :]
     
    honeyb3 and p4andrews like this.
  9. adizz131

    adizz131 Member
    Rank:
    None
    Points:
    18
    Posts:
    54
    Joined:
    Aug 8, 2010

    Aug 8, 2010
    54
    18
    18
  10. landis76

    landis76 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Apr 5, 2010

    Apr 5, 2010
    2
    0
    5
    Is there a way to fix contact storage w/o deleting everything? Or can I back up everything somehow to restore later?
     
  11. jeanne64

    jeanne64 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 4, 2010

    Dec 4, 2010
    1
    0
    5
    I have the same problem as well. It either says "The application Google services Framework(process com.google.process.gapps) has stopped unexpectedly." or "The process com.google.process.gapps has stopped unexpectedly. Please try again". It'll pop up randomly, sometimes once a day up to several times a day. I already did a factory reset and still getting the same problems. My contacts aren't updating to gmail also, and when i try to sync it myself the I will definitely get one of the above messages. Anyone know how to fix this?

    HTC EVO
     
  12. chrs

    chrs Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    113
    Joined:
    Jan 15, 2010

    Jan 15, 2010
    113
    19
    38
    I had this problem and read pretty widely trying to find a solution and finally found one that worked for me on the Google Support Forum. Basically you sync calendar contacts and gmail individually to find which is the problem. Then you thorughly back up everything in that category, and delete everything from either google or the phone, and try to sync again. Then you can see how far in got in syncing--wherever it got it is a problem entry. For me it was a contact that had some weird non-ascii characters (corrupted data) in one field. After I deleted those fields, all worked again.
     
  13. raptorspike

    raptorspike Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    May 31, 2011

    May 31, 2011
    6
    0
    5
    chrs, how do you find out what causes that issue from the sync? Mine comes from the calendar, and I have hundreds of things on my calendar.
     
  14. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
     #13
    Points:
    1,923
    Posts:
    23,596
    Joined:
    May 13, 2010

    May 13, 2010
    23,596
    14,436
    1,923
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    try clearing out the calender cache and maybe try and power off then reboot.
     
    peosteve likes this.
  15. chrs

    chrs Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    113
    Joined:
    Jan 15, 2010

    Jan 15, 2010
    113
    19
    38
    I'm afraid I don't remember exactly what I did. At the time I was using lots of different methods to transfer data from the old Palm-based system I was using, and looking at them different ways, so I don't remember which I used to ID the problem, but I guess that it was exporting them from Google contacts to a csv file, which you can then look at in Excel or just a text editor. Another thing I was using that might be what it was is MyPhoneExplorer which directly syncs the phone to files on a PC without a cloud.

    With the calendar, you can do the same thing: export to CSV from Google, or use MyPhoneExplorer to get the data on a PC to look at (probably again export to CSV from MyPhoneExplorer).

    If all else fails you can try a binary search: try deleting half and see if it works. Then know which half the problem is in. Repeat until you have it narrowed down.
     
  16. jvdfw

    jvdfw Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 26, 2011

    Feb 26, 2011
    1
    0
    5
    This was happening to me too, on my Streak 7 running, honeycom rom,

    Go to settings-accounts&sync

    disable backround data and autosync!!!
    that worked for me




    JV
     
  17. Aim High

    Aim High Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 5, 2011

    Dec 5, 2011
    1
    0
    5
    Executive IT Support
    Saudi Arabia
    thanks adizz , this link was usefull , after following this my problem has been solved ,, thanks alott. was not a member of this forum , but now i became member just to reply and thank you ..
     
  18. markt23

    markt23 Lurker
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Dec 6, 2011

    Dec 6, 2011
    6
    1
    6
    I'm getting this but appears much worse than above. I cannot receive text messages or use the internet app. HTC EVO 4G. Anyone else have that issue?
     
  19. ngamtns

    ngamtns Lurker
    Rank:
    None
    Points:
    6
    Posts:
    4
    Joined:
    Apr 8, 2010

    Apr 8, 2010
    4
    1
    6
  20. peosteve

    peosteve Lurker
    Rank:
    None
    Points:
    6
    Posts:
    1
    Joined:
    Sep 20, 2012

    Sep 20, 2012
    1
    1
    6
    Turned off auto-sync from the settings for the calendar, cleared the cache from all the calendar apps, and then started sync again. Calendar went from empty with tons of popups to synced almost right away. This did the trick...
     
    ocnbrze likes this.
Tags:

Share This Page

Loading...