1. Are you ready for the Galaxy S20? Here is everything we know so far!

Google Voice incoming calls won't ring

Discussion in 'Android Devices' started by raudesign, Dec 13, 2021.

  1. raudesign

    raudesign Lurker
    Thread Starter

    Hi, I'm new to Android and tried to set up Google Voice. When I call my Google number using another phone, my Android phone only shows a notification, vibrates, but doesn't ring. My goal is to have it ring like a regular phone.

    All my devices are toggled to on (green) under "Calls > My devices". My iOS device and my Web browser both ring. I tried toggling all of them off, tested, and turned them back on, tested, it still did not ring.

    I tried removing "Linked numbers" and relink, it did not ring.

    "Devices and numbers" has the Android device listed.

    The phone is not on DND mode, my regular incoming calls ring.

    Google support says I can customize ringtones by going to Google Voice's "Settings > Calls > Incoming call notifications > Sound"; but there's no such option as "Incoming call notifications" under "Settings > Calls". There is "Message notifications" under "Settings > Messages" though.

    The Android phone can receive the calls by pressing "Accept" on the notification.

    In summary, when someone calls my Google number, my Android device only shows a notification and vibrates. I want it to ring, just like receiving a regular call, just like all my other iPhones and iPads and browsers. And again, all of them ring to the same call I made, the only device that did not ring is my new Android device.

    I thought Google on Android is supposed to be straight forward, but everything has been extremely difficult so far. I've spent hours on forums looking for answers as if I'm fixing Windows 95 in 1998 lol. Am I doing something wrong? Please help! TIA!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    What phone do you have?
     
  3. DonB

    DonB ♡ Truth, Justice and the American Way !! ♡ ™
    Moderator

    In settings, where it says incoming calls notifications, is that enabled ? and if it is, and if you don't see notification settings, scroll further down, see if you have an advance tab, if you do, hit that and check if it gives you notification options.

    If you still don't have these options, only other thing I would do is, clear cache, force close and then clear data, and start from fresh and see if that helps or works.
     

    Attached Files:

    • 1.jpg
      1.jpg
      File size:
      68.1 KB
      Views:
      34
    • 2.jpg
      2.jpg
      File size:
      144.3 KB
      Views:
      36
    • 3.jpg
      3.jpg
      File size:
      167.1 KB
      Views:
      33
    #3 DonB, Dec 14, 2021
    Last edited: Dec 14, 2021
    Dannydet likes this.
Loading...
Similar Threads - Google Voice incoming
  1. MartyDC
    Replies:
    6
    Views:
    232
  2. lennnn
    Replies:
    3
    Views:
    705
  3. MartyDC
    Replies:
    1
    Views:
    582
  4. Njem
    Replies:
    3
    Views:
    988
  5. kblanco
    Replies:
    7
    Views:
    1,401
  6. googlesucs
    Replies:
    1
    Views:
    2,605
  7. bubDozer
    Replies:
    3
    Views:
    2,731
  8. consultant
    Replies:
    2
    Views:
    912
  9. David Pesetsky
    Replies:
    1
    Views:
    993
  10. Doulos Adonai
    Replies:
    3
    Views:
    2,735

Share This Page

Loading...