1. Download our Official Android App: Forums for Android!

Google Voice - No Texts/Voicemail Notifications all of a sudden

Discussion in 'Android Apps & Games' started by surfer513, Nov 7, 2010.

  1. surfer513

    surfer513 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Nov 7, 2010

    Nov 7, 2010
    3
    0
    5
    I'm having a problem that just started today for some reason (maybe I messed something up). I've been using Google Voice for texting as well as sending/receiving phone calls. Up until today, whenever I got a text message it notified me through Google Voice app on my phone. The same thing with voicemails.

    But what happened today is that it isn't notifying me for some reason. To actually "receive" the text messages and voicemails through Voice, I have to go into Google Voice app and hit "refresh".

    Under "sync and notifications" for settings in Voice, I have "synchronize inbox" checked as well as "inbox notifications" so that I'm notified in the status bar when new items arrive.

    And like I said, up until today it was working flawlessly, but now I have to hit "refresh" to receive them in Voice.

    Any ideas what could be causing this and what the fix may be?
     

    Advertisement

  2. Clementine_3

    Clementine_3 Android Expert
    VIP Member
    Rank:
     #28
    Points:
    993
    Posts:
    4,987
    Joined:
    Nov 16, 2009

    Google had/is having issues with Google Voice, it started last week and has apparently reared it's ugly head again. Service has been sporadic at best lately for some.
     
  3. surfer513

    surfer513 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Nov 7, 2010

    Nov 7, 2010
    3
    0
    5
    Ok, so what you're saying is that it's not the actual configuration on my droid 2 that's causing this? It's just Google problems right now that'll resolve itself soon?
     
  4. Clementine_3

    Clementine_3 Android Expert
    VIP Member
    Rank:
     #28
    Points:
    993
    Posts:
    4,987
    Joined:
    Nov 16, 2009

    AFAIK, yes. Your settings are right and unless you changed something I'd go with "blame it on Google".
    I've not have any issues (now I've cursed myself) but my sister has, she is not getting texts and could not make calls using GV on Friday.
    I've read a few articles over the past few days about it...
     
  5. amlothi

    amlothi Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,185
    Joined:
    Jul 23, 2010

    Jul 23, 2010
    1,185
    201
    143
    Just to confirm:

    Mobile data is set to always be on?

    Background data syncing is enabled?


    You need to have an always on data connections to allow Google Voice to get notifications. If not, it will only happen when you manually connect/sync.
     
  6. surfer513

    surfer513 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Nov 7, 2010

    Nov 7, 2010
    3
    0
    5
    I think those are both enabled. (I have the Droid 2) In Data Manager/Data Delivery I have "Background Data" and "Data Enabled" both enabled. That's correct, right?
     
  7. amlothi

    amlothi Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,185
    Joined:
    Jul 23, 2010

    Jul 23, 2010
    1,185
    201
    143
    I also have a setting for "Background Data" under Accounts & Sync settings.
     
  8. droidfancy

    droidfancy Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 5, 2012

    Feb 5, 2012
    1
    0
    5
    I had the same problem - no notification when receiving a text in Google Voice. It used to work fine but recenI started to miss incoming texts due to no notification. I fixed it by setting GV to only keep text in Gv and not sent to Messaging.

    In gv settings, go to Sync and Notification, Receive Text Messages, and select Only Via the Google Voice app. This fixed it instantly.

    I also re-installed gv before doing this, but that didn't make a difference.
     

Share This Page

Loading...