1. Download our Official Android App: Forums for Android!

Tips Got a question? Need Help?

Discussion in 'Android Devices' started by 916x10, Sep 30, 2011.

  1. 916x10

    916x10 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    73
    Posts:
    491
    Joined:
    Nov 13, 2010

    Nov 13, 2010
    491
    65
    73
    Please make sure to include the following info whenever you're asking for help, it will expedite the process.

    Firmware version
    Kernel version (if not stock)
    Rooted, yes or no
    Any other mods/tweaks

    Too many times people are asking for help and we don't know that info and either people assume what you have/don't bother to help cause you didn't provide this necessary info/or have to ask you for it. Include this info and not only will you get a more accurate answer, it'll probably come quicker and might be more of it as well :)
     

    Advertisement

    Sam-SonyXperia likes this.
  2. Merolas

    Merolas Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    413
    Joined:
    Aug 3, 2010

    Aug 3, 2010
    413
    29
    43
    Male
    IT consultant
    Montreal
    vote for sticky!
     
  3. 916x10

    916x10 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    73
    Posts:
    491
    Joined:
    Nov 13, 2010

    Nov 13, 2010
    491
    65
    73
    Agreed!
     
  4. Jonince

    Jonince Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Nov 15, 2011

    Nov 15, 2011
    5
    0
    5
    IT Consultant
    North East
    HI there........Completely new to this forum looking for answers after and Xperia X10 upgrade to 2.3.3...
    So Android 2.3.3
    Baseband 2.1.71
    Kernel 2.6.29-00054-g5f01537
    Build Number 3.0.1.G.0.75

    Hope that helps........Ok the Problem..It constantly powers itself off which didn't happen before the upgrade.

    Scrolling through fotos in media....go too fast it powers off.
    Taking photos quickly in succession: Powers off
    Dialling my provider with short cut phone number and using theor menus: Powers off

    Sometimes you power it straight back on and it comes up..thinks about it for 20 seconds or so then powers off again. Battery out sim out wait a minute...back in power up...comes up and stays up.

    Wehn just in standby...lasts for ages without recharging..full day at work come home still 93% battery.......Use it for anything like photos or anything that's not a call...10 minutes and the power is down by 50%......Use the application monitor and it tells me the biggest user of battery is the screen....i have normal settings and volume same as in call. I don't walk around with bluetooth on, wireless is off unless i am using router at home for internet which is very infrequent so i think my settings are minimal and should promote maximum bateery conservation.......naht !

    But the most important issue to me is the Powering off. Someone suggested a damaged or corrupt file on the mini SD card...about 250 photo's resident on there..none seem to have an issue..downloaded them off the card...still happens so i don't think it's camera related..so three occurences to date where powering off occurs
    1. Scrolling Photos on phone
    2. Taking sequential photos back to back
    3. Using menu driven feature during a call.

    any ideas......
     
  5. stocker

    stocker Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    75
    Joined:
    Jun 3, 2010

    Jun 3, 2010
    75
    3
    16
    Canada
    After you did the upgrade, did you go through a battery calibration?
     
  6. beau420

    beau420 Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,104
    Joined:
    Nov 10, 2010

    Nov 10, 2010
    1,104
    173
    143
    Computer Guy
    Ottawa
    After upgrading to 2.3 very few people do a Factory Reset, which are part of the upgrade steps from 2.1 to 2.3.

    Back everything up on the phone. Contacts and whatnot.

    Then do a Factory Reset.

    Don't install any other apps for an hour or so.

    Now mess with the phone after the factory reset and see if you can crash it....make it reboot.
     
  7. Adam A

    Adam A Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 22, 2011

    Nov 22, 2011
    1
    0
    5
    Hey, all i know it that i got a X10, not sure what the other things ur askn for. Got a question, i just recently had the newst software loadd in2 my fone n now when i go in2 the calender then try 2 add a new event it comes up with NO CALENDERS! then tells me 2 go to Settings > Account & Sync> Add Account, to add account & sync calender, n when i do theres nothn to do with a calender n still cant add any events to the calender. Any ideas?
     
  8. Jonince

    Jonince Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Nov 15, 2011

    Nov 15, 2011
    5
    0
    5
    IT Consultant
    North East
    Ok Guys ...thanks for your varied replies all of which were valid.....however i went to my phonestore (Vodafone)...They ran a diagnostics on the phone after i described the problem and came up with 4 fault codes..Guess what...some of the Android 2.3.3 software was missing and had not been installed. So not a hardware problem with the Xperia X10i but a faulty 2.3.3 upgrade.....3 hours later and at no cost to me..phone back...everything working and no more power offs...(I'll update again in a week just to confirm everything is still ok with the unit)....
     
  9. Sam-SonyXperia

    Sam-SonyXperia Android Expert
    Rank:
    None
    Points:
    153
    Posts:
    1,042
    Joined:
    Jun 14, 2011

    Jun 14, 2011
    1,042
    151
    153
    Just to confirm, you did go to the Accounts & Sync section and set up a valid Gmail account? If you did and this problem continues I would advise running a repair via PC Companion.
     
  10. Jonince

    Jonince Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Nov 15, 2011

    Nov 15, 2011
    5
    0
    5
    IT Consultant
    North East
    Hi There.......My Xperia continued it's powering off traits after the Android 2.3.3 was repaired by my local Vodafone store. Same stuff day in day out...seems to stay on a bit longer if you start with a max charged battery...So took it back in again and looking at their diagnostics form i was thinking along the lines of a replacement battery would be all they would do....A week later got the phone back with the resolution being to completely re-flash the android 2.3.3 onto the phone...I lost all my apps but no bother as 99% of them were free anyway. Lost all the contacts on the phone as well but had them backed up anyway....So far so good. I had a good play re-associating photos from the memory card to the contacts that had lost them. Sent some post new year happy new year txts..took some photos, browsed the web...seems to be hanging together now...will post again in a week to let you know but looks like a re-flash of the 2.3 Android software has done the trick....Good luck to you all.
     
  11. Jonince

    Jonince Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Nov 15, 2011

    Nov 15, 2011
    5
    0
    5
    IT Consultant
    North East
    So 6 days in after return to home re-flash of Android 2.3 and it has not powered off on it's own once. Stable device once more. A subtle difference noted in the mediascape software so maybe this was the cause and has been addressed. But as advertised elsewhere on this forum there are no more further updates planned for the xperia X10i...so this is it. My contract is up in a couple of months but at least i now have something with a resale value instead of a door stop !
     
  12. Ca5p3r69

    Ca5p3r69 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    20
    Joined:
    Dec 22, 2011

    Dec 22, 2011
    20
    0
    15
    Male
    Sydney
    my Xperia X10a just stays on the begining screen n says sony ericsson it will not go to the next screen to ask for my pin i have to pull out the battery eventually i have lefted like that for ages and nothing it just happen out of nower has ne1 had dis problem ??? ne clues on wat to do ????
     
  13. Sam-SonyXperia

    Sam-SonyXperia Android Expert
    Rank:
    None
    Points:
    153
    Posts:
    1,042
    Joined:
    Jun 14, 2011

    Jun 14, 2011
    1,042
    151
    153
    Try running the Update Service (don't worry this is done with the phone powered off)

    http://dl-www.sonyericsson.com/cws/download/1/110/61/1323075336/Update_Service_Setup-2.11.12.5.exe
     
    Ca5p3r69 likes this.
  14. Ca5p3r69

    Ca5p3r69 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    20
    Joined:
    Dec 22, 2011

    Dec 22, 2011
    20
    0
    15
    Male
    Sydney
  15. Ca5p3r69

    Ca5p3r69 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    20
    Joined:
    Dec 22, 2011

    Dec 22, 2011
    20
    0
    15
    Male
    Sydney
    Hey the update has stuffed up the sd card sync , it wont read any sd cards wat do I do ?
     
  16. Sam-SonyXperia

    Sam-SonyXperia Android Expert
    Rank:
    None
    Points:
    153
    Posts:
    1,042
    Joined:
    Jun 14, 2011

    Jun 14, 2011
    1,042
    151
    153
    This generally means the update did not install correctly, I would advise running it again.
     
  17. Jonince

    Jonince Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Nov 15, 2011

    Nov 15, 2011
    5
    0
    5
    IT Consultant
    North East
    OK guys..it has been several weeks now and i am happy to report my "re-flashed" Android 2.3.3 is once more a stable platform. No hangs, no power offs, decent battery longevity, no issues.........So i guess it's fixed. So a little redemption for Sony-Ericsson....but not much as it's the hard works of experts on these forums that leads to the right advice being given and followed. I am once more happy with my Xperia X10i.....woo Ha !
     

Share This Page

Loading...