1. Download our Official Android App: Forums for Android!

Support Got the latest Swype on my SGS!

Discussion in 'Android Devices' started by psommerfeld, Oct 22, 2011.

  1. psommerfeld

    psommerfeld Member
    Thread Starter
    Jan 4, 2011

    Jan 4, 2011
    Ontario, Canada
    FINALLY! I've gotten sooo sick of the factory Swype, I couldn't take it anymore and spent two half-days figuring out how to get the latest Swype on my Galaxy S. Here's how I did for anyone interested.

    To install Swype Beta on to a phone that came factory-installed you have to jump through the hoops. The steps are:
    1. Must get a Swype Beta account.
    2. Must root the phone.
    3. Must remove existing Swype.
    4. Install swype Beta

    Here we go!

    Go to beta.swype.com. At bottom of page, click Register, fill in info, and follow the email that was sent.

    I was not successful rooting with z4root, so I used One-Click Root which worked after jumping through some hoops.
    2a. Enable Settings>Applications>Unknown sources. This lets you install non-Market apps.
    Before rooting, I had to get the "3e recovery mod". No idea what this is for, but anyways I had to go through otherwise rooting failed.
    At the bottom of this post, check out [1] for where I originally got this from.
    Get the 3e recovery mod from http://dl.dropbox.com/u/19201431/Files/3e_fix-Unzip-ClickInstall.zip and install
    2c. Make sure phone is in USB debug mode: Enable Settings>Applications>Development>USB debugging.
    2d. Connect phone to Windows PC. (Ensure your Samsung drivers are working properly).
    2e. Open a DOS command window. Run install.bat that is part of the 3e fix. Follow the instructions.
    2f. Reboot
    2g. Install Microsoft .NET Framework v4, which the root tool needs, from Download Details - Microsoft Download Center - Microsoft .NET Framework 4 (Web Installer) [2]
    2g. Get One-Click Root from MEGAUPLOAD - The leading online storage and file delivery service
    2h. Since I have 2.2 kernel, I run rootme2.2.bat [3] (I was not able to run the GUI .exe; it always fails on Windows PC; the .bat works fine).
    NOTE: if you have 2.1 or 2.3 kernel, google stuff about one-click, you'll get lots of info
    2i. Follow the instructions.

    Now that your phone is rooted, remove factory Swype:
    3a. Get Titanium Backup from the App Market (free version is fine), install and run. Give super user access when it asks for it.
    3b. Select Backup/Restore button at top, and fine Swype in the list.
    3c. Backup Swype, and then Un-install it.
    3d. Using a file browser, ensure that /system/lib/libswypecore.so or any *swype* files have been removed.
    3e. Reboot

    Get Swype Beta:
    4a. On your phone, go to beta.swype.com, and log in.
    4b. Download the Swype installer and run.
    4c. The Installer will prompt for a few things and then install the real Swype package. Install and run.
    4d. Change keyboard type back to Swype, go to your personal dictionary and find all the crap the old Swype version added and if you are like me, you will probably delete almost all of it.

    You're done!!! The new Swype (just got 3.26.92) is SOOOOO awesome! Such an improvement!

    What problems might YOU encounter?
    - Issues getting root. I had all sorts of issues, but the sequence I did works fine now. There's people on here way more versed in this stuff than I am.
    - The new Swype may fail to install. Make sure you reboot before doing this. Some people say they have to clear the davlik cache; I didn't have to.

    [1] [how-to][condensed]e:signature verification error/aka 3e recovery mod and workarounds - xda-developers
    [2] How To: Root And Unroot Samsung Galaxy S i9000 With A Single Click
    [3] Galaxy 3 GT-i5800: root, gps fix, lagfix, upgrading (JPM/JPD fw) - Page 2 - xda-developers


Share This Page