1. Are you ready for the Galaxy S20? Here is everything we know so far!

GPS doesn't work.

Discussion in 'Android Devices' started by JamesBwoii, May 21, 2011.

  1. JamesBwoii

    JamesBwoii Lurker
    Thread Starter

    Ever since I have had my DHD GPS has never worked. I have waited hours and hours but it always says "searching for GPS". I read some where that using "GPS Stauts" might fix it but it didn't. How do I fix it?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member

    Try this -

    Taken from a thread a while back.
     
  3. JustByZero

    JustByZero Newbie

    Mine worked for ages then a few days before 2.3 was released it stopped working, which was a bugger, but as soon as I did the update it started working again. Not sure to this day why it stopped, but I have seen before the post above works. Good luck :)
     
  4. JamesBwoii

    JamesBwoii Lurker
    Thread Starter

    I tried that and it worked with no sim in, but soon as I put the sim in and tried it didn't work...
     
  5. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member

    If you have Use Wireless Networks checked, do the above, then uncheck Use Wireless Networks, see if that makes a difference.
     
  6. monkeyhanga

    monkeyhanga Lurker

    Mine stopped working too.
    I sent it back to HTC who fixed it and it works fine and dandy now.
    I could only get a really poor signal. I compared signal strength with my wife's wildfire which had good signals using gps status
     
  7. Omar Days

    Omar Days Android Expert

    If you're using a protective case, then try finding a gps signal without it.

    Ive had my dhd since dec and could never get a gps lock on. Without the case I can even get a gps signal indoors. As soon as I put the case back on and try and find a signal it fails.
     
  8. Garyp5957

    Garyp5957 Lurker

    Hi everyone.

    Im seriously struggling to find any gps signal at all! Ive tried every method possible that ive read about and yet i still cant get a lock on.... I have used GPS Status which at best gets a fix on 2 Sats but when i open Google Latitude i can sit for hours waiting for it to get a fix but to no avail. Im getting really frustrated with it now and as much as it pains me to say it, perhaps wishing i got an iphone. :(
     
  9. anandv76

    anandv76 Well-Known Member

    same problem here too, 2.2.1 (yes the buggy version) used to find a lock within 10 secs even without agps. whereas now my phone doesnt even see a satellite. strangely, it could see 8 satellites this morning but wouldnt lock even after a few minutes, and now complete blackout. wonder what is wrong with it. any ideas?
     
  10. anandv76

    anandv76 Well-Known Member

    and this morning, i the phone again started seeing some satelllites giving me hope. at one point it was seeing 9 satellites but funnily all of them with weak signal strength that none would lock. and then right in front of my eyes and without me moving an inch or changing the orientation of the phone, each satellite the phone saw started disappearing and then there was none. i took out my trusted n95 and even that could see a more than 5 satellites and in fact even got a lock in about a minute or so. given that even the n95 could get a lock and my dhd with the spanking new gingerbread on it couldnt (whereas it did so withink 10 secs with the buggy froyo!) makes me believe that htc have completely effed the update this time too. i dont think the phone is navigation suitable anymore with the current firmware...pity, and i thought nokia were bad...
     
  11. savage_henry

    savage_henry Lurker

    I had the same problem and after a long search online i found a fix which has worked for me

    Go into your settings > wireless & networks > mobile network > access point names > 'provider' internet (mines orange internet) > scroll to the bottom and under APN type is should say 'default' > open and add at the end ',supl' so it now reads 'default,supl'

    After this fix my gps finds a lock within 30secs when im outside and normally 1 min when im inside

    Hopefully it will help some of you
     
    anandv76 likes this.
  12. anandv76

    anandv76 Well-Known Member

    i searched on the internet for possible solutions and also spoke with the customer care at htc, who suggested a soft reset by removing the battery and if it failed, a full factory reset. the former was easy and i did that but the latter would have meant a full backup of everything i had on the phone and restoring once factory reset was complete. i wasnt up for it, and searched the internet a bit more for solutions. and eventually found one that sounded absolutely ridiculous to start with. however, with no other choice left i did what i read which was to give your handset a (few) gentle whack(s) against your palm. and i couldnt believe what i saw. almost instantly the phone was seeing 11 satellites (up from 3/4 before the whack) but couldnt still get a lock. this was perhaps of the soft reset which had cleared up the gps cache too. so i came back home, went outside to the balcony, put the phone on a flat surface and in a few minutes got a lock. the phone now sees many satellites and has signal strength > 25 for most. anyone else want to try this and confirm? if this is true and works for all/many, i would be really be shocked...

    edit: well not shocked, but you understand what i am trying to convey.
     
  13. SB13X

    SB13X Android Expert

    Anyone found a reliable fix for this as I have tried the threads mentioned and applied their updates via CWM, used GPS Status and FasterFix apps to no avail. I'm banging my head against a brick wall. When I do manage to get a fix I have to be stood in the middle of my back garden and even then its 6-9 sats at best with crap signal?
     
  14. denialnw10

    denialnw10 Guest

  15. Xyro

    Xyro 4 8 15 16 23 42
    Moderator

    Am I right in thinking there aren't any void stickers that get broken when you remove the rubber with the LEDs in it?
     
  16. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member

    I don't believe so. If you look from roughly 1:57 in the vid in stublake's post here, you'll see that the GPS cover is the 1st bit they take off when the phone is disassembled. So even if there were void stickers, they'd be pointless as HTC would have to break them when they took the phone apart for repair anyway.
     
  17. denialnw10

    denialnw10 Guest

    Definitely no void stickers...

    ...And 24 hours later I can still get a fix of 7 satellites when I'm indoors within 20 seconds. I cannot believe the transformation.


    :D
     

HTC Desire HD Forum

The HTC Desire HD release date was October 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 768GB RAM, Snapdragon S2 processor, and 1230mAh battery.

October 2010
Release Date
0
Reviews
Loading...
Similar Threads - GPS doesn't
  1. jsmith50
    Replies:
    4
    Views:
    310
  2. Six dots Software
    Replies:
    3
    Views:
    267
  3. App Update
    Replies:
    0
    Views:
    432
  4. Sinnie
    Replies:
    2
    Views:
    619
  5. ocnbrze
    Replies:
    13
    Views:
    814
  6. App Update
    Replies:
    0
    Views:
    327
  7. Raza Shaikh
    Replies:
    0
    Views:
    369
  8. App Update
    Replies:
    0
    Views:
    483
  9. Raza Shaikh
    Replies:
    1
    Views:
    605
  10. haniya
    Replies:
    0
    Views:
    733

Share This Page

Loading...