1. Are you ready for the Galaxy S20? Here is everything we know so far!

GPS issues after 2.1 Update

Discussion in 'Android Devices' started by bikedogrun, May 24, 2010.

  1. bikedogrun

    bikedogrun Member
    Thread Starter

    Deja Vu all over again... I know I replied earlier in another thread that everything since the 2.1 upgrade has been great - but sadly; that is no longer true.

    We took a trip over the weekend and suddenly the GPS is taking forever (like 2 minutes) to find current location and half the time not even able to. We had a Droid (also on 2.1) along and it had no problem immediately getting GPS links in all of the same exact locations.

    Sad... been loving my Moment and 2.1 but this is a SERIOUS issue??? :(

    /BD :cool:
     



    1. Download the Forums for Android™ app!


      Download

       
  2. colettak

    colettak Lurker

    I am also having problems with my gps. Mine NEVER connects, however, and only does assisted gps. They're replacing my phone, so we'll see if that fixes the issue.
     
  3. pastafarian

    pastafarian Pâtes avec votre foie

    I've had some issue with the tower location being off more with 2.1 than cl14, but the GPS works like before (as in weak reception). Early on, I had some part of the GPS system in the phone fail entirely requiring a replacement phone. It started with the GPS taking longer and longer to lock till it didn't lock at all.
     
  4. paulohdz

    paulohdz Lurker

    I thought that getting the update would make my gps on the moment work just as great as my wife's PRE. I was wrong. its frustrating for the GPS to never work.
     
  5. Gremlyn1

    Gremlyn1 Well-Known Member

    The only issue I've run in to is reacquiring lock after going out of range of my WiFi when pulling out of my driveway. Once I get down the block it has usually caught up, and barring the occasional CDMA lock, works fine the rest of the trip.
     
  6. ewraven

    ewraven Lurker

    I had this issue the very first time I used Sprint Navigation just four days ago.:mad:

    I was late to where I was going because the phone lost the GPS signal and just stopped showing progress on the navigation screen. I had to pull off the road and wait ten minutes while the stupid phone rebooted. It did work after the reboot.

    I sure hope this isn't something I will have to do every time I want to use Sprint Navigation.

    Up until that point I was considering giving away my Magellan GPS device but I guess I better keep it as a backup now.
     
  7. Navigation on the Moment is horrible. Mine only holds a decent signal if the phone is on the dash, looking through the windshield.

    Set it in the cupholder and all is lost. :)
     
  8. generalmoment

    generalmoment Lurker

    ok great. I'm not the only one having issues on their moment. I too love my moment, but Android/Sprint needs to handle this ASAP.
     
  9. mrmojoz

    mrmojoz Android Enthusiast

    I've never had a single issue with the GPS, sometimes I can even get a good signal indoors. I wonder what the diffrence is.
     
  10. chibucks

    chibucks Android Enthusiast

    what settings does everyone have on? i turn on "use wireless networks" along with "use gps satellites"...
     
  11. 4runneradam

    4runneradam Newbie

    I've tried every which way with 2.1 and its still screwy
     
  12. Spr8dogg

    Spr8dogg Member

    I've had the same problems all of you have described. I found a fix on these forums and it has worked great! Try this:

    Settings -> Location & security -> Use wireless networks OFF and Use GPS satellites ON

    Good luck!
     
  13. drummindude1

    drummindude1 Lurker

    I have having the same problems. If it finds me at all it is miles off and connection is slow if possible at all.
    Post if you hear any solutions. I agree this makes that functionality unuseable and a serious issue
     
  14. drummindude1

    drummindude1 Lurker

    tried you idea and still same problem. Sprint will have to take care of this or they will be getting lots of phones back. It is just too big of a issue for a phone sold with these features:thinking:
     
  15. ewraven

    ewraven Lurker

    Yep, mine is still doing the same thing. I used it the other day and after roughly 23 miles on the freeway, it malfunctioned. The only way to get it working again was to reboot the phone.
     
  16. LaFlavor

    LaFlavor Well-Known Member

    I get the same issue I see some of you having. I was out of town all week, and really needed the GPS to work. It would find my location just fine at first, but it seems like it would lock up after 10-20 minutes almost every time. The only way to get a signal again was to reboot the phone. Definitely moving to a different phone as soon as my upgrade is available.
     
  17. ewraven

    ewraven Lurker

    I just did a little experiment with my phone.

    I turned on Sprint Navigation with a route. This was in my house. The phone got a GPS signal and started the route. I left it just sitting there for a full hour and it never lost any signals and had zero malfunctions.
     
  18. zippy

    zippy Well-Known Member

    Following the advice given here a few weeks back, I had my phone exchanged by Sprint. The replacement had only CL14 so I immediately upgraded to 2.1 release from Sprint. GPS works perfectly now whereas my other Moment never worked anywhere or at any time. Used it all day yesterday for hiking, driving and locating stores and pointsof interest perfectly. Even when phone signal disappeared, gps was still working! Must have been bad Moments in the beginning I assume, I was an early owner.
     
  19. ewraven

    ewraven Lurker

    That is good to know Zippy. I am going to take mine to the local Sprint store on Tuesday.
     
  20. zippy

    zippy Well-Known Member

    I hope you have the same good luck. I also haven't needed to use the wifi setting either, only thing checked is the GPS Satelites.
     
  21. artzyfartzy68

    artzyfartzy68 Lurker

    I have several apps which rely on GPS and none of them are working now. My cadiotrainer had me starting my run in Denver, and I live in Dallas. Navigation isn't finding a gps signal at all. I've tried all the various settings to no avail.
     
  22. ewraven

    ewraven Lurker

    Just an update on the problem of my GPS(Sprint Navigation) shutting off after roughly twenty minutes.

    As it turned out, it was an app on my phone that was causing the problem.

    I uninstalled all but like three Android Market downloaded apps. I used the Sprint Navigation for five hours nonstop on a trip today. It worked excellent, I had zero problems with it.

    I wish I could say what app was causing the problem, but I uninstalled something like fifteen apps. I'm not sure at all which was causing the trouble.
     
  23. maylea

    maylea Member

    artzyfartzy68:

    A couple of us were discussing this in another post. Don't know why, but if you use the free app GPS Test it improves lock and accuracy of other GPS programs. I run it first and then open the other apps. Just takes 5 secs more. May not work for everyone, but it does for me and a few others.
     
  24. Shiftr182

    Shiftr182 Lurker

    Did anyone do the GPS reset? ##GPSCLRX#....you need your msl, then hit "yes"
     
  25. caspertodd

    caspertodd Well-Known Member

    I did this, but it didn't help. Make a backup of your phone before you do it because it causes a boot loop on next reboot.
     

Samsung Moment Forum

The Samsung Moment release date was November 2009. Features and Specs include a 3.2" inch screen, 3MP camera, GB RAM, processor, and 1440mAh battery.

November 2009
Release Date
0
Reviews
Loading...

Share This Page

Loading...