1. Are you ready for the Galaxy S20? Here is everything we know so far!

GPS Issues

Discussion in 'Android Devices' started by darrin2520, Sep 2, 2011.

  1. darrin2520

    darrin2520 Well-Known Member
    Thread Starter

    Is anyone else having GPS issues with their phone? More often than not, I have to reboot my phone to get my GPS to work. It is turned on and I can see the symbol in the window but none of my apps are able to use it / find it including Navigation, Cardio Trainer or GPS Status. This is always fixed by rebooting the phone. Just wondering if I got a glitchy phone or if this is an issue anyone else is having. Also, on cardio trainer, it really struggles to follow the route, where my OG droid was almost dead on for the same route.

    The other unrelated (possibly related) problem I am having is reboots. I can always tell when it will reboot because the unlock screen is nearly unresponsive before it happens. I have read every thread on here and so far I haven't found a solution.

    I'm not big on returning things, but if no one else can confirm these issues, I may look into a replacement phone. Love the phone, but these are pretty annoying things for what I use on my phone.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. azdawg

    azdawg Newbie

    I have the same issue with my GPS..... don't know if its a hardware or software issue....
     
    darrin2520 likes this.
  3. B360155

    B360155 Well-Known Member

    Usually, my DX locks onto the signal within just a few seconds but a couple of times this week the icon just kept flashing and couldn't get a lock. What worked for me was to toggle to turn on airplane mode, then immediately toggle back out of airplane mode.
     
  4. thruapole

    thruapole Lurker

    It's not just yours, mine acts the same way. A reboot has always fixed it. I miss how well the gps worked on my d1 as well.
     
  5. pbwhite

    pbwhite Member

    I think it's fairly common with the D3 so far - it happens to me a every so often. Fortunately, it's as easy as a) rebooting, b) toggling airplane mode on/off or c) turning off and back on GPS services under settings|location & security.

    Doing any of these seems to fix the problem and you have GPS lock almost immediately after.
     
  6. azdawg

    azdawg Newbie

    It seems to me now that I have updated to the leaked upgrade... that my GPS works every time I turn it on and off.... I haven't had to reboot for GPS issue yet....
     
  7. rushmore

    rushmore Extreme Android User

    GPS seems slow to lock on (can take up to two minutes). Come to think of it, all of my phones have had slow to lock GPS.... The Incredible was the worst.
     
  8. azdawg

    azdawg Newbie

    Mine locks within seconds..... I'm diggin it..... :D
     
  9. bebbles

    bebbles Member

    Yes.

    Everytime I use navi, a few minutes into it it will say that I lost signal and wont pick it back up. I have to exit out of the navi and go back in and itll work.

    Also, the screen will lock in navi at random times.

    Hopefully there will be an update soon to fix this...
     
  10. HadouGhost

    HadouGhost Android Expert

    havent turned on gps all day so i turned it on and went to google maps and then clicked my location. used my computers analog clock to count how long it took to get my location. 40 seconds. Not bad. not the best but its not as bad as my old samsung vibrant. 40 seconds is plenty acceptable.
     
  11. bebbles

    bebbles Member

    Ghost, Keep using the GPS. Mine finds my location almost instantly... but the GPS signal cuts out randomly while using the navigation to get anywhere. Its a huge pain, Ive gotten thrown off course a couple times already =T
     
  12. rushmore

    rushmore Extreme Android User

    Mine averages a minute to lock on, but stays on when it does.
     
  13. bishop0114

    bishop0114 Member

    I had similar issues. I finally had VZW replace my phone and the new one has had no issues.
     
  14. ndoren

    ndoren Well-Known Member

    I made a change to my /etc/gps.conf file and the difference has been night and day. I went from huge inaccuracies, to losing lock with gps (requiring reboot) to having nearly perfect lock and great accuracy. It has to do with changing the ntp server specification in the conf file. That may explain why some of you have better luck than others with GPS, because it's somewhat location dependent as far as the NTP time server used. You have to be rooted... and it's safe cuz you make a backup of the current config file. But I can't tell if it will work for anyone else.

    Use root explorer (from the market). Change partition to r/w.

    If you are desperate, try changing your /etc/gps.conf as follows:
    Change:
    NTP_SERVER=north-america.pool.ntp.org
    To:
    NTP_SERVER=us.pool.ntp.org

    Let me know if this helps. If your gps works fine already, don't bother with this change.
     
    darrin2520 likes this.
  15. G4bama

    G4bama Lurker

    When I select GPS I do not see an icon in the noticifaction bar unless I am using google maps at the same time. I read on the Bionic forum page that this appears to be a programmed function within gingerbread 2.3 and higher.
    My HTC eris showed the GPS icon in the noticication bar as long as GPS was turned on. I guess we will just have to adjust and get use to the way the system works. It is aggravating though.
     
  16. darrin2520

    darrin2520 Well-Known Member
    Thread Starter

    Right now I have been resisting rooting, but I may go this route if after the OTA things are a bit better. Thanks for this. If I implement it, I will comment back for sure.
     
  17. redsox985

    redsox985 Android Enthusiast

    I feel mine is quite tempermental. At first, it would take more than a few minutes to lock, or would never lock unless I went into location settings and reassigned 3rd party GPS new rights to share location. Now, I can flip on the toggle as I'm getting in the car and it will be locked on by the time it's in car dock mode.
     
  18. ndoren

    ndoren Well-Known Member

    Yeah, its pretty sad you have to root to fix this, but hey, at least we can root. Yeah, not a bad idea to see if its fixed in the ota update.
     
  19. BMeyer

    BMeyer Lurker

    I having the same problem with GPS & my WiFi is getting buggy too. Dumb question, what is "OTA"?
     
  20. Sneeky

    Sneeky Newbie

    Mine seems to be okay, it does have issues finding sats inside, and have had an issue from time to time with it not loading right away, but for the most part mines been okay
     
  21. Sneeky

    Sneeky Newbie

    Over The Air referring to an update that you will recieve remotely or over the air, instead of having to hardwire and install it


    Not a dumb question friend...just a question, after all if you dont ask you may never know.;)
     

Motorola Droid 3 Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...