1. Are you ready for the Galaxy S20? Here is everything we know so far!

GPS problem

Discussion in 'Android Devices' started by lisa4labz, May 28, 2011.

  1. lisa4labz

    lisa4labz Newbie
    Thread Starter

    I'm having a problem with my GPS...I enter my destination and it brings up the directions but the screen reads "Searching for GPS" and the voice doesn't come on (reading the actual directions) for at least 10 minutes. Kind of useless to me if this is the case. Any thoughts or ideas?

  2. Opticman

    Opticman Newbie

    Noticed the same issue just this evening. Not sure what or why that is happening. Do you have most current Google maps? Also I am a bit confused about the options in setting regarding using google location services versus using "stand alone GPS". You can actually check each one at same time, maybe there is some conflict when doing so.
  3. lisa4labz

    lisa4labz Newbie
    Thread Starter

    I have all 3 checked and re-installed Google Maps with all of the updates. I tried it without one of them checked and couldn't connect at all. My current location is way off too (by about 7 miles). I might stop at the Verizon store today and see if a tech can figure it out, if not I can always call tech support. If you figure it out let me know.
  4. lv2bsilly

    lv2bsilly Newbie

    I just switched out my original Charge in the store yesterday because of gps issues. The issues I was having originally was it rerouting me in circles, even when I was stopped.

    My new Charge seemed to work fine and I didnt have that issue but after downloading the new ED2 update it now has trouble locking in on the gps. I think others are having the issue so its probably the update :( hopefully they will have a fix to this soon
  5. GunnerJim

    GunnerJim Well-Known Member

  6. katoom400

    katoom400 Well-Known Member

    I am strongly considering the charge as my og droid is just about done....

    one thing I have read is that it has a hard time pulling gps signal, can anyone comment on this as I don't mount it on the windshield but lower by the radio inside my Toyota tundra...certainly not an optimal sport for gps but my og droid never had a problem keeping gps connections. after reading some of these posts I'm a little concerned about gps reception on the charge???

    are these just a few defective units or more the norm for samsung gps/antennas??
  7. Mine sits in my center console and gets gps signals just fine, I wouldn't worry about it.
  8. Sintec

    Sintec Newbie

    Mine also has serious issues with the GPS finding a signal. My Incredible would find it immediately. My charge has taken roughly 5-10mins. I am still on ED1 btw.
  9. mjakers_usmc

    mjakers_usmc Lurker

    I had the same issues. I unchecked the "Verizon" GPS Services and left the other two (Stand-Alone and Google) checked. My GPS then worked perfectly. Maybe that will work for you as well. Otherwise, I would talk to Verizon about maybe swapping your phone out. Best of luck!
    secretLOVER likes this.
  10. Bozz5384

    Bozz5384 Well-Known Member

    Thanks, just tried this and found my phone locked on MUCH faster...even sitting inside my house on the couch. :)
  11. secretLOVER

    secretLOVER Android Enthusiast

    BUMP! Thank you!!!!
  12. thevaliantx

    thevaliantx Member

    Yeap, un-checking Verizon's option for GPS services (and leaving stand-alone and Google's services checked) worked much better for me, too. What does this say about Verizon? :thinking:
  13. iClark

    iClark Newbie

    I recently had an issue with my phone... looping in the start-up. They sent me a CLN Charge.... GPS locks in under 5 seconds now!! My old one, 5-10 minutes.
  14. Josiemadda

    Josiemadda Lurker

    what's a cln charge?
  15. Josiemadda

    Josiemadda Lurker

    That didn't work for me. :thinking:
  16. ukrkoz

    ukrkoz Well-Known Member

    Certified like New - CLN
  17. juanito157

    juanito157 Well-Known Member

    I cant stand this phone! It is the most glitchy pos ive ever owned! GPS virtually doesnt work! Phone reboots all the time especially when using the browser with flash! Im now getting a green transparent screen at times! It has literally taken 10 minutes to reboot at which point I pull the battery and try again! Rtf file system really screws up this phone, it is so so laggy!! Worst friggen phone ive ever owned! Oh and it drops calls all the time in full bars of service! I have a replacement on the way! Just FYI, this is a root only device! Without root access this phone is very slow and unreliable!
    Norril likes this.
  18. Norril

    Norril Android Enthusiast

    I agree. Most miserable phone ever. I do like the pretty screen and good photos, when the camera doesn't cause a reboot... Today I was on the phone calling support and the phone started screeching super intense beeps at me. I tried making another call and more screeching beeps. had to battery pull. This thing is going back. I have not been able to get a GPS lock for over a week. My Original evo locks in less than 5 seconds every time.
  19. E77

    E77 Lurker

    I was having the same difficulty getting a GPS lock. Sometimes taking 20 minutes. I searched the internet and finally found this solution which works for me.
    On the Settings -> Location & security page select as follows:
    Standalone GPS services AND (VZW location services OR Google location services)

    If using Verizon location tools such as VZNavigator the select VZW location services; if using Google services such as Google Maps or Google Navigation then select Google location services. You can still use Google Maps if you select VZW location services but your location will not be displayed until you get GPS lock.

    Apparently there is some sort of cross-talk inducing error that slows/prevents GPS lock when both location services are selected. Since selecting only one I am able to get a GPS lock in a matter of seconds, even indoors.
    cag-go likes this.
  20. DaManDJ3

    DaManDJ3 Member

    Welcome to the world of Samsung phones. Samsung is notorious for having crappy gps chips in their phones. The problem has always existed from their first android phone onward. Just stop giving them business from now on. Samsung's other tactics include...not providing updates to their present phones to force the consumer to purchase a newer phone. Total lack of respect for the consumer.
  21. Agreed. I'll buy a Samsung display again, but not a phone. Assuming that Motorola, LG, and HTC are all much better, or are any of those known to be problematic too?
  22. internettutor

    internettutor Lurker

    Have EVO with Sprint and have been having issues with navigation - everywhere.

    Followed the suggestion on this forum about gpsfix and it works
    1. google market - search for GPSFIX
    2. install and rebook phone
    3. check navigation - should work.

    Thanks for the answer!
  23. Bozz5384

    Bozz5384 Well-Known Member

    Mine suddenly went in the crapper now too... I used to use it all the time, now it won't lock. Even downloaded GPSfix and did all that nonsense and it hasn't helped. Its been searching for location for more than 2 hrs.

  24. Bozz5384

    Bozz5384 Well-Known Member

    I suspected Google Maps was the problem, after it updated so you could download maps and keep them local, etc. I noticed it acting weird and FC'ing sometimes.

    Uninstalled Google Maps, re-booted, then went back to Play and updated it so it was up to date again and it locks on right away now.

    So, Google Maps broke the GPS function temporarily.

Samsung Droid Charge Forum

The Samsung Droid Charge release date was May 2011. Features and Specs include a 4.3" inch screen, 8MP camera, GB RAM, Hummingbird processor, and 1600mAh battery.

May 2011
Release Date

Share This Page