1. Check out our companion app, Forums for Android! Download from Google Play

Support GPS woes

Discussion in 'Android Devices' started by Anthony2816, Mar 24, 2011.

  1. Anthony2816

    Anthony2816 Well-Known Member
    Thread Starter

    Nov 29, 2010
    After I rooted and installed Superclean 2.9, I was happy to find that my GPS was locking on within seconds (using Google Navigator).

    But now I've had the opportunity to use it more, I find that sometimes it takes a very long time to lock on...I've had it literally take over 20 minutes.

    At other seemingly random times, it will still lock on immediately.

    I've also discovered that when it isn't locking on, if I power down the phone and restart it, it locks on immediately.

    I've tried running the GPS Status app, to no obvious effect.

    Any ideas on what's going on?


  2. f@scin8

    f@scin8 Active Member

    Nov 29, 2010
    Leominster, MA.
    I'm running stock EA28. In January I did the OTA update (DL09?) and my GPS starting working just fine. I had some minor issues prior - slow lock on, etc. - but I went to use it the other day and I notice GPS doesn't work at all! I reboot and still no satellites at all.

    I saw on another forum some *#xxxxxxx sequence to get to the GPS setup menu, but it doesn't work on my phone or I did something wrong. The person did say they were rooted. I'm not.

  3. Lars

    Lars Well-Known Member

    Sounds like typical Samsung gps issues. A couple of work arounds. Uncheck "Use Verizon location services" Just use sats and google.
    Another trick is to leave wifi on but that only helps if you are in town.

Share This Page