1. Download our Official Android App: Forums for Android!

Support (GSM) Battery with 4.0.4

Discussion in 'Android Devices' started by brounmoney, Apr 26, 2012.

  1. brounmoney

    brounmoney Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    274
    Joined:
    Mar 16, 2011

    Mar 16, 2011
    274
    17
    38
    So I just got the OTA update to 4.0.4 yesterday and man has the battery life gone down. I have really done nothing on my phone all day but about every 30 min or so I will just drop another % off. 4.0.2 never did this. Has any one else had issues with the battery after 4.0.4? I thought they were fixing the sub par battery from 4.0.2.
     

    Advertisement

  2. kylecummins

    kylecummins Android Expert
    Rank:
    None
    Points:
    93
    Posts:
    841
    Joined:
    Dec 11, 2011

    Dec 11, 2011
    841
    160
    93
    Union Member
    Canada
    My phone improved with the 1st 4.0.4, however the 2nd ota has made it the worst so far since launch
     
  3. charliecc

    charliecc Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    424
    Joined:
    Oct 12, 2011

    Oct 12, 2011
    424
    184
    68
    My battery usage has been amazing since 4.0.4 (IMM76I), it's at least 50% better, perhaps more. FYI, I have the GSM model.

    Current battery stats with low/moderate usage.

    31% charged, 2days exactly since last charge.
     
  4. brounmoney

    brounmoney Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    274
    Joined:
    Mar 16, 2011

    Mar 16, 2011
    274
    17
    38
    Really that is crazy that is the one I just got and the first two days with it were not good at all. I am working on day three as we speak. Did it take time for your battery to get better or right when you received the update it was better?
     
  5. charliecc

    charliecc Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    424
    Joined:
    Oct 12, 2011

    Oct 12, 2011
    424
    184
    68
    Straight away, got the update 2 days ago, charged straight after then stats as above.
     
  6. brounmoney

    brounmoney Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    274
    Joined:
    Mar 16, 2011

    Mar 16, 2011
    274
    17
    38
    This is kind of making me mad. I just lost 5% in 2 hours while my phone was doing nothing.
     
  7. charliecc

    charliecc Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    424
    Joined:
    Oct 12, 2011

    Oct 12, 2011
    424
    184
    68
    Update, I'm back to normal battery usage now, and I think I know why.

    When I updated to 4.0.4 I was at home and the phone was connected to wi-fi pretty much exclusively for those first 2 days. When I left the house on the weekend I was trying to browse the web using network data, nothing, it was totally dead.

    I could still make phone calls but no data transfer at all. I did some googling when I got in, and apparently this had happened to a few people when they installed 4.0.4 and all that was required was a reboot. So I rebooted and now it's fine. However, my battery usage has gone back to normal, as I type I'm 35% on 24hrs with the same usage as before.

    So it looks like having 3G (network data) off made all the difference.
     
Tags:

Share This Page

Loading...