1. Are you ready for the Galaxy S20? Here is everything we know so far!

(GSM YAKJU) Galaxy Nexus USB Host

Discussion in 'Android Devices' started by sniperfox47, Aug 14, 2012.

  1. sniperfox47

    sniperfox47 Newbie
    Thread Starter

    Hello, I have a Samsung/Google Galaxy Nexus GSM/HSPA+ phone currently with Wind Mobile in Canada running Yakju 4.1.1 (baseband:I9250XXLF1, kernel:3.0.31-g6fb96c9, build:JRO03C)

    It is my understanding that the Nexus has complete USB host support now (although I know it didn't at release) however I can't for the life of me get it to work. I understand that the Nexus apparently doesn't mount external mass storage devices automatically but I can't get anything to work including HID devices. I've tried the "USB Host Diagnostics v1.2" tool and it says that my phone reports that it supports USB host in the API AND the kernel but that it does not detect the device in either when it's connected. I've tried with both the stock USBmicro->USB cable and a similar cable I bought from 'The Source', both with a USB male->female adapter(I've tried a couple different ones in case it was the adapter).

    Does anyone have any advice on how I can troubleshoot this issue? My friend has the Yakjux(samsung) variant of the phone and I know USB HOST works fine for her, so I don't see why the Yakju(google) variant should be any different. If you don't have anything nice or constructive to say, please keep your opinions to yourself, but any constructive advice would be greatly appreciated. Thank you all in advance for your help.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. ritchea

    ritchea Well-Known Member

    Are you trying to use a usb keyboard/mouse? I think I have seen that those devices do work. My usb keyboard does work, but I wanted it to read storage devices (OTG) so I rooted mine and use Stick Mount. I have the yakju with stock JB (all stats are the same as yours except that I am rooted). Are you trying to use a USB keyboard/mouse? Does your friend have the same service and does the usb device you want work on hers? Are you using the exact same adapter she uses (you said you tried a variety but didn't mention trying hers)? If so, you may have a defective device. A couple other things, although it shouldn't be necessary, have you tried a reboot after plugging in the usb device? If the usb device is usb powered, you may need to have a full (over 75%) battery to use it.
     
  3. sniperfox47

    sniperfox47 Newbie
    Thread Starter

    I have tried both Mass Storage and HID (human interface devices such as keyboard and mouse) usb accesories and neither work. As I said already I know that you need a terminal with root access to mount mass storage in the nexus version of ICS and JB because of a bug, but my device does not even see it as a usb device. I'm thinking it may be defective. I haven't tried with her cable (she has an actual USB2go cable) but the cables I've been using should appear exactly the same to both phone and accessory as the one she uses.
     

Galaxy Nexus Forum

The Galaxy Nexus release date was November 2011. Features and Specs include a 4.65" inch screen, 5MP camera, 1GB RAM, TI OMAP 4460 processor, and 1750mAh battery.

November 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...