1. Check out our app, Forums for Android! Download and leave feedback here!

Root [GUIDE] Brick Recovery

Discussion in 'Android Devices' started by bg4m3r, Jan 4, 2015.

  1. bg4m3r

    bg4m3r Well-Known Member
    Thread Starter
    393

    Nov 1, 2013
    2,850
    1,120
    393
    Male
    IT Contractor
    This guide is intended for recovering from a brick where you can't access recovery or boot the phone. If you can do either of these, you are not bricked and this guide is an extreme solution to your problem. Access to download mode and a computer is required.

    Several of the files have an MD5 listed below them. You can use this to verify that the file downloaded correctly. Install this hash checker and compare the MD5 of your file to the one listed. (Android MD5 Checker)

    Step 1 - Gather materials for zv3 downgrade
    What you will need:
    zv3 stock tot file - DL to computer
    MD5 = 0D7AAAFB6742CEAB7BCAEECBAE3C1F39
    LG Flash Tool 1.8, Megalock, and LS740 - DL to computer
    MD5= C1825BA208611B23B9B0D4aBDD0C5731
    LG Universal Drivers - DL to computer

    Step 2 - Setup your computer
    Uninstall any and all phone related drivers and software currently on your computer from any phone you've had. You can reinstall them once the downgrade is complete if you still need them.
    Reboot the computer.
    Install the driver package.
    Reboot the computer.
    Install the LG Flash Tool to the root of your drive.
    Place the DLLs (megalock and ls740) and tot file in the folder with the flash tool.
    With the phone off, and USB cable plugged into your computer, hold Vol + and plug the cable into the phone. (Some drivers may install, allow this to happen.)
    Continue holding Vol + until download mode loads. See screenshot.
    upload_2015-1-7_17-23-25.png
    In Device Manager on your computer, find LGE AndroidNet USB Serial Port (under Ports) and set it to port 41 (COM41).
    Leave your phone connected and set it aside for now.

    Step 3 - Flashing zv3
    Open the LG Flash Tool. On the config window, make it look like the picture below
    (note the DLL, S/W, and Action Mode) and hit OK:
    upload_2015-1-4_11-55-48.png
    On the main window, hit the yellow arrow at the far left.
    Once it finishes, unplug the cable from the computer, and plug it back in to start the flashing process.
    When the phone reboots, it will boot into the MiniOS setup screen.
    (You can now disconnect the phone and close the Flash Tool.
    Don't worry about any fail messages from the flash tool.)
    On the MiniOS screen, hold power and tap Normal Boot.
    Rebooting will take several minutes, DON'T PANIC! :)
    If you don't have service, just use ##72786# dialer code to reactivate.



    Step 4 - Allow your phone to update to the current version
    Once you've reinstalled the stock software, it will need to update to the current version. Doing this on WiFi is recommended as it will take up about half a GB by the time it's fully updated.

    Step 5 (optional) - Restore carrier labeling
    Flash this universal APN Fix in custom recovery.
    http://androidforums.com/index.php?posts/7283452

    Disclaimer
    As always, the responsibility for the results of this information is at your own risk.
    We'll happily help you fix any problems, just don't blame us for breaking your phone.

    Credits
    Huge credit to asmugone for getting the stock zv3 tot file!
    He had to pay for this, so please send him a donation!
    Thanks to Team Codefire for creating bump.
    Thanks to whoshotjr2006 for TWRP
    Thanks to kwknott for the zv5 ROM.

    Thanks to everyone else who contributed time and knowledge to getting this stuff working!

     

    Advertisement

    #1 bg4m3r, Jan 4, 2015
    Last edited: Jul 24, 2016
    erogier, 3stan, spunky168 and 45 others like this.
  2. spocko

    spocko Well-Known Member
    63

    Jan 19, 2014
    106
    88
    63
    Thanks bg4m3r, great job! This should be stickied. The currently stickied "rooting guide" is outdated.

    Here is a link to version 3.13.2 of the LG driver direct from LG. I have used this version successfully.
    http://tool.xcdn.gdms.lge.com/dn/downloader.dev?fileKey=UW00120120425

    Here is a link to the latest version of SuperSU (currently 2.40):
    http://download.chainfire.eu/supersu

    This is not needed when using Flashify as described in the OP, but for anyone who wants access to fastboot and adb, you can use this package without needing to install the whole Android SDK:
    http://forum.xda-developers.com/showthread.php?t=2317790

    For further reading and to help give more credit to the people to originally discovered/created/shared/consolidated some of this great info about rooting and updating the Volt, here are links to some of the original threads. Thanks so much to all who have contributed, and apologies in advance if I missed anyone or any significant threads!

    Restoring with Download Mode:
    http://androidforums.com/threads/official-restore-with-dl-mode.853693/
    http://androidforums.com/threads/how-to-restore-phone-with-dl-mode.861292/
    http://androidforums.com/threads/the-so-you-upgraded-to-z4-and-lost-root-guide.874943/

    CWM recovery:
    http://androidforums.com/threads/test-a-working-lg740-cwm-based-recovery-v6-0-3-7.862425/
    http://androidforums.com/threads/working-cwm-recovery.880181/

    Rooted ZV4 Rom:
    http://androidforums.com/threads/rom-zv4-updated-stock-rom.872005/
     
    #2 spocko, Jan 4, 2015
    Last edited: Jan 6, 2015
  3. bg4m3r

    bg4m3r Well-Known Member
    Thread Starter
    393

    Nov 1, 2013
    2,850
    1,120
    393
    Male
    IT Contractor
    Where was the page that link for the drivers is from? I would've expected it to be listed on the page I linked.
     
  4. The version 4 update has caused SuperSU to stop funtioning, my phone is still rooted how do I get a superuser app to work on my phone?
     
  5. bg4m3r

    bg4m3r Well-Known Member
    Thread Starter
    393

    Nov 1, 2013
    2,850
    1,120
    393
    Male
    IT Contractor
    Use the link in the guide, install with cwm. SuperSU is working perfectly fine on my phone.
     
  6. bg4m3r

    bg4m3r Well-Known Member
    Thread Starter
    393

    Nov 1, 2013
    2,850
    1,120
    393
    Male
    IT Contractor
    Added additional thanks to the credits as mentioned by spocko. :)
     
  7. DanniRulezzz

    DanniRulezzz New Member
    16

    Jan 4, 2015
    1
    1
    16
    Chiraq
    Thank you very much sir!

    Just what I needed. Do we have any custom stable roms on the forum?
     
    #7 DanniRulezzz, Jan 4, 2015
    Last edited: Jan 4, 2015
    POCHOLOJP likes this.
  8. bg4m3r

    bg4m3r Well-Known Member
    Thread Starter
    393

    Nov 1, 2013
    2,850
    1,120
    393
    Male
    IT Contractor
    There are several in the works, but nothing is 100% yet.
     
    Sands207 and DanniRulezzz like this.
  9. I don't have a working PC Computer any other suggestions?
     
  10. bg4m3r

    bg4m3r Well-Known Member
    Thread Starter
    393

    Nov 1, 2013
    2,850
    1,120
    393
    Male
    IT Contractor
    You're rooted right? You don't need a computer. If you already have cwm installed, just download the zip on your phone and flash it with cwm. If you don't have cwm installed, it can be installed with Flashify.

    Have you tried running towelroot again? It may work since you are at least semi rooted.
     
  11. sagethesagesage

    16

    Dec 30, 2014
    6
    1
    16
    Thanks a lot for the guide, it's a lot easier to follow than the other one.

    What effect does this have on my phone's interaction with my carrier? That is to say, I shouldn't have to activate my phone, pay again, or get a new number, right? I assume it's not an issue, but I'm pretty new to toying with android phones, so I figure it's best to ask.
     
  12. AndroidEJ7

    AndroidEJ7 Active Member
    28

    Sep 29, 2014
    27
    12
    28
    Female
    Texas
    First off, thank you for the guide! I'm having some problems with the LG Flash Tool. After "Waiting for connection" I get this error:

    PID: NULL
    IMEI: Unknown
    Model : UNKNOWN
    DLL : LS740
    BIN : LS740ZV3_17.33030_SECURE.TOT
    SW : UNKNOWN
    SWOV : UNKNOWN
    Device Model is different!
    Check Phone or DLL!
    00000000
    Factory Model Check ERROR!!

    Any idea what's going on? I followed the steps exactly, tried 4-5 times, and keep getting the same error message.
     
  13. bg4m3r

    bg4m3r Well-Known Member
    Thread Starter
    393

    Nov 1, 2013
    2,850
    1,120
    393
    Male
    IT Contractor
    Well, first question, and it may be a stupid one, but I don't recognize your name, do you have a Volt? This will only work with the Volt.

    Second, did you download the 3.11 drivers? It won't work with older ones, and it might not work with the 3.18 drivers spocko posted (I personally haven't used them).
     
  14. AndroidEJ7

    AndroidEJ7 Active Member
    28

    Sep 29, 2014
    27
    12
    28
    Female
    Texas
    Yes I do have a Volt, just got it last week. I did download and install the 3.11 drivers (the ones linked in the OP, correct?). I kinda have a feeling I may be doing something wrong even though I'm following the instructions exactly, just not sure what it could be.
     
  15. Jose Flores

    Jose Flores Member
    6

    Jan 4, 2015
    5
    1
    6
    Hey, so I rooted my phone and I'm pretty sure it's rooted, but when I got to the boot.img I was confused. Do you install boot.img as a recovery image or boot image?
     
  16. How do I get to the boot recovery?
     
  17. bg4m3r

    bg4m3r Well-Known Member
    Thread Starter
    393

    Nov 1, 2013
    2,850
    1,120
    393
    Male
    IT Contractor
    Boot image... As stated. :)
    Cwm is the recovery
     
    #17 bg4m3r, Jan 5, 2015
    Last edited: Jan 5, 2015
  18. bg4m3r

    bg4m3r Well-Known Member
    Thread Starter
    393

    Nov 1, 2013
    2,850
    1,120
    393
    Male
    IT Contractor
    Do you mean how to boot into recovery?
    Vol - + Power
     
  19. bg4m3r

    bg4m3r Well-Known Member
    Thread Starter
    393

    Nov 1, 2013
    2,850
    1,120
    393
    Male
    IT Contractor
    Did you set the port correctly in device manager? Are you running the flash tool on board mode or update mode? Where is the flash tool installed, and where are the other files located? I'm not sure what you could have wrong otherwise.

    I used this exact method a couple weeks ago, so I know the process is sound.

    Are you using the USB cable that came with the phone? Some cables only do power, or are wired a little funky. Maybe try a different USB port?

    On the drivers again, there are three different sets on that page. If you just downloaded the first one, you didn't get the right thing.
     
    #19 bg4m3r, Jan 5, 2015
    Last edited: Jan 5, 2015
  20. AndroidEJ7

    AndroidEJ7 Active Member
    28

    Sep 29, 2014
    27
    12
    28
    Female
    Texas
    Port is set to 41. Ran flash tool on Board DL. Flash tool is installed to C: and both the .dll and .tot files are located in the LGFlashTool folder. Wasn't using the right USB cable earlier, but I just tried again with the one that the phone came with and got the same result. Installed the LG USB Drivers Ver.3.11 from the page you linked to.

    I am completely stumped. When I get to the download screen on my phone and run the flash tool, I see no progress at all. Stays at 0% until I get that error message from the flash tool. Tried enabling USB debugging mode from the developer options and that didn't work. Tried a different MegaLock.dll file that I found online also and that didn't work either. No idea what the problem is :/
     
  21. spocko

    spocko Well-Known Member
    63

    Jan 19, 2014
    106
    88
    63
    The version that I linked is 3.13.2, and I have used that version several times. It comes straight from LG, and I linked directly to the relevant file so no chance of downloading the wrong file. Your link goes to a 3rd party site with multiple download links, so someone could download the wrong file. IMHO I think my link is preferable, no offense. :)

    The source page is here:
    http://www.lg.com/us/support-mobile/lg-LGV500#software_panel


    One thing that is missing in the OP is megalock.dll. You need to download that and copy it into the LgFlashTool program folder, overwriting the existing file. You need to do this before running the LG Flash Tool. There is a download link in the first post of this thread:
    http://androidforums.com/threads/how-to-restore-phone-with-dl-mode.861292/

    Also, you might want to verify the MD5's of the downloaded files to confirm that your downloads are not corrupted. Here are the MD5's of the actual files that I used, and I just verified that they match the files linked in the OP.

    LGUnitedMobileDriver_S51MAN313AP22_ML_WHQL_Ver_3.13.2.exe
    MD5 = 5B42B87660CC30168DA629BFD75A105D

    LGLS740_20140414_LGFLASHv160_Download.zip
    MD5 = 8ADCC4F4BA818C4D6583870CF0717931

    LS740ZV3_17.33030_Secure.zip
    MD5 = 0D7AAAFB6742CEAB7BCAEECBAE3C1F39

    MegaLock.zip
    MD5 = F20BFD2743C279186998A53F9B70984A

    Here is a tool for easily checking MD5 values in Windows:
    http://code.kliu.org/hashcheck/

    To sure you are in download mode before running the LG Flash Tool, I attached a photo showing what your phone screen should look like (yours may not say "rooted" yet).

    After running the LG Flash Tool, that tool always ended with a "Failed" result for me, even though it had worked. As long as the phone reboots into MiniOS afterward, I think you are ok. If the phone boots into a blue screen saying Status 2 or similar, then you need to try again. That will happen if you use "Upgrade DL" mode instead of "Board DL" mode.

    Once your phone reboots into MiniOS, it may not be easy to select the "Normal Boot" option. It took several tries for me. If the phone restarts without prompting you, that is probably just because you were holding down the power button, and the phone will just boot back into MiniOS. When it recognizes the selection properly, it should pop up a menu where you tap "OK" to proceed. If you don't get that right away then keep trying.

    bg4m3r, feel free to incorporate any of this info into the OP. I'm not criticizing, just trying to help! After going through this process a few times I was also thinking about starting a thread like this to consolidate the info. Kudos for beating me to it.
     

    Attached Files:

    #21 spocko, Jan 6, 2015
    Last edited: Jan 7, 2015
    bg4m3r and AndroidEJ7 like this.
  22. sagethesagesage

    16

    Dec 30, 2014
    6
    1
    16
    Whenever I try to start the LG Flash Tool it pops up an error saying, "LG USB/Parallel Lock Key is not detected!!!" and then asks for a country, id, and password. What exactly am I doing wrong, here?

    Edit: Nvm, I was typing this as another person solved it for me.
     
    Porrie17 likes this.
  23. AndroidEJ7

    AndroidEJ7 Active Member
    28

    Sep 29, 2014
    27
    12
    28
    Female
    Texas
    OK, just followed everything in this post as well. Replaced the MegaLock.dll, which I did earlier but gave it another shot, checked all the MD5 values, everything is good as far as that goes. Still getting the same error, % bar on the Download Mode screen doesn't move, nothing happens at all. SS of LG Flash Tool attached.
     

    Attached Files:

  24. spocko

    spocko Well-Known Member
    63

    Jan 19, 2014
    106
    88
    63
    Hmm, don't know what the problem could be. The % bar on the phone screen should move while the download is in progress (it does not move at the same rate as the progress bar in the LG Flash Tool).

    The only thing I can think of is some kind of driver issue. You could try another computer if you have one available. If not, try removing all phone drivers from your computer, including LG, Samsung, HTC etc. Reboot afterward. Then reinstall the LG driver and try again. Good luck.

    Not sure if the Windows version matters, but I ran it on an old laptop with Vista 32-bit.
     
  25. AndroidEJ7

    AndroidEJ7 Active Member
    28

    Sep 29, 2014
    27
    12
    28
    Female
    Texas
    Yeah, I've been up all night and tried just about everything except another computer, and nothing has worked. Guess I will have to wait till there's a little more info posted in here. Thanks for all your help, though!

    Also just realized you mentioned a progress bar in the Flash Tool...I didn't even see anything like that. I see "Waiting for connection" for a few mins then the error message I posted above. What a headache lol!
     
  26. bg4m3r

    bg4m3r Well-Known Member
    Thread Starter
    393

    Nov 1, 2013
    2,850
    1,120
    393
    Male
    IT Contractor
    What exactly is your issue here?
     
Tags:

Share This Page

Loading...