1. Are you ready for the Galaxy S20? Here is everything we know so far!

[GUIDE][CTmod] Rooting the Prevail [SPH-M820] for Dummies (written by a dummy)

Discussion in 'Android Devices' started by Lordvincent 90, Apr 10, 2012.

  1. BkkTraveler

    BkkTraveler Lurker

    I rebooted it and it got stuck on the Koumakernel screen. After about 5 minutes, I powered it down and then powered on again, and it started up into the lock screen. When I unlocked it, it said something along the lines of 'android.process.acore' is not working properly, so I force closed it. Everything seems to be working normally so far. Any thoughts?

    Also, will the phone have to be rebooted like this after every time I use the wifi tether?

    1. Download the Forums for Android™ app!


  2. resevil239

    resevil239 Newbie

    I tried lord's suggestions and was met with no success. I then used pretty much all of the format options (except the system one) to ensure that everything was wiped. Below I listed everything I did in order and detail so you know exactly what I did since the problem still occurs. I hunted for the apkinstaller but unless I somehow overlooked it I can't find it anywhere, so thats the only other option I can think of unless theres a problem using CTmod 3.68 with the FE16 root, but I think someone would have figured that out by now.

    I then used Odin and the stock files to revert back (ops, phone, PDA, proper boxes checker/left unchecked), then shut the phone down and re-rooted it (now the third time) using odin. Then booted CWM to partition (advance-partition sd-512mb-0), then mount usb to add the CTmod file, unmount, install from sd, choose, [ctmod file]. Then reboot (using option in CTmod), popup asks to give koumo kernel super user permissions once it starts up (allow), menu-settings-ctmod-ct superuser permissions popup (allow), koumamod-pick data, check disable internal option, save settings (confirmation message), reboot. And for the third time all my work was greeted with nothing but that kouma kernel message yet again.
  3. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓
    Thread Starter

    after you change the settings in koumamod, THEN boot into cwm and format your sdext.

    so in other words:
    install rom
    setup koumamod
    boot into cwm
    wipe sdext (mounts and storage>wipe sdext)
    then reboot and wait atleast 10 min before declaring a fail

    wonder if blooddawn knows that those instructions are in post 777.... JACKPOT! :D
  4. resevil239

    resevil239 Newbie

    okay, following after my last post I again chose the format sdext option, which also didn't work. Following that I got the apk installer, opened it with winrar to put the apk file in the proper folder as stated, then CWM to put it on, install from sd, chose installer, reboot and...nothing. back to CWM, wipe dalvik cache, reboot. Still stuck at that screen. I'm beginning to loose patience with this as this has taken me almost literally all day to do and I still haven't fixed this issue. Did you mean to format the SDdex or mount it because I'm fairly certan both delete anything on it.
  5. vce2005

    vce2005 Android Expert

    Not wanting to interfere, but I think he meant Formatting the sd-ext....

    As I said, I had the same trouble before as you do... Not sure what the cause is, but it could be the SD-Card itself.... ( do you have a spare other one to try ? In my case, it was just this particular SD Card, all other, all sizes would work...)

    Whenever I was stuck at the Kouma logo, I just re-installed CTMod again, booted the phone all the way up, rebooted into CWM recovery, installed the Koumamod1.7.apk via the APKInstaller, booted, back into CWM and formatted sd-ext, rebooted all the way up, went to the koumasettings, selected data, booted into CWM recovery and formatted the sd-ext, then a final reboot and it worked....... Have done this same procedure on 5 different SD-Cards and all work, except ONE, I never could get it to work.

    My advise to try : Don't Odin the base band, that's fine, just reinstall CTMod368 from within CWM and follow the steps above ! My point is, have the sd-ext formatted, then change koumasettings to DATA, boot into CWM and format sd-ext again. See if that works.

    Hope this helps a bit until LordVincent is answering back, he's better with this stuff, I am a "new-rooter" too... ;)
  6. resevil239

    resevil239 Newbie

    I tired this and it worked perfectly...until I picked the data option (with the update there is no box). For whatever reason there seems to be no problem until I pick the data option. Then, wither I format the sd-ext or not it sticks on the kouma screen. Unless Lordvincent has some better suggestions tomorrow I think I'm just gonna give up and leave it at none or maybe try using ssm (I don't remember what it does, but I remember reading earlier and it sounded like a better choice then none, assuming data won't work). If I'm not mistaken all that means is that I'll be stuck with the minimal internal memory, but I read on another thread that using the SD card as internal makes it die faster plus without all those useless (for me) forced apps (ie, google books, thinkfree office, hooked, and whatever other crap they forced on you) I'll have room for the few apps I actually want (of which there are very few).
  7. vce2005

    vce2005 Android Expert

    Well, as I said, I had exact the same problem as you have. I almost would bet, if you pickup another SD-Card ( most are pretty cheap now ! ) and try the same way it will work. I can't explain why, but I tried everything with my 16GB/class6 card and it would not work. I even partitioned and formatted outside the phone and tried all kind of tricks, but this card would not work... but the card works just fine in camera and on notebook......JUST NOT IN THE PHONE !! As I said, no clue why !!

    BTW, did you wait the 10 ( maybe 15 ) minutes at the Kouma logo as LV suggested ? First time boot after changing to data mode takes quiet some time !

    Sorry that I couldn't help.
  8. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓
    Thread Starter

    Ok, last suggestion/comment.

    How did you partition the card?
    if you did it in cwm, it should be the correct format...
    If not, did you choose ext4 as the format?
    If you did choose ext4 then perhaps the partition you choose is to large or as mentioned above, the card just might not like your phone.
  9. resevil239

    resevil239 Newbie

    No, I only used cwm. As the guide recommends I picked the 512mb, then 0 for the swap options.
  10. resevil239

    resevil239 Newbie

    I waited that long only when I tested the things he said. When it booted up right it never took longer than 20 seconds, so while I gave it more time I honestly was not willing to wait that long after spending all day working on this. My guess is that its the card, which would mean most people who have done this already upgraded from the 2gb starting card, hence why there aren't that many people with this issue. Could you please post the info on your cards (brand, size, class) and which one didn't work? Maybe its just a specific type that doesn't work, but otherwise at least I know which one to make sure I don't get.

    Edit: sorry about the double post. In the forum I frequent they automerge and others I've been on just don't let you post again.
  11. vce2005

    vce2005 Android Expert

    Hi again,

    well, the point of the "10 - 15 possible Minutes" waiting time comes in AFTER you change to DATA mode in Koumasettings and then formatted the SD-ext in CWM..... Then, THIS first reboot can take some time.... I believe it took like 8-9 minutes on my first bootup..... that's why LV and I said, wait like 10 even maybe 15 minutes.... Be patient. Now after 15 minutes or so, I'd agree, it failed.

    The non-working 16GB microSD Card I have, says :

    Turbo / 16GB / micro SDHC / class6 / "A Data"

    Not sure what the brand is, but I know for sure, it's no Sundisk Card, since I bought this card for my old phone, 3 years ago ( for a high price ) and no Sundisk ( my preferred brand ) card was available at this time. And as I said, this card works anywhere I put it in, even in the Prevail, just does not work with the CTMod/kouma kernel data setup !!!

    Hope this helps.
  12. resevil239

    resevil239 Newbie

    okay, well maybe I'll try it again later (re-doing the whole process up to putting it in data mode doesn't wipe anything right? so long as you don't re-partition it?). I have it working now and don't really want to mess with it till I get another card. I can live without the extra internal space. Now that its not cluttered with auto-starting system apps that can't be removed its not really a problem. Getting rid of those (and maybe some cosmetic changes via themes) was all I really wanted to do anyways. Now if I can figure out how to force the my xbox live app to work I'll be good to go.

    Thanks for the help guys, I'll post when I get the card down the road if it works then.
  13. inigomontoyasr

    inigomontoyasr Android Enthusiast

    I recently switched my wife's phone to /data mode with the stock card. first boot took very near 10 minutes. felt like an eternity. after that, boots are fast and system is smooth.
    vce2005 likes this.
  14. vce2005

    vce2005 Android Expert

    I can confirm that as well !
  15. ThePits411

    ThePits411 Lurker

    Running GINGERBREAD-FF19 an Android version 2.3.6 on the Prevail. Have tried to root several times unsuccessfully. All i want to do is remove some system apps. can anyone assist?
  16. cwhatever

    cwhatever Life Goes On

    this thread and odin is the way to go:) just ask ?'s and we all here will help guide you.
  17. ThePits411

    ThePits411 Lurker

    using odin and cwm installed the rooted FF19 (android 2.3.6), but now can not connect to wifi.. phone still shows "not rooted" also.
  18. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓
    Thread Starter

    Kouma (who created the FF19 image) says there is an issue with root access in the kernel.
    If you use the Phone.tar from FF19 and the Boot.tar and PDA.tar from the EJ06 OR FA19 image you will get the newest baseband (radio) and a ROM with functional root access.
    ThePits411 likes this.
  19. ThePits411

    ThePits411 Lurker

    Worked Great! Thanks.............
  20. CGlase7

    CGlase7 Lurker

    I did everything step by step and everything is working great. The only problem I am having is a very large amount of dropped calls. I had some dropped calls before, but nothing like this. My calls will drop after 4 or 5 seconds. Sometimes I have to call the same person 6 or 7 times before I can actually carry on a complete conversation without the call dropping. Any suggestions of the cause of this?
  21. Savage Shadows

    Savage Shadows Android Enthusiast

    Caeadas, I just wanted to say you have made a GREAT guide. I used it when I rooted and started modding my Prevail, and now your guide will be what my EVO Design 4G guide is based off of. Good job!
  22. snappwrench

    snappwrench Well-Known Member

    Hello all, just bought a prevail a couple months ago and like an idiot updated it first thing, so i would like to root it now but after going through this whole thread i didn't see anything about what i was running before the update and would FE16 rooted be fine to use in my case? Was it FE16 before i updated or just an update for FF19? That's what i'm on now so just trying to figure out where i actually started before i follow the instructions in this thread. Any help would be greatly appreciated.
  23. snappwrench

    snappwrench Well-Known Member

    Ok so before any mods can be made i must be able to connect to my my pc. I can connect via USB as it should but not through downloading mode. Running Kubuntu 10.10 with winXP installed with Vbox. Please, any suggestions would be great as i am banging my head at this point trying to find any info.
  24. inigomontoyasr

    inigomontoyasr Android Enthusiast

    you would have to find a solution for usb passthrough to the vm. i found a tut after a lot of googling a few months ago but it was for the regular variation of Ubuntu 9.04 and didn't work for me on 12.04 so i use my wife's win7 box to use odin and cdma workshop. it's not cool that you need a windows box to root this phone but it's the way it is.

    if you DO find a way to get usb passthrough working, please share it.
  25. rio2356

    rio2356 Lurker

    New to the forum! I followed all of the steps and after loading CTMod 3.68 and settings check "disable internal data" when using /data mode I rebooted and it just sits with the KOUMA KERNEL 2.5 logo!

Samsung Galaxy Prevail Forum

The Samsung Galaxy Prevail release date was April 2011. Features and Specs include a 3.2" inch screen, 2MP camera, GB RAM, MSM7627-3 processor, and 1500mAh battery.

April 2011
Release Date

Share This Page