Root Guide: Downgrade your X10i from 2.1 to 1.6


Android Expert
Some people keep asking how to downgrade back to 1.6. So I wanted to provide how to do it :)

Note: This will give you UK Generic R1FA016 firmware

1) Install SEUS (Sony Ericsson Update Service).
You can get it from here:

2) Run SEUS, follow the prompts. You don't need to update the phone through it, but get the phone ready for updating. This process should install the drivers necessary for the rooting process.

Note: I suggest you keep your USB cable attached to that USB port. Remember which USB port of your computer it's attached to, as changing USB ports can lead to a bit of confusion for the next 2 steps!

3) To check if #2 was successful, click on Start, click Run, and type: regedit
In the Registry Editor that pops up, click on Computer, press CTRL+F, and search for this: USB\Vid_0fce&Pid_adde\

After it's finished finding, on the right side you'll see DeviceInstance, then it says REG_SZ, then it says something like USB\Vid_0fce&Pid_adde\5&270d2a78&0&3
You'll need that last bit (in this example: 5&270d2a78&0&3 Yours would probably be different). This is your DeviceID (you'll need it soon!)

Note: You may have multiple of these if you plugged the USB cord into many USB ports on your computer. Each USB port will give a different DeviceID, so if you have more than one DeviceID, you'll have to choose one, and if it doesn't work (you'll find out when you reach #5!) you will have to choose another one.

Alternatively, download the file in the next step and extract it, go to the folder called 1st, and run the DeviceID.jar file. It should give your DeviceID

4) Download this:
Download R1FA16 rar
or from here:
Extract it.
In the step1 folder, you'll see a file called DeviceID.txt
Open it up, delete whatever's there, and put YOUR DeviceID (that you found from the previous step).
Save the file and close notepad.

Note: Make sure there are no extra spaces or lines after/before the DeviceID. The ONLY thing that should be in the file is your DeviceID, NO SPACES/LINES (for example, only this: 5&270d2a78&0&3 [yours will probably be different])

5) Take out the USB cable from your phone (leave it plugged into your computer)
Turn your phone OFF
Open up step1.cmd (it's not inside the step1 folder, but outside it), but DON'T PRESS ANYTHING

Now we have to put the phone into flash mode. This is how you do it:
Hold the Back button on your phone, and while holding the back button, insert the USB cable into the phone.
A green light should come on the phone (like when it's charging or a missed call)
Quickly "Press any key to continue..." in the open step1.cmd window.

Let it finish what it's doing. It will say "Press any key to continue..." after it's finished. Until then, DON'T touch anything!

If you get problems in this step, refer to this post:
Here's a helpful video for common java issue: [ROOT/De-Brick Guide] Java Issue 64 bit Fix Walkthrough (Video guide included) - xda-developers

After completion, this will give you a Generic X10i R1FA016 firmware (check it by pressing the left button, go to settings>about phone and at the very bottom under build number)
Keep your phone plugged into the USB.

6) Run SEUS to get to the latest firmware (do this before 2.1 is released in the UK if you don't want 2.1)

Sorry to the people who don't want the UK firmware but this is all I know at the moment.

If you any other way, please let me know and I will add it to the post :)


Android Expert
Thread starter
I think he was back on 2.1 when he wrote this post. Only person I know so far that had 2.1, went back to 1.6 & is back to 2.1. :eek:

Ye, I went to 2.1, but it was very laggy so I went back to 1.6, but then found out the lag goes after about 30 minutes, so I went back to 2.1 and now its brilliant, no lag at all and havn't come across any problems. Also, I was up all night playing Angry Birds lol :)


i had to go to old apps site to find the specific update 20 java 32 bit, other than that it worked a treat thnx, i noticed there were some errors whilst on 2.1 so i'll wait for the proper uk version, at least the errors will then be sony's :)

i had planned changing the prop file back after getting 2.1, be warned you cant cos its not there anymore


Well-Known Member
Apparently, if you run SEUS in the UK it will tell you that you have the latest software, but if you click install anyway, it brings you to 2.1 (I have not tried this though). I am about to debrand back to 1.6 and give it a bash though as my APN settings are really disfunctional with the nordic version and the signal keep dipping out.

Well-Known Member
CuBz, that guide looks foolproof (so i should be able to do it!)
I wanted to ask about going up to .24 from .504 though, I have read (most!) of this XDA thread ( Generic 2.0.2.A.0.24 firmware (21/12/2010) | rooted | for xRecovery + X10flasher - xda-developers )
But the 5th step is somewhat confusing me, i have been through the thread but still can't get my head around it, quite simply - i don't know what folder to "put" the SIN files into (in the flashtool where is says "flash the SIN siles with xflasher").

I have "flashed" the multi touch accross my 3 working roms, the guide for that improvment told me to put the files into the "fimewares" folder, easy peasy. - So is this where to put the SIN files mentioned? and what about the "loaders", do they go in the same file??

sorry if this is covered elsewhere. I have looked.

I wasn't going to persist in this update - but went to try the "blue Sparks" ROM the other day, but got an md5 mismatch, checked the name was ok - then realised it said ROM was for working .24. Didn't have that problem with Eminence ROM, but this was installed as a custom zip, rather than a "restore" on xrec.

Runs off to excitedly look at x10i's green glow...

EDIT - i have found the info needed! here :


hi, i have a sony xperia x10a
i updated it to the latest firmware n for sum reason it keeps freezing then rebooting when im running apps on it.
now i dont c the point of this phone if i cant run my favorite apps...
my phone used to work fyne before the update, nothing ever used to happend. Sony said try re-installing and changing ur battery, well i cant buy a new battery because i just cant. it cant b my battery prob because it worked fine before the update.
I've been wanting to downgrade back to 1.6 and i found this thread. Ive come to step number 5 where u have to run step1 to flash the phone. But everytime i open step1.cmd it closes on me and doesn't even stay up for a sec more like half a sec. I dont understand y.... i updated my phone before so i must have all the nessesary files as said in step one or an earlier step.

CAN SOMEONE PLEASE HELP ME ;( i just wannt to go on my fav apps but this update ****ed EVERYTHING up and im really agitated and anoyed. can someone please help me n tell me y i am stuck ?

btw- i have windows vista. THank you :)


Android Expert
How did you run the update before.... if you used PC Companion then it might be worth trying Sony Ericsson Update Service and seeing if you can run a repair with that.