1. Download our Official Android App: Forums for Android!

Root [guide] How to manually downgrade firmware build 6.01.605.05 and newer

Discussion in 'Android Devices' started by scotty85, Jul 29, 2012.

  1. scotty85

    scotty85 Extreme Android User
    Thread Starter
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    i had no idea either,until i looked at the commands. its next to impossible sometimes when folks just say "i did this and got this response!". seeing it all in context usually helps quite a bit. :)
     

    Advertisement

  2. bbdino

    bbdino Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Aug 17, 2012

    Aug 17, 2012
    1
    0
    5
    I had a problem with the flash, other than having to run rebootRUU twice to get to the proper screen (kept getting FAILED (status read failed (too many links)) I didn't have any problems prior.

    While running it the proper black screen with silver lettering it successfully ran the UZ,hboot / WP,hboot / UZ,boot / WP,boot but FAILED when beginning the image[recovery] unzipping & flushing...

    I was in the process of renaming it and attempting to send to SD card when I realized I was in the wrong screen, here is the CMD log from that point:

    c:\miniadb_inc2>fastboot flash zip PG32IMG.zip renamed it
    < waiting for device >
    sending 'zip' (292817 KB)... OKAY [ 49.299s]
    writing 'zip'... INFOadopting the signature contained in this i
    mage...
    INFOsignature checking...
    INFOzip header checking...
    INFOzip info parsing...
    INFOchecking model ID...
    INFOchecking custom ID...
    INFOchecking main version...
    INFOstart image[hboot] unzipping for pre-update check...
    INFOstart image[hboot] unzipping & flushing...
    INFO[RUU]UZ,hboot,0
    INFO[RUU]UZ,hboot,100
    INFO[RUU]WP,hboot,0
    INFO[RUU]WP,hboot,100
    INFOstart image[boot] unzipping & flushing...
    INFO[RUU]UZ,boot,0
    INFO[RUU]UZ,boot,31
    INFO[RUU]UZ,boot,73
    INFO[RUU]UZ,boot,100
    INFO[RUU]WP,boot,0
    INFO[RUU]WP,boot,99
    INFO[RUU]WP,boot,100
    INFOstart image[recovery] unzipping & flushing...
    FAILED (status read failed (Too many links))
    finished. total time: 98.233s
    c:\miniadb_inc2>fastboot reboot-bootloader
    < waiting for device >
    rebooting into bootloader... OKAY [ 0.157s]
    finished. total time: 0.158s
    c:\miniadb_inc2>fastboot reboot
    rebooting...
    finished. total time: 0.171s
    c:\miniadb_inc2>

    It appeared to run all of the updating on the RUU screen properly, but it did Bypass the [8] TP

    I figured it worked, ran the final commands and moved on, boots up fine.
    When I try to use revolutionary, however,

    [edit]

    I get stuck at:

    "Communication with phone unexpectedly interrupted. Try again"
     
  3. Droido2381

    Droido2381 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Aug 17, 2012

    Aug 17, 2012
    6
    0
    5
    Georgia
    Can someone tell me why it wont pick up my device in the step where its suppose to return your serial number???

    I receive a message saying "daemon not running. starting it now. daemon started successfully. list of devices attached. List of devices attached." but not my serial number :(
     
  4. scotty85

    scotty85 Extreme Android User
    Thread Starter
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    -enable usb debugging
    -phone in charge only mode
    -try different cables and ports on your pc
    -if all else fails,its likely a driver issue. did you run the .exe file to install the drivers?
     
    HpTouchMePad and Droido2381 like this.
  5. scotty85

    scotty85 Extreme Android User
    Thread Starter
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    from the red text,it appears the ruu failed. if you ran it again and different results that you didnt paste,i cant comment. double check that you are on hboot .97 if so, i have no idea why revolutionare would give that output. off the top of my head,make sure htc sync,and NO programs capable of comunicating with the phone are running.

    if youve successfully downgraded to .97 hboot,may want to start a thread in the forum :)
     
  6. Droido2381

    Droido2381 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Aug 17, 2012

    Aug 17, 2012
    6
    0
    5
    Georgia

    I've installed the necessary software. (SDK and AVD kits and even eclipse for future development use.) They are located in my "SDK" folder in the root of my C: drive. I have run the adb device command multiple times after trying to solve my driver installation issue and I'm still not getting my serial number feedback. Just says "list of devices attached" Also usb debugging is on and fastboot is off. Im running 2.3.4 trying to downgrade before root.

    All of my files are in C:\SDK. MY COMMAND PROMPT STARTS IN MY C:\USERS FOLDER, SO DOES IT NEED TO BE IN MY C:\SDK FOLDER TO RUN ADB DEVICES??
     
  7. bberryhill0

    bberryhill0 Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    2,716
    Joined:
    Jan 27, 2010

    I would definitely "cd" to your "SDK" directory.
     
  8. Droido2381

    Droido2381 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Aug 17, 2012

    Aug 17, 2012
    6
    0
    5
    Georgia
    No luck
     
  9. bberryhill0

    bberryhill0 Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    2,716
    Joined:
    Jan 27, 2010

    Can you see your sdcard when you mount the phone as a drive?
     
    Droido2381 likes this.
  10. scotty85

    scotty85 Extreme Android User
    Thread Starter
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    none of those are going to matter if you dont have drivers. again,have you installed drivers?

    if youve doublechecked usb debugging is on,phone in charge only mode, tried as many different usb cables and ports as possible,and run the .exe file linked to install the drivers,then you may try installing the drivers manually.

    find your phone, plugged in,usb debug on,in device manager and update its drivers. point the wizard to the extracted revolutionary .exe file. (HTCDriver3.0.0.007)

    if that fails,i see 99% of the time when everything looks 100% correct and still doesnt work that something is running on the PC,interefering with comunication. make sure youve disabled htc sync,pdanet,easytether,and any other program on your pc that is capable of communicating with your phone.

    unfortunately,some folks never seem to figure out exactly what is going on,and have success only by using a "virgin" pc or laptop thats never had any phone stuff installed :eek:

    last and not least,you seem to have further development plans in mind,and as such your needs are greater than the normal folks who just want to root their phone,so i not directing this to you,i just want others reading to not have any confusion: you do not need to install the sdk to use this guide. adb and fastboot are included in the mini-adb_inc2 download. :)

    edit:
    if youre getting the 'list of devices' response,then adb is in the directory youre using(or at least in its path).so the directory is not your issue.
     
    Droido2381 likes this.
  11. Droido2381

    Droido2381 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Aug 17, 2012

    Aug 17, 2012
    6
    0
    5
    Georgia
    Thanks for all your help. I finally just did an HBOOT install and it worked!
    My post from droidforums and the site that helped.

    Driver install fixed!

    Holy hell I finally searched enough and tried the HBOOT DRIVER INSTALLATION. If you are having any troubles with driver installation just use these instructions. Hope this helps!!

    public:windows_hboot_driver_install [RootWiki]
     
  12. KaHOnas

    KaHOnas Newbie
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Aug 5, 2012

    Aug 5, 2012
    13
    4
    16
    I think I did something wrong. I saved a .txt of all my C: prompt entries and haven't seen any errors. I followed the instructions and thus far I have S-off, I have superuser installed, but Titanium Backup is saying I don't have root. I got a small app called "root check basic" and it claims I have not achieved root. Any ideas of where I may have gone wrong and how to correct it?
     
  13. scotty85

    scotty85 Extreme Android User
    Thread Starter
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    if youve got s-off and recovery installed,youve accomplished the hard part.

    did you flash a superuser in recovery,or did you simply download it from the market?

    you need to flash this from recovery: http://www.androidfilehost.com/main/-Support_Files-/superuser/Superuser-3.0.7-efgh-signed.zip

    wipe dalvik and cache
     
    KaHOnas likes this.
  14. scotty85

    scotty85 Extreme Android User
    Thread Starter
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    glad you got it working. make sure that it installed drivers for fastboot as well by checking connectivity with fastboot devices and the phone in fastboot,not hboot.

    hboot is for flashing via sd card,fastboot is the bootloaders mode for PC/command line comunication :)
     
    bberryhill0 likes this.
  15. KaHOnas

    KaHOnas Newbie
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Aug 5, 2012

    Aug 5, 2012
    13
    4
    16
  16. milleraj66

    milleraj66 Lurker
    Rank:
    None
    Points:
    6
    Posts:
    2
    Joined:
    Jun 20, 2012

    Jun 20, 2012
    2
    1
    6
    I'm new to the forum, but I've got a quick question.
    I used this method and everything went fine. it says i have s-off but then i used root checker and it says i don't have root privliges. Anyone have any ideas?
     
  17. scotty85

    scotty85 Extreme Android User
    Thread Starter
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    did you install a recovery,and then flash superuser files? if not then you are not "rooted" i.e.,having superuser access to /system.

    this guide is only to downgrade to older firmware where the revolutionary s-off tool will work,its not intended as an all inclusive root guide,sorry for the confusion.

    if you have s-off,youve successcully completed what this guide was intended to do.

    if you did not have revolutionary install a recovery,your next steps will be:
    1)install a recovery in hboot as a PG32IMG http://forum.xda-developers.com/showthread.php?t=1240426
    2)flash superuser files in recovery superuser
     
    bberryhill0 and milleraj66 like this.
  18. milleraj66

    milleraj66 Lurker
    Rank:
    None
    Points:
    6
    Posts:
    2
    Joined:
    Jun 20, 2012

    Jun 20, 2012
    2
    1
    6
    Thanks a bunch bro, I was banging my head trying to figure out what i did wrong.
     
    scotty85 likes this.
  19. scotty85

    scotty85 Extreme Android User
    Thread Starter
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    anytime :)
     
  20. jntdroid

    jntdroid Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    254
    Joined:
    Aug 18, 2010

    Aug 18, 2010
    254
    35
    43
    CFP
    Just picked up an Inc2 to hold my upgrade a little longer - had one over a year ago. Great guide man - I've had/rooted a lot of phones, this one's pretty in depth... lol.
     
  21. jntdroid

    jntdroid Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    254
    Joined:
    Aug 18, 2010

    Aug 18, 2010
    254
    35
    43
    CFP
    I guess my only question at this point would be is there a way to revert back to 6.01.605.05? I've seen the pg32img.zip to revert to 5.10.605.9 - but it doesn't replace the bootloader. Trying to find an old thread by jcase that reverted back even further and replaced the bootloader I believe...
     
  22. scotty85

    scotty85 Extreme Android User
    Thread Starter
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    there is a PG32IMG to get back to 6.01.605.5: Shipped ROMs (vivo_w section: http://shipped-roms.com/index.php?category=android&model=Vivo_W )

    this guide downgrades you all the way back to 2.18.605.3,wich does change the hboot to rebolutionary-able .97

    if you want to go back even further for some reason,all you need to do is change 2.18.605.3 in this command line to a lower version number:
    adb shell /data/local/tmp/misc_version -s 2.18.605.3

    you could technically change it to 1.0.000.0 and then flash any ruu you wish. you only need to go back to 2.18.605.3 in order for revolutionary to work,however.

    once youve used revolutionary for s-off, nothing youy flash will change the bootloader. revolutionary uses a hard-patched hboot for s-off,meaning the hboot itself is giving s-off,not the radio. if the hboot is overwritten,then s-off is gone,so the revo hboot protects itself from overwrite. you must purposely remove it to get rid of it,you cant just flash an ruu.

    if you want different hboots with s-off,then you need radio s-off,wich is still possible via an xtc clip.
     
    bberryhill0 likes this.
  23. jntdroid

    jntdroid Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    254
    Joined:
    Aug 18, 2010

    Aug 18, 2010
    254
    35
    43
    CFP
    Thank you for that link. Server seems to be down now, but I'm sure it'll be back up later. Somehow I couldn't find that last night!

    I'm simply trying to make sure I have a way to get it back to it's current "factory" setup. It doesn't seem to want to grab any OTA's when I revert back to stock otherwise. So now the only question is getting back to the current hboot (still .98?).

    I have also previously used this method to replace revolutionary's hboot with .97. The question is, how to get back to .98 or later...

    Well wait, I might've just solved it in my head. If I can get it back to the .97 hboot, the 6.01.605.5 PG32IMG.zip will update hboot along with everything else won't it, since it's not rev's hboot?

    So if that's correct, the path "back to stock" would be to use that method above to get to .97 hboot, then flash the 6.01.605.5 PG32IMG.zip. And then I guess the 0312 radio if the previous PG32IMG doesn't update that.

    Sound right, or am I missing something?
     
  24. jntdroid

    jntdroid Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    254
    Joined:
    Aug 18, 2010

    Aug 18, 2010
    254
    35
    43
    CFP
    Hey you (or anybody) wouldn't happen to have a mirror for that 6.01.605.05 file would you? That link is still down.
     
  25. scotty85

    scotty85 Extreme Android User
    Thread Starter
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    no,sorry,i dont. hopefully it will be up soon,or i could try and find somewhere to upload it later.

    so are you wanting to root? or unroot? im a little confused ...
     

Share This Page

Loading...