1. Are you ready for the Galaxy S20? Here is everything we know so far!

[GUIDE] How to Root - Insignia Flex 8" NS-14T002

Discussion in 'Android Devices' started by Sepero, Jan 5, 2014.

  1. Sepero

    Sepero Linux Guru
    Thread Starter

    Merry Christmas, I recently got this tablet. This advice is only for NS-14T002 (as far as I know). How to get Root access.

    After finishing here, see my Guide on installing ClockWorkMod on Insignia Flex 8 NS-14T002.


    1. Make sure USB debugging is enabled on the device. For instructions, see my previous thread on adb insignia flex 8.
    2. Download Cydia Impactor for your OS.
    3. Reconnect the tablet via USB to your computer.
    4. Start the program as Administrator (run as root/sudo on Linux)
    5. On Windows, you will need to have the USB drivers for the device installed. You can also try the inbuilt Driver Scan function in Cydia Impactor to automatically construct and install a driver for your device. From the menu choose: USB > Driver Scan
    6. Making sure that # drop SuperSU su to /system/xbin/su is selected in the dropdown menu, and click the Start button.

    Wait a few seconds and your tablet should be rooted. The tablet already comes with a generic version of busybox preloaded, so you may not need to install busybox from the play store. Congrats.

    Device partition information:
    Code (Text):
    1. mtdblock0 misc
    2. mtdblock1 kernel
    3. mtdblock2 boot
    4. mtdblock3 recovery
    5. mtdblock4 backup
    6. mtdblock5 /cache
    7. mtdblock6 /data
    8. mtdblock7 kpanic
    9. mtdblock8 /system
    10. mtdblock9 /sdcard
    This tablet is also mistaken for model NS-14TOO2 (Someone in marketing put "OO" on the box instead of "00" zero zero). You will find NS-14T002 under the model in the device settings.

    andro1d5 likes this.

    1. Download the Forums for Android™ app!


  2. Sepero

    Sepero Linux Guru
    Thread Starter

    Reserved post
  3. andro1d5

    andro1d5 Newbie

    Thank you very much. Clear and flawless instructions.
  4. D_Manes

    D_Manes Lurker

    Didn't work.

    Followed the instructions to the letter, ran the program, everything looked good, but when I ran a check for Root, it said sorry...

    Any thoughts?
  5. Sepero

    Sepero Linux Guru
    Thread Starter

    Did you enable USB debugging on your device? (Step #1)
    If yes, then I can only recommend going through the steps again. After plugging in the USB, wait a few minutes to see if your machine recognizes the device. Also, perhaps try a different USB port.
  6. MrDayAndNighT

    MrDayAndNighT Member

    Following instructions.cant get Cydia to recognize device... drivers installed...in device manager...shows "Android phone" and "android composite adb interface" also the device is on usb debugging and connected as MTP device...

    what am i doing wrong?
  7. MrDayAndNighT

    MrDayAndNighT Member

    And do i have to get adb access first ??? only with linux ???
  8. Sepero

    Sepero Linux Guru
    Thread Starter

    Hi MrDayAndNighT. I'm not sure why it isn't working for you. You must "enable" adb/debugging access on the device as step number #1.

    I use Ubuntu Linux as my OS, and that's the software I used to rooted my device. The Cydia software should work the same for Linux and Windows.

    It may help to tell us anything you can about your system, or any possible abnormalities:
    32bit or 64bit?
    Windows 7?
    USB 2.0 or 3.0?
  9. MrDayAndNighT

    MrDayAndNighT Member

    hi, thanks for replying Sepero...

    First off... i do have usb debugging checked in developer options... my computer does see it as android composite device in device manager with no yellow exclamation...
    and the device has mtp and camera (ptp)option and mtp media device is checked...

    i start cydia to start... im stuck there... says no device found... ive tried many times and run program as admin... nothing...

    i have windows 7 64bit... ive rooted htc and lg phones with no problem and have sdk tools installed... usb 2.0 and have tried diff ports...

    any more input on what im doing wrong?
    been all over google for weeks with no solution.i dont have the protection plan and hope not to brick...lol problem seems to be they are not communicating... but the device does show on comp...hmmm

    your input is appreciated
  10. Sepero

    Sepero Linux Guru
    Thread Starter

    Hopefully, someone with Windows will post and give some insight on how they got it to work.

    No need to worry about bricking your device until after it's rooted. Perhaps "no device found" means that there is a problem with the drivers?

    Before using Cydia Impactor, I tried over 5 other different rooting methods, and they all failed. So getting Cydia to work is key.
  11. MrDayAndNighT

    MrDayAndNighT Member

    hi, ok i guess ill try messing with drivers... do you know any other way i can see if the device and comp can see each other via adb using windows command prompt?
  12. MrDayAndNighT

    MrDayAndNighT Member

    ok well i got the comp to see the tablet with it off...it now sees it as htc dream... adb reboot works... now running cydia...its says unable to see package manager...is the system running?

    and with the tablet on... it doesnt communicate...and see's it as "android composite device"

  13. Sepero

    Sepero Linux Guru
    Thread Starter

    I didn't want to recommend this, but as a last ditch option, you might try using an Ubuntu LiveCD.

    Essentially, the steps would be something like this

    1. Download Ubuntu
    2. Burn it onto a CD or install to USB
    3. Reboot your computer in Ubuntu ("Try Ubuntu")
    4. Download Cydia Impactor (32bit) for Linux
    5. Open a file browser, extract the Impactor "tgz" archive file
    6. Go into the Cydia folder and run the Impactor file
  14. MrDayAndNighT

    MrDayAndNighT Member

    Hi Sepero,

    Well after several attempts, I took your advice.... took me awhile to get it setup...but I finally finally got it rooted using Ubuntu...at first had same problems not recognizing device... did all more research and ran some commands via terminal...ran cydia and presto it worked:)

    now that I'm rooted... noticed the su binaries are outdated in the su app...ran su fixer thru market it says its fine...
    They have a su update available...but it's a zip I would have to flash...
    so basically I'm sort of interested in installing the cwm recovery they have for the ns14t002
    ... have you seen it??? suppose to just work for this device... would u recommend it???

    they have the cwm and stock recovery In case need go back...

    so basically my question is... would you do this? or do you have a custom recovery on yours??? and secondly is the outdated su a biggie???

    your opinion is appreciated and thanks for the insight about running it in Ubuntu:eek:
  15. Sepero

    Sepero Linux Guru
    Thread Starter

    Wow, that's great news to know everything worked out for you. Glad to hear it. I'm interested to acquire CWM also. I contacted Shabbypenguin and he was Very kind to provide me a couple different CWM binaries, but unfortunately they didn't work on our device. We don't know why. So currently I have no recovery.

    I haven't seen this recovery you are referring to. Post a link and I would be willing to test it. If it works, I'll post up a new guide for that.

    (For your question about the outdated "su", I personally wouldn't bother with it, because it won't provide any noticeable difference in operation.)
  16. MrDayAndNighT

    MrDayAndNighT Member

    Hello Sepero,

    OK cool about the su... here is the link... seems to work
    Insignia Flex - xda-developers

    P.S. just saw a person there who just rooted this device with kingo root, hmmmm wonder if it really worked... well check it out and let me know how it goes.... I've been dying to try it;)
    Sepero likes this.
  17. Sepero

    Sepero Linux Guru
    Thread Starter

    I avoid kingo because it is reported to contain malicious virus software. Perhaps why it only runs on Windows? As a Guide on our forums, I couldn't recommend kingo in good conscience- especially when the job can be done with a perfectly open source tool like Cydia Impactor.

    So thanks for the link to the CWM. i will definitely try it out a little later today. If all goes well, I should have a new How To guide for everyone soon.
  18. Sepero

    Sepero Linux Guru
    Thread Starter

    Good news. It works. You need to write it over the partition /dev/block/mtdblock3. I don't know if it has any bugs, but it works. Cheers
  19. MrDayAndNighT

    MrDayAndNighT Member


    Alright sounds good....I'll give it try in awhile...thank for letting me know :)

Share This Page