1. Are you ready for the Galaxy S20? Here is everything we know so far!

[GUIDE] How to root T-Mobile 6.0 update

Discussion in 'Android Devices' started by TMacgnolia, Mar 11, 2016.

  1. tube517

    tube517 Android Expert

    I'm having the same issue. I installed the adb tool that was linked by Blu. Still did not work. What did you end up doing to make it work?
     

    Advertisement

    master odysues likes this.
  2. Jack Mickey

    Jack Mickey Well-Known Member

    @Zardoz007 , afaik, in order to use kingroot. You have to unlock the bootloader first. This can be done using adb and fastboot. During the process, you can boot your phone temporarily to twrp, flash the supersu zip, then reboot system. If twrp asks if you want to install supersu say no. Once rebooted, use flashify to flash twrp, and you should now have root and custom recovery installed. My main reason for this post is because i had the same issue with kingroot. The adb fastboot method seemed far easier and safer imho.
     
    #152 Jack Mickey, Mar 26, 2016
    Last edited: Mar 26, 2016
  3. tube517

    tube517 Android Expert

    Well, I finally got MM and root. I had to update every driver on my laptop and had to unlock bootloader using the OP's method and then rooted w/kingroot and just flashify/TWRP. Flashed SU and kingroot was gone. TiBU is now restoring some apps.

    I'll miss XCam/Xcam settings
     
  4. Blu8

    Blu8 Android Expert

    I thought Xcam had a beta build for MM? The zip file didn't work for me when I tried it but I just installed it as a user app a couple of weeks ago.
     
    tube517 likes this.
  5. tube517

    tube517 Android Expert

    Nice. I didn't know about the MM beta. will check it out
     
    Blu8 likes this.
  6. zardoz2112

    zardoz2112 Newbie

    I'm having the same roblems that @Jack Mickey had before he found salvation. I suppose I should have asked...is there any known issues with using Windows 10 to accomplish this? I just can't get any fastboot recognition. Incredibly frustrating.
     
  7. Blu8

    Blu8 Android Expert

    Fastboot worked without a hitch on my Windows 10 desktop, actually I couldn't flash the recovery.img using fastboot so I just booted and did the whole rooting and flashify-ing process to get TWRP. But other than that it recognized my phone in fastboot mode.
     
  8. zardoz2112

    zardoz2112 Newbie

    Man, I tell ya, I'm so frustrated I'm ready to Vote Trump! I feel driven to get this done tonight, but I am running out of time, and pissing off my wife in the process. Effin' Easter!

    I dunno if I got the right drivers. The ones that the phone instals? Device manager seems to think they are fine. Although it does list more than a few of them when I go and look it up. Adb has fastboot. Maybe I need to uninstal/reinstal it. Had to use the older one, new one gave me the 0 files coped issue. I can't seem to find in programs where to uninstal it however. My freaking brain is trying to kill me at this point, I think.
     
    #158 zardoz2112, Mar 26, 2016
    Last edited: Mar 26, 2016
  9. jmitchell1979

    jmitchell1979 Member

  10. zardoz2112

    zardoz2112 Newbie

    I sincerely appreciate all you smart guys helping me out here. I dunno if I have the will to go on...sob...
    If I don't stop, I could be up for days, and my wife and kids will stop speaking to me if I 'Eff up Easter.
    I may just have to live with the wonderfull world of UNROOTED Marshmallow for a while until someone MUCH MUCH smarter and more patient than I figures out a one-click trick.
     
  11. RikuAzhurlar

    RikuAzhurlar Lurker

    just saw the 6.0 update somewhere else and i instantly went to work on it. glad we already have root for the 6.0 update. unfortunately i found an issue with making a flashable zip. this update seems to change the partition table slightly since the system image is just barely over 2GB
     
  12. RikuAzhurlar

    RikuAzhurlar Lurker

    from what ive seen on the surface no changes but in the code its brought imrovements to art and a form of deep sleep when the device is locked that actually saves battery
     
    Blu8 likes this.
  13. xyourxhighnessx

    xyourxhighnessx Android Enthusiast

    My nexus 7 2013 runs marshmallow better than this stylo (at least my specific stylo). Don't get me wrong the standby time is great but the battery seems to tank when I'm using the phone. More so than it did in 5.1.1 but nothing major or epic. I'd just say a decrease. I'm still sticking with marshmallow though. Defintiely. I think the now on top is useful if I can train myself to use it instead of copy/paste to search things but old habits are hard to break lol
     
  14. xyourxhighnessx

    xyourxhighnessx Android Enthusiast

    Can you upload a new link to the drivers ? That link didn't work for me and the drivers I had installed to update my metro stylo don't seem to be working for this.

    Everything works great until I type fastboot devices. Adb devices works and shows I'm attached. Adb reboot bootloader works.

    I enter fastboot devices and nothing shows.

    The oem unlock command just says "waiting for device" until I give up n close it down
     
  15. xyourxhighnessx

    xyourxhighnessx Android Enthusiast

    OK i finally got it working. I had to flash the SU zip twice. First time everythingvwent according to plan.

    But upon boot I didn't have root.

    I Boot into twrp again and flashed again and this time it worked

    Do I flash the recovery IMG u provided with flashify or do i use a different version of twrp?
    I'm doing it this way because it failed to flash via fastboot as warned it may do
     
  16. brucedroid

    brucedroid Newbie

    So is anyone going into or currently developing a custom 6.0 rom?
     
    master odysues likes this.
  17. TMacgnolia

    TMacgnolia Well-Known Member
    Thread Starter

    Updated the guide to show steps to properly use Kingroot to root successfully thanks for the info.
     
    #167 TMacgnolia, Mar 29, 2016
    Last edited: Mar 29, 2016
    tube517 likes this.
  18. CYCONUMNUM

    CYCONUMNUM Android Expert

    i tried kingroot after flashing Tmobile to my Metro and updating to MM...
    and it got me in a boot loop after rebooting on its own....
    i did'nt get to flashify anything...but, it did say i was rooted....
    so i updated to MM twice...boot looped twice
    before giving up and leaving it vanilla MM
     
  19. ghet2rockuu

    ghet2rockuu Android Enthusiast

    u need to unlock the bootloader
    through adb commands
     
    CYCONUMNUM likes this.
  20. CYCONUMNUM

    CYCONUMNUM Android Expert

    ahhhhh....i see....
    i did not even use ADB/fastboot
    i just rooted it with king ....same steps that work with lollipop..
    OK :) ...thanx for pointing out something obvious that i did'nt see..
    i attempted the ADB method..but did not install ADB correctly
    it would'nt see the device
    thanx man.......
    i really appreciate it :)
     
  21. ghet2rockuu

    ghet2rockuu Android Enthusiast

    fyi this mm will eat your battery i went back to ll
     
  22. Blu8

    Blu8 Android Expert

    Not sure why that happened to you, I get 24 hour battery life and consistent 6-7 hours SOT, phone sleeps like a baby, hell even better than a baby.
     
    Jack Mickey, tube517 and antonioblee1 like this.
  23. Telyx

    Telyx Well-Known Member

    It's working fine for me too--battery seems to last at least as long as it did on LP.
     
    Jack Mickey, Blu8 and tube517 like this.
  24. ghet2rockuu

    ghet2rockuu Android Enthusiast

    not mines im on a metro phone , n the battery evryminute im on it it goes down a percentage i had to switch back with in an hour phone was almost dead
     
  25. Blu8

    Blu8 Android Expert

    I have a Metro phone too, flashed the T-Mobile kdz and took the OTA's to Marshmallow. Nothing like that. It's on your end.
     
    tube517, Jack Mickey and CYCONUMNUM like this.

Samsung Galaxy Note 8

Welcome to the Galaxy Note 8 Forum where you'll find help, tips, tricks, accessories, reviews, and more for Samsung's S-Pen enabled smartphone. With a 6.3-inch screen, 6GB RAM, 8MP/12MP front & back cameras and a whole lot more- the Galaxy Note 8 is an absolute BEAST!
Loading...
Tags:

Share This Page

Loading...