1. Are you ready for the Galaxy S20? Here is everything we know so far!

Guide: How to S-Off, Root and install CWM. On a Wildfire running Froyo 2.2.1

Discussion in 'Android Devices' started by Howard Hopkinson, Jun 27, 2011.

  1. Howard Hopkinson

    Howard Hopkinson Android Enthusiast
    Thread Starter

    I don't have the md5 checksum of the apk, but that's the version I used the very first time I did the procedure.

    When I did my sons phone, he purchased the new version of Root Toolbox from the market and that worked fine too.

    1. Download the Forums for Android™ app!


  2. warhein

    warhein Lurker

    I went to this site:


    But it only shows hboot 1.01.0001 for HTC Wildfire.

    HTC Wildfire (buzz) 1.01.0001.

    Are you guys sure it works for 1.01.0002 ????

  3. Howard Hopkinson

    Howard Hopkinson Android Enthusiast
    Thread Starter

    If support for Hboot 1.01.0002 is not there, then it must have been temporarily discontinued for some reason.

    I will change the guide to reflect the change.
  4. NFSGamer

    NFSGamer Lurker

    Thanks for the brilliant tutorial man :)

    A couple of things to note for others who are going to try this

    1) When I ran the GingerBreak app, it didn't restart the phone. However, just powering it off normally, and powering it on normally again did the job. If the booting process takes longer than usual, this is a good sign that rooting worked. It is normal for first booting after rooting to take a while.
    2) An easy way to install GingerBreak is to go to the market, download Linda File Manager, go to Settings->Applications and make sure the box is ticked for the option labelled "Allow installation from non-Market sources", copy the downloaded APK file onto your SD card, get into Linda File Manager, find the file, and single click it. Et viola, the APK should be installing
    3) When you run Revolutionary, there is an option to download and install ClockworkMod Recovery. I chose to allow it to do that. It installed the newest version of ClockworkMod Recovery, and I didn't have to install Root Toolbox

    Once again, thanks for the brilliant tutorial, and I hope my advice is useful :)
    Togera and Howard Hopkinson like this.
  5. Howard Hopkinson

    Howard Hopkinson Android Enthusiast
    Thread Starter

    Thanks for the info, I will add it to the guide.
  6. TheCzAR

    TheCzAR Lurker

    awesome. worked like a charm. thanks a ton...
    Howard Hopkinson likes this.
  7. Howard Hopkinson

    Howard Hopkinson Android Enthusiast
    Thread Starter

    I'm glad you got it sorted and thanks for taking the time to let me know.
  8. hi i followed all the steps but when it click flash recovery it says file manager not found. PLZ Help.
  9. ArchWildfire

    ArchWildfire Lurker

    When i try and install Gingerbreak, it keeps coming up 'gingerbreak could not extract assets'
    please help!

  10. chris2243

    chris2243 Lurker

    I joined this forum to say thanks, what a great tutorial.
    The only problem I had was when running gingerbreak, it took 3 attempts to root. But the best things come to those who wait!!
    I am now using CM7, the stable build, very speedy.
    Thanks again!
  11. Togera

    Togera Lurker

    hey im thinking of rooting my phone,what do i have to do before rooting,will i lose all my data ?

    i got to the point where im about to run ginger break,does my phone have to be connected to my pc ?
  12. Howard Hopkinson

    Howard Hopkinson Android Enthusiast
    Thread Starter

    You should definitely backup the contents of your SD card as well as your contacts to your pc.

    What Hboot does your phone have?
  13. Togera

    Togera Lurker

    my hboot is the .1 version

    i copied all the contents of the sd card to my pc,

    I tried running the apk again with the phone connected to my pc and it said 'not sure what happened please reboot manually and see if you have super user installed'

    I took out the battery and tried to turn it on but it wont get past the quietly brilliant screen
    edit,i went into the bootloader and rebooted from there and it it turned on with the super user app installed.

    Now I want to install a custom rom any recommendations as to what I should install would be appreciated
    When i installed revolutionary and the program asked me if i want to download clockwork recovery I did,where should i go from here ?

    Also please excuse my English since its not my first language

    edit:if im going to need busy box its unavailable in my country do you know where i can get a good apk ?

    edit again,i downloaded rom mangager and tried to flash the cyogen rom,foundit on my sd and said press ok to continue to install,but that just brings me to bootloader
    any help
  14. I also have the following problem! please help, it states file manager not found

    hey mate... my HTC wildfire is rooted(got SU).. installed root toolbox... downloaded ur attached file, extracted and renamed as recovery.img and put in root of sd card.... ran toolbox... erased recovery... but when tapped on flash recovery... it says file not found... plz help mate...
  15. Howard Hopkinson

    Howard Hopkinson Android Enthusiast
    Thread Starter

    There is no need to rename the file as I have already done that for you.

    Download it again as per the instructions and extract it. Place it on the root of your SD card.
  16. i have the file recovery.img on the sd card, f:/recovery.img.

    i really need help!
  17. Howard Hopkinson

    Howard Hopkinson Android Enthusiast
    Thread Starter

    Did you redownload the file as per my last post?

    Once you have the file on the root of your SD card, disconnect your phone from your computer and run the root toolbox programme as per the instructions, it should worke fine.
  18. yeah i downloaded your link aove 30 minutes ago and placed it onto the sd card.

    I then opened up root tool box 'erase recovery' then i hit 'flash recovery' and it states that 'file manger not found'
  19. is there any other app i could use?
  20. Sorted! i did option 3

  21. Ramzanali007

    Ramzanali007 Lurker

    My Hboot version is 1.01.0002 and Revolutionary accepts 1.01.0001 only. What do I do???
    Please Help
  22. Howard Hopkinson

    Howard Hopkinson Android Enthusiast
    Thread Starter

  23. I am new one in this! someone help!
    I can not run Revolutionary! :( download,extract but will not start...
  24. bravo s

    bravo s Newbie

    I'm facing the same problem as Ramzanali007,I can root my wildfire buzz with super oneclick v1.9.5 but i cannot flash recovery. It;s still the red triangle pic. in the recovery mode.
    Help me guys.
  25. mjzulfi

    mjzulfi Lurker

    Thanks alot mate for your awesome post... Im having lots of fun with my HTC Wildfire nw.... Its great... Thanks again... Tc...
    Howard Hopkinson likes this.

HTC Wildfire Forum

The HTC Wildfire release date was May 2010. Features and Specs include a 3.2" inch screen, 5MP camera, 384GB RAM, Snapdragon S1 processor, and 1300mAh battery.

May 2010
Release Date

Share This Page