1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Guide]ROOTING HTC android 2.2.1 or lower with unrEVOked - Windows (updated 20th December 2012)

Discussion in 'Android Devices' started by SUroot, Mar 19, 2011.

  1. SUroot

    SUroot Extreme Android User
    Thread Starter

    This guide is for the desire only. Can't help on your device sorry. You need to see your devices (Evo 4G?) forum here instead.

    1. Download the Forums for Android™ app!


  2. shawpye

    shawpye Lurker

    Thanks for the help. Just changed my windows settings regarding hiding file extensions and I can now use the recovery image.
  3. thebillington

    thebillington Well-Known Member

    Shouldn't this have been made into a Sticky by now?
  4. SUroot

    SUroot Extreme Android User
    Thread Starter

  5. Tunga

    Tunga Well-Known Member

    I rooted my Desire a year or so ago and now a friend has asked me to do his. I am confortable with the risks and so forth, I just want to confirm something because it has been such a long time since I did mine.

    If I just root his phone, it will apply root to the existing ROM, correct? I am not required to apply a custom ROM at the same time.

    He has a lot of stuff that he doesn't want to lose so my plan was to root first, then install Titanium, backup apps, flash ROM, and then restore (user) apps. I have used this process a lot when switching ROMs but without the rooting part. From what I remember that should work fine, can someone confirm?
  6. thebillington

    thebillington Well-Known Member

    You are correct. Rooting the phone will simply grant SuperUser permissions and install a custom Recovery to the phone. The ROM stays the same with all User Apps e.t.c still there.
    Tunga likes this.
  7. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Just check the rooting guide again to make sure you are familiar.

    If his phone is more recent than yours you should check PVT version, and if PVT4 check the erase size: erase size = 40,000 means you should flash AmonRA recovery rather than unrevoked's default (ClockworkMod Instructions are all in the guide.
    Tunga likes this.
  8. Tunga

    Tunga Well-Known Member

    Great, thanks.

    It's not particularly new, it's an early SLCD, around August 2010 (mine was a June 2010 AMOLED). I believe that was before before the new PVT appeared, but I will check it first, of course :) Thanks.
  9. benjaminr2011

    benjaminr2011 Lurker

    So I have Hboot version 1.06. What can i do then to still be able to use unrevoked??
  10. davoid

    davoid Android Expert

    I'm new here and I'm posting, firstly, to ask how long unrevoked takes to root the Desire?

    I'm sat here looking at the application and it still says "Pushing Recovery" - I've been waiting over 10 mins now and nothing indicates any progress, so I was wandering whether something was wrong.

    One thing I've considered is that when I plugged in my phone, i didn't know what USB setting it should be on - USB charge only, Sync, Drive, etc. does it make a difference? I couldn't see anything in the guide that said which setting it should be on.

    Secondly, I'm posting to say 'Hi", as i was too impatient to use the introduction forum... with my phone rooting and all :rolleyes:
  11. SUroot

    SUroot Extreme Android User
    Thread Starter

    It should be fine on any setting as long as debugging is on. Recovery push should complete within a minute. The process shouldn't take more than a few minutes. It does seem like something has gone wrong

    You're using unrevoked 3.21?
  12. jrtfiges

    jrtfiges Lurker


    New here but was hoping for a little bit of help with rooting my Desire if it's at all possible :)

    So I read through your (SUroot's) FAQ and Guide on rooting and decided to do it myself - checked to make sure my Desire was compatible and it was. Couldn't manage to unzip the goldcard.rar file so went straight ahead to the rooting. Had Sync uninstalled (with the driver left in place), installed the HBoot drivers, and finished all the 'prerequisite steps'. Updated the driver software, all the rest. Moved onto actually rooting with unrEVOked buuut it won't do anything at all. The phone's switched on, debugging's on, yet unrEVOked won't recognize it :( so after that I crumbled and went back to trying to get the goldcard to work - downloaded winzip free trial, unzipped the .rar file, got the tool to work, but now it won't find the MMC0 or MMC1.

    Anyways, sorry for the miniature essay and thanks for any help you can offer!
  13. handy5876

    handy5876 Guest

    You dont need to worry too much about goldcard. You can make it at any point of time. You dont even require the phone to read the cid. All you need is a laptop with cardreader (not usb adapter) and gparted live cd. After gparted boots, in the terminal just type the command given in the 'How to debrand the phone' in the sticky. Except type mmc0 instead of mmc1. It will print the cid. Reverse it in pairs and just follow the rest of the steps. The post in the ulockr has a bug and doesnt correctly describe the cid reversing procedure. It is brought out in one of the comments of the post.
  14. SUroot

    SUroot Extreme Android User
    Thread Starter

    If you have a working android device, goldcard helper from the market can get the reverse cid, but the goldcard isn't required for this step.

    The issue is either cable, usb port or drivers. Try other usb ports. If its a desktop, use the rear ports.

    Ensure you have uninstalled any android applications on the pc and try disabling anti virus (which av have you got?)

    If still failing, reinstall the drivers again. Make sure in add remove programs, you can see the HTC drivers but not HTC sync itself.
  15. jrtfiges

    jrtfiges Lurker

    I've never had a problem with the USB ports before (it's a laptop) so I doubt that's the problem - but I'll try and remove my mouse USB receiver and connect the phone through that one instead.
    The only HTC software I have installed is the BMP USB Driver and nothing Android whatsoever (unless it's being obscure and doesn't have Android or HTC in the name of the program).
    My AV is McAfee, and I also have Windows Defender (comes with Windows OS) but I disabled my McAfee FireWall so I'm assuming that worked?
    I'll try reinstalling the drivers again though. I've got work in an hour, so might not have a result until later tonight.

    Also, Handy, thanks for the advice. I think I'll skip the goldcard section for now, I only went back and tried it so hard last night was because I failed at rooting and was bored :p if I can do it post-rooting then it's something I'll look into when I've got more time.

    Cheers guys!
  16. jrtfiges

    jrtfiges Lurker

    Ok, I think I've identified the problem with the rooting. I extract the HBOOT driver files and check that they're installed in device manager, and they are every time. I then disconnect the phone, boot it up and enable USB debugging. I start unrEVOked and connect the phone via the USB cable. However, I checked again about the third time that I did this step that the HBOOT driver files were still installed on the phone, and they're not!
    So for some reason they're installing fine whilst in HBOOT then completely disappearing when I reboot the phone and plug it in to root.

    Sound like there's anything to be done about this?
  17. SUroot

    SUroot Extreme Android User
    Thread Starter

    Device manager only shows devices that are currently connected. When android is running, it uses those drivers (as supplied by HTC sync) and when Hboot is running, it uses the hboot drivers.

    The Hboot device and the android device are seen as separate devices. Think of it like superman. When he is around, Clark Kent is nowhere to be seen. This is normal as they are physically the same person but they are completely different people.
  18. jrtfiges

    jrtfiges Lurker

    I get you, thought that might've been the case :)

    so what's going wrong then? can't get unrEVOked to work, like it won't recognize the phone when it's plugged in even though the computer does. tried it when it's been plugged in, and on a couple of different USB settings (charge only and connected it as an external hard drive or whatever)
  19. handy5876

    handy5876 Guest

    I think maybe you should suspect the computer. Try a different computer preferably with minimum software installations.
  20. SUroot

    SUroot Extreme Android User
    Thread Starter

    Or download a Linux live cd like ubuntu. Burn to cd or make a virtual machine to boot the ISO. No drivers needed. Just download Linux version of unrevoked.

    I have a VMWare guide in my Sig. I'll get a link to the live cd


  21. SUroot

    SUroot Extreme Android User
    Thread Starter

    Added revolutionary link and info for 1.02 and higher.
  22. speedycolzalez

    speedycolzalez Android Enthusiast

    I finally decided to root after running out of space for apps. Thanks for the guide, made the whole process easy peasy lemon squeezy :D

    Off to read the guide for a2sd+ now...
    SUroot likes this.
  23. Chilly McFreeze

    Chilly McFreeze Well-Known Member

    Many thanks SUroot, just rooted my phone and it was completely painless thanks to your guide, great job!
    SUroot likes this.
  24. SUroot

    SUroot Extreme Android User
    Thread Starter

    Thanks for feedback guys.
  25. Alexothy

    Alexothy Lurker

    Hi looking into rooting. Have PTV4 but get a permission denied instead of the expected 20000/40000 when using the emulator. Anyone else seen this?

HTC Desire Forum

Features and specs are not yet known.

Release Date

Share This Page