1. Are you ready for the Galaxy S20? Here is everything we know so far!

Hacker's Keyboard issues

Discussion in 'Android Help' started by MoodyBlues, Apr 5, 2019.

  1. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member Thread Starter

    When I was setting up my new phone (Moto Z² Force Edition, Oreo 8.0.0), I used app settings from my old phone (Moto X 2nd Generation, Lollipop 5.1) as its initial settings, then tweaked as necessary.

    I use Hacker's Keyboard--same version on both phones. I set its settings to match the old phone's--and since then, I've tweaked and tweaked because something's just WRONG.

    On my old phone, when I long-press any key, 8 for example, almost instantaneously its default alternate, *, prints. But on my new phone, it's a crap-shoot. :eek: Sometimes it works...usually it doesn't. I end up having to navigate up the screen to where its alt characters are shown, and press it there.

    EVERY setting is [now] identical to the old phone. Its "long-press duration" is 400ms. I've tried much higher and much lower values, and everything in between, but still can't duplicate the old phone's responsiveness. :(

    Ideas?
     


  2. GameTheory

    GameTheory Android Expert

    Seems like maybe some faulty code. I don't have a solution, but rather some helpful info.

    Have a look on the developers github repo for this app in the issue tracker link which can provide clues from perhaps others with similar issues:
    https://github.com/klausw/hackerskeyboard/issues

    I would also suggest maybe trying a previous version of the app. The developer has all versions available on github:
    https://github.com/klausw/hackerskeyboard/releases

    By the way, the dev also has an alpha version(pre-release) which you can try that may help. It's in the link above.

    If you try any of this, let us know how it goes.
     
    MoodyBlues likes this.
  3. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member Thread Starter

    Thank you, you hot, virile, masculine...oops, wrong thread... :eek: :D
     
    GameTheory likes this.
  4. GameTheory

    GameTheory Android Expert

  5. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member Thread Starter

    Thanks, but no. :(

    I use 'full 5-row layout,' and when I long-press on any key [that has alternate characters], the characters appear, but the default doesn't usually print, as it does on my old phone.

    As in my example, long-pressing '8' should quickly print '*'--but instead, it just pops up a row of the alt characters, and then I have to move up the screen to select the one I wanted (the default, the asterisk).

    Anyway, I've signed up for the alpha version, so let's see if maybe that helps. But like I said, I'm using the identical version (1.40.7 official), with identical settings, on two phones--but this only happens on one of them. :thinking:
     
  6. GameTheory

    GameTheory Android Expert

    MoodyBlues likes this.
  7. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member Thread Starter

    It's already done! I didn't need to DO anything--'signing up' just involved pressing a button; all-knowing Google took it from there, telling me it would automatically download, replacing my current version.
    There's some interesting reading there! People have problems I don't, so that's good (for me, not them). If there's some issue with Oreo, hopefully my problem will get sorted out along with the others.
     
  8. GameTheory

    GameTheory Android Expert

    Ah that was easy. I'm guessing it didn't fix the issue. :(

    I wonder if he may be aware of your particular issue. Maybe a good idea to post in the github issue tracker to make him aware before his next official release.
     
    MoodyBlues likes this.
  9. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member Thread Starter

    I thought about that, too. Maybe tomorrow...
     
  10. jcan577

    jcan577 Lurker

  11. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member Thread Starter

    Okay, a little update: I'm now using v1.41.1 official--and it made my problem 100 times WORSE! :eek:

    Now, when I long-press on a key, all it does is pop-up a row of alternate characters. I then have to navigate to that row to select my choice. At no point does it do what I want, which is automatically print the default alternate character.

    Its settings are as before, so I will tweak them and see if that helps.

    BTW, there's a feedback function on its Play page; only the developer can see those comments. Cool!

    ETA: My old phone automatically updated to the beta version. With all settings identical on both phones...it's just like before, works on old phone, doesn't work on new.

    I've also tried changing various settings, but to no avail. I believe I'll let the developer know my findings. Hopefully, they'll help.
     
    #11 MoodyBlues, Apr 6, 2019
    Last edited: Apr 6, 2019
    mikedt and GameTheory like this.
  12. jcan577

    jcan577 Lurker

    Would it solve all my google & gmail acctssue
     
  13. mikedt

    mikedt 你好

    I have to report exactly the same thing as well when using Hacker's Keyboard. I hold down on top row, it comes up with a selection of foreign accented letters in addition to the associated number, but the number is NOT the default, and end up typing a foreign accented letter instead. The thing is I only have English installed, and have absolutely no need to be typing accented letters, as in French etc. The only foreign language I type is Chinese, which this keyboard doesn't support anyway.

    This was current version installed from Google Play on a Huawei Mate 10 with Pie

    My keyboard of choice is SwiftKey, and have been using it for years. But will sometimes try others, to see what they're like. But I won't be using Hacker's Keyboard in its current form.
     
    #13 mikedt, Apr 7, 2019
    Last edited: Apr 7, 2019
    MoodyBlues likes this.
Loading...

Share This Page

Loading...