1. Download our Official Android App: Forums for Android!

Root HARD Brick Fix for Triumph?

Discussion in 'Android Devices' started by triumphants, Aug 5, 2013.

  1. triumphants

    triumphants Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 13, 2013

    Jul 13, 2013
    14
    0
    15
    I was using Link2SD and hit "Clean up the dalvik-cache" under the app's settings after linking 30+ apps to the sd card. Tried to reboot, but the phone never came back on. I can't get into recovery or download mode, since it doesn't even turn on. Also, no charging light comes on.

    Things I've tried:

    - Use a fully charged battery from wall charger
    - Try a 2nd battery
    - 'Jumpstart' battery using stripped USB charger
    - Charged overnight
    - Try charging using USB w/ computer
    - Pull up pins slightly on charger to make better connection

    Any ideas or am I SOL?
     

    Advertisement

  2. dsmryder

    dsmryder Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    2,418
    Joined:
    May 28, 2011

    May 28, 2011
    2,418
    502
    213
    mechanic
    NE Florida
    Could you check the voltage on the battery? It should be above about 3.6V and below 4.2V.
     
  3. triumphants

    triumphants Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 13, 2013

    Jul 13, 2013
    14
    0
    15
    Stock battery = 3.76V
    Anker battery = 3.88V
     
  4. triumphants

    triumphants Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 13, 2013

    Jul 13, 2013
    14
    0
    15
    I just remembered that I also used Swapper2 before the reboot so it also might be the culprit (I'm not really sure). I made a swap partition, ext4 (sd-ext), and FAT32 on my SD card.

    Swapper2 failed to create a swap file on the swap partition, and I decided I'd figure it out some other time. I had already rebooted once or twice after using Link2SD, but this failed reboot was the first since trying to use Swapper.

    This guy seems to have had the same problem...
     
  5. mozzwald

    mozzwald Newbie
    Rank:
    None
    Points:
    18
    Posts:
    23
    Joined:
    Jul 13, 2012

    Jul 13, 2012
    23
    10
    18
    Male
    Slot Tech
    Illinois, USA
    Sounds like swapper overwrote some important partitions if it thinks mmcblk0p* is your sd card (mmcblk1p* is your sd card and mmcblk0p* is the internal NAND). This seems to have happened to someone else: http://androidforums.com/triumph-all-things-root/468165-broken-triumph.html

    If you dis/reconnect the battery and plug into a computer is anything detected?

    JTAG might be the only fix and I don't think anyone knows the pinout.
     
    triumphants likes this.
  6. dsmryder

    dsmryder Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    2,418
    Joined:
    May 28, 2011

    May 28, 2011
    2,418
    502
    213
    mechanic
    NE Florida
    Try to hit up BSydz. He seems to be the best using dd_rescue. I know if it can get into the base partition table it can be fixed.

    Are you using a distro of Linux? If not, download a copy of Ubuntu. This will allow you to boot into a live CD and do the work from there.
     
    triumphants likes this.
  7. triumphants

    triumphants Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 13, 2013

    Jul 13, 2013
    14
    0
    15
    Thank you both for your replies!

    I installed Ubuntu and found this detected in the USB port:
    Then in the terminal when using the command "lsusb" I found:
    Googling for now to try and make sense of it. Unfortunately, I don't see partitions mounting, and adb doesn't detect any devices.
     
  8. BSydz

    BSydz Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    951
    Joined:
    Mar 31, 2012

    Mar 31, 2012
    951
    944
    163
    The Mitten
    OK, first does it show in disk utility? It has to be in download mode to work with the file system.

    In Ubuntu, depending on which version, it can be found in Ubuntu 10.04 under System>Administration>Disk Utility or 12.04 under Applications>Accessories>Disk Utility. Found a pic here.

    If it does not then you will have to use an app called SUTLR in windows. Then you will have to use an nb0 from one of our sister phones, then follow this guide.

    I can provide more info, once we get a few more details. Like is it in download mode when you plug it in to Ubuntu? That is the only way to work with the file system. No matter how messed up the HDD is it should still get in to download mode. It may not show the usual polling message so connecting it to a computer is the only way to tell. It also has to be in download mode for SUTLR to work.

    I have done this at least 20 times, so I can walk you through the process from the top of my head. So, get back to me if you have any questions.
     
    DezertDawg1 and triumphants like this.
  9. triumphants

    triumphants Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 13, 2013

    Jul 13, 2013
    14
    0
    15
    Thanks so much for your help, BSydz!

    No luck in detecting the phone in Disk Utility, but I think SUTLR found it. It says "Phone is connected.." at the bottom of the screen when asking for an nbo file. Good to go?

    Are the Cherry Magnum, Wellcom, Spice, and Sharp the sister phones?
     
  10. BSydz

    BSydz Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    951
    Joined:
    Mar 31, 2012

    Mar 31, 2012
    951
    944
    163
    The Mitten
    Yes you are good to go. Grab the Cherry 2.3.4 nb0, and flash it through SUTLR. Then follow the instructions in the other link I posted, and you should be good to go in about 30 minutes. SUTLR may ask if you are sure this is a phone, and do you want to format, just say yes. I had overwritten some of the partitions on the phone at one time, and that is what it asked me. Here is a link to partition 1 aka the mobile partition BSydz_Triumph_Mobile_Partition_with CWM-5.0.2.7.

    Good luck.

    EDIT: also the download mode buttons on the sister phones is Vol up +power instead of Vol dn.
     
    triumphants likes this.
  11. triumphants

    triumphants Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 13, 2013

    Jul 13, 2013
    14
    0
    15
    Ok, I think I'm getting closer, but things haven't been going smoothly. I've written everything out in case I've made mistakes.

    BEFORE nb0:
    • no LED light
    • no partitions mounted in ubuntu
    • no screen (even in download mode)

    I flashed the Cherry Magnum nb0 using SUTLR 1.70 but I had an error. I tried a few more times, including with different computers, but kept getting an error:
    Error Code: 0x4000

    Error: Task 1 of 2, Download Image
    (QC,AMSS,CEFS,APPS,WINCE,aSYS,aUSR,aSPL,aHID) fail,
    Error = DEVICE_NOT_CONFIGURE (0x4000).
    Init Mode = Emergency Download Mode.
    In spite of the error, the LED was lighting up now, and 4 partitions were mounting. I just don't know if the error messed anything up. The 1st partition was 100MB unallocated, instead of a "MOBILE" partition. I made the 1st partition "MOBILE" with the settings of FAT & Primary, then placed the "image" folder from BSydz mobile partition file into it.

    Now, the screen was turning on (!!) but always going into download mode, regardless of the button combos w/ power (vol-up, vol-down, both vol, power only. I can't get into CWM recovery to flash "b_randons stock ROM".

    Also, how do I use dd_rescue with the "TriumpPartition3.img" file for the 3rd partition? I can't get it to mount in Ubuntu.
     
  12. BSydz

    BSydz Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    951
    Joined:
    Mar 31, 2012

    Mar 31, 2012
    951
    944
    163
    The Mitten
    You're gonna have to get SUTLR to work first. There are settings in a drop down for how to flash the nb0. Choose different options til it goes through. Try other nb0s from the sister phones and just keep at it. Once any of the nb0s flash you can then get back.

    The img can be flashed with a command like this(easier if you open the folder it is in with terminal):[HIGH]dd_rescue TriumpPartition3.img /dev/sd?3
    or
    dd_rescue /home/User/downloads/TriumpPartition3.img /dev/sd?3[/HIGH]
    WARNING!!! If you copy and paste make sure the commands and names are correct. Your device names are probably gonna be different.
    NOTE: When doing any action with ddrescue, I advised that you first open Disk Utility to make sure that you know which device is named what. THIS is what you should see on the screen. You will notice this is my thumb drive with my phone backed up to it, so this is what your phone will look like also. Note that the whole device is named "sdd" and each individual partition is named "sdd1" "sdd2" "sdd3" ... accordingly.

    NOTE: You may have to use sudo with these commands, just type sudo and a space before the commands below if you get a message about permissions.
     
  13. triumphants

    triumphants Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 13, 2013

    Jul 13, 2013
    14
    0
    15
    I've been at it with SUTLR for a long time and probably tried 30+ times, but still no luck...

    Things I've tried:
    • nb0s for Vigo 410, Cherry Magnum, Spice Mi 410, and WellcoM A99
    • nb0s above, unpacked via nb0-utils.jar, try to flash the .mlf file
    • All SUTLR options : "None, Erase user data, Enable 'Error Fatal Option', NV Only, Erase Flash"
    • SUTLR v1.7 & v1.82
    • 32-bit & 64-bit SUTLR

    I get this error every time (different from the one before):

    I've attached my first and last log from SUT LR in case you can make sense of them.

    Are there any other options?
     

    Attached Files:

  14. triumphants

    triumphants Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 13, 2013

    Jul 13, 2013
    14
    0
    15
    After the 1st SUTLR, when the partition table was restored, I had 4 partitions. The 1st (100MB) and 4th (~1.7GB) were "UNALLOCATED". After formatting the 1st partition FAT and adding an image folder, the screen started turning on and actually showing the download mode text.

    I know the 4th partition is supposed to house a bunch of other partitions. Is it possible that the 4th partition being unallocated is causing the SUTLR problem?
     
  15. BSydz

    BSydz Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    951
    Joined:
    Mar 31, 2012

    Mar 31, 2012
    951
    944
    163
    The Mitten
    Sorry for the delay been busy.

    Can you post a screenie of the disk utility? THIS is what you should see on the screen. You will notice this is my thumb drive with my phone backed up to it, so this is what your phone will look like also, minus the extra free space at the end. You can only mount and view partitions 1, and 7-12, if I remember correctly.

    The problem may be partition 5 which is the kernel as that contains model info, possibly 3 also, I can get you most of the partitions that you will need.

    Also I've been there where it always shows polling no matter what. Just make sure that you are in download mode, remember after you flash the nb0 it will be vol up and power until you swap the third partition back to Triumph.

    Also, shoot me a PM with contact info like talk or yahoo messenger and we can chat real time while you work on it.
     
  16. triumphants

    triumphants Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 13, 2013

    Jul 13, 2013
    14
    0
    15
    DiskUtility screenshot HERE

    The "MOBILE" and extended partition weren't originally formatted that way. I added them in my efforts to get the phone to work. Also, "MOBILE" is the only volume that actually mounts.
     

    Attached Files:

  17. BSydz

    BSydz Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    951
    Joined:
    Mar 31, 2012

    Mar 31, 2012
    951
    944
    163
    The Mitten
    Umm with the fourth partition wiped you just lost your phone. There are non-replaceable partitions that contain the meid and esn for the phone. There will be no way to get those back if you formatted the 4th partition. Possibly you could try to recover them with some kind of recovery tool. Look here for some info on recovering data in Linux, and here. I don't think it can be done with windows.

    I could give you most of the partitions but 13-17 are phone specific. So unless you can recover those then back them up there is only one other option, I'll PM you the details.
     
  18. triumphants

    triumphants Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 13, 2013

    Jul 13, 2013
    14
    0
    15
    If it helps, I did a ddrescue backup of the phone to an SD card before I formatted the 4th partition. A couple questions:

    1) The 4th partition was showing as free space & labeled unallocated in Ubuntu's Disk Utility. (This was after using Swapper 2, but before I formatted the 4th as an extended partition). Was it possible that I still had the 13-17 partitions after using Swapper 2, even though Disk Utility showed the 4 partition as free space?

    2) I have a ddrescue backup of the phone before I formatted the 4th partition (but after Swapper). Should I restore the ddrescue to the phone and practice using TestDisk on the sd card OR does the phone still possibly have some recoverable data not found in the ddrescue?

    3) Here's what a Deep Search in TestDisk found on the ddrescue backup. Some of the partitions I can explore and see files (apks, folders) but some of them say no filesystem found. Should there be 17 partitions showing up?
     
  19. BSydz

    BSydz Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    951
    Joined:
    Mar 31, 2012

    Mar 31, 2012
    951
    944
    163
    The Mitten
    It sounds like it might work. You don't care about the ones with files, those are wiped every ROM install except mobile, it is the ones you can't read that are important. You will have to recover any partitions that you can. There are unknown filesystems, this is what it should look like with FDisk.
    FDisk output:
    Device Boot >Start >>>>>End >> Blocks>>>>> Id >>>>>System
    /dev/sdd1 >>>1 >>>>>>>204800 >10>>>>>>6 >>>>>> FAT16
    /dev/sdd2 * >204801 >>>205800 >500 >>>>>>4d >>>> QNX4.x
    /dev/sdd3 >>>205801 >>>208800 >1500 >>>>>46 >>>>>Unknown
    /dev/sdd4 >>>208801 >>>3735551 > 1763375+ >5 >>>>>Extended
    /dev/sdd5 >>>212992 >>>229375 >8192 >>>>> 48 >>>>>Unknown
    /dev/sdd6 >>>229376 >>>245759 >8192 >>>>> 50 >>>>>OnTrack DM
    /dev/sdd7 >>>245760 >>>753663 >253952 >>>>82 .>>>>>Linux swap / Solaris
    /dev/sdd8 >>>753664 >>>2998271 >1122304 >>83>>>>> Linux
    /dev/sdd9 >>>2998272 >>3162111 >81920 >>>>6c>>>>> Unknown
    /dev/sdd10 >>3162112 >>3227647 >32768 >>>>6a>>>>> Unknown
    /dev/sdd11 >>3227648 >>3637247 >204800 >>> 6b >>>>> Unknown
    /dev/sdd12 >>3637248 >>3653631 >8192 >>>>> 7b>>>>> Unknown
    /dev/sdd13 >>3653632 >>3670015 >8192 >>>>> 7a >>>>> Unknown
    /dev/sdd14 >>3670016 >>3686399 >8192 >>>>> 78 >>>>> Unknown
    /dev/sdd15 >>3686400 >>3702783 >8192 >>>>> 79 >>>>> Unknown
    /dev/sdd16 >>3702784 >>3719167 >8192 >>>>> 7c >>>>> Unknown
    /dev/sdd17 >>3719168 >>3735551 >8192 >>>>> 7d >>>>> Unknown

    Partitions:
    1 (FAT) Mobile Partition containing image folder, which is very well documented around the forums.

    2 (crypt/QNX4.x) Primary Boot Loader (PBL) I believe that this is what the SOC uses to boot.

    3 (crypt) Secondary Boot Loader I believe this is where the hardware layout is contained, as it changes button configuration and was key to getting back to normal after I flashed the wrong nb0. It is linked to the mobile partition, as the phone will not boot properly without the correct amss.mbn

    4 (extended) Just an extended partition containing partitions 5 - 17.

    5 (Boot) This is where the boot img is extracted.

    6 (OnTrack DM) I think this manages and verifies integrity of partitions 13-17.

    7 (ext3) This is where the system/rom is located. This is what you see in root explorer as "system", containing the build.prop and other stuff.

    8 (ext3) This is the "data" folder .

    9 (ext) This partition holds CDA info, with OEM apks, ringtones, and wallpapers, it seems to be mounted inside partition 10 (hidden) when the phone is on you can find the information merged into "hidden/data" using root explorer.

    10 (ext3) This is the hidden partition containing boot images and CDA info. This can be found in "hidden" using root explorer.

    11 (ext3) This is the cache partition.

    12 (ext3) This is the Caivs, can't find too much info on this.

    13-17 (unknown) I believe this is where the phone specific data is stored, including but not limited to MEID, ESN, and PRL.
     
  20. triumphants

    triumphants Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 13, 2013

    Jul 13, 2013
    14
    0
    15
    I ran into problems with detecting the extended partition and testdisk. I'm going to try to restore the partition table via sfdisk ala this thread

    Any chance you could run this command in linux on a working triumph and post the results?

    [HIGH]sudo sfdisk -d /dev/sda > partition_table.txt[/HIGH]

    I was writing it myself from the fdisk you posted but I want to be sure I get it right.
     
  21. BSydz

    BSydz Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    951
    Joined:
    Mar 31, 2012

    Mar 31, 2012
    951
    944
    163
    The Mitten
    Here you go, and I also uploaded the first three partitions for use with dd_rescue. Partition 1 has a newer cwm recovery, just so you know. They can be found here.

    If you can get the last four partitions then I can get you any other partition you may need, excluding 4 of course.

    Here is the output from the command above:

    Warning: extended partition does not start at a cylinder boundary.
    DOS and Linux will interpret the contents differently.


    # partition table of /dev/sdc
    unit: sectors

    /dev/sdc1 : start= 1, size= 204800, Id= c
    /dev/sdc2 : start= 204801, size= 1000, Id=4d, bootable
    /dev/sdc3 : start= 205801, size= 3000, Id=46
    /dev/sdc4 : start= 208801, size= 3526751, Id= 5
    /dev/sdc5 : start= 212992, size= 16384, Id=48
    /dev/sdc6 : start= 229376, size= 16384, Id=50
    /dev/sdc7 : start= 245760, size= 507904, Id=82
    /dev/sdc8 : start= 753664, size= 2244608, Id=83
    /dev/sdc9 : start= 2998272, size= 163840, Id=6c
    /dev/sdc10: start= 3162112, size= 65536, Id=6a
    /dev/sdc11: start= 3227648, size= 409600, Id=6b
    /dev/sdc12: start= 3637248, size= 16384, Id=7b
    /dev/sdc13: start= 3653632, size= 16384, Id=7a
    /dev/sdc14: start= 3670016, size= 16384, Id=78
    /dev/sdc15: start= 3686400, size= 16384, Id=79
    /dev/sdc16: start= 3702784, size= 16384, Id=7c
    /dev/sdc17: start= 3719168, size= 16384, Id=7d
     
  22. MCPhotographer

    Rank:
    None
    Points:
    15
    Posts:
    33
    Joined:
    Jul 22, 2012

    Jul 22, 2012
    33
    0
    15
    Is there an update to whether or not this was resolved. I have the same issue.
     
  23. dsmryder

    dsmryder Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    2,418
    Joined:
    May 28, 2011

    May 28, 2011
    2,418
    502
    213
    mechanic
    NE Florida
    Where are you in all of this? What have you tried? How did you get to the failure point?
     
  24. MCPhotographer

    Rank:
    None
    Points:
    15
    Posts:
    33
    Joined:
    Jul 22, 2012

    Jul 22, 2012
    33
    0
    15
    Unfortunately, nowhere. I don't get a light when I plug in and I don't get any type of recognition from my computer when plugged in via usb. Something happened during a restore and I'm pretty sure that's what started the problem.
     
  25. lilcourv

    lilcourv Newbie
    Rank:
    None
    Points:
    15
    Posts:
    37
    Joined:
    Jul 14, 2012

    Jul 14, 2012
    37
    0
    15
    Ya so I had bought the evo awhile back and my triumph was sitting for awhile and now it won't turn on or charge or recognize the charge,so would I follow the same steps as above to get it back even if I didn't do anything to cause it?
     

Share This Page

Loading...