1. Are you ready for the Galaxy S20? Here is everything we know so far!
  1. retrogaming1

    retrogaming1 Lurker
    Thread Starter

    I have this old MediaPad 10 FHD which I decided to upgrade its OS from KitKat to Nougat. I took root access by Kingo Root and then Install TWRP Official. I looked up the net for TWRP file for MediaPad online and Flashed it. When I turned it off to boot for Recovery it hung up to Huawei Logo and it does not go any further, and it doesn't turn off either unless runs out of battery. What I've tried so far:

    - I tried every combination said online for hard resting (Power+Volume Up, Power+Volume Down, Power+Middle Volume) but none of them brought me recovery mode.
    - I tried boot from SD Card, downloaded latest Firmware for MediaPad, format my SD in FAT32 and copied dload folder to the root. I tried many times to boot from SD card. It didn't work either.
    - I also tried the boot image here and created it using this, but booting from this image didn't work either.

    My questions:

    1. What should I do which I haven't done?
    2. What needle hole on top of the tablet? Can it help?
    3. Can I hard reset this device by dismantling and hitting some magic button inside?

    Please help :)

    1. Download the Forums for Android™ app!


  2. retrogaming1

    retrogaming1 Lurker
    Thread Starter

Huawei MediaPad 10 FHD Forum

The Huawei MediaPad 10 FHD release date was September 2012. Features and Specs include a 10.0" inch screen, 8MP camera, 2GB RAM, processor, and 6600mAh battery.

September 2012
Release Date

Share This Page