1. Are you ready for the Galaxy S20? Here is everything we know so far!

Hardware ID missing

Discussion in 'Android Devices' started by Max_Headroom, Aug 18, 2012.

  1. Max_Headroom

    Max_Headroom Well-Known Member
    Thread Starter

    I have a windows 7 64-bit PC and every time i plug the phone into the USB slot i get the message below, if i unplug it and plug it in again it sometimes works. (more often than not it doesn't)

    Has anyone else had this problem?


    1. Download the Forums for Android™ app!


  2. Ballymoss

    Ballymoss Android Expert

    Did you buy it new and if not is it possible the IMEI number has been blocked?
  3. Max_Headroom

    Max_Headroom Well-Known Member
    Thread Starter

    Yes it was new, it always works eventually but rarely works the first time i plug it into the USB socket. [​IMG]
  4. Ballymoss

    Ballymoss Android Expert

  5. Max_Headroom

    Max_Headroom Well-Known Member
    Thread Starter

    I think i might have found a solution (not a fix but it seems to work)

    When i plug the phone in if it pops the "hardware ID missing" message up i go to the screen that says "connected as i media device" (sorry for the lame description) and change the setting from Media Device (MTP) to Cameras (PTP) then back and it works a treat.
  6. Max_Headroom

    Max_Headroom Well-Known Member
    Thread Starter

    Back again.

    It turns out the method i described above is not very reliable so i am back to square one plugging it in then removing it when i get the "ID missing" message (see original post) then plugging it in again until it works.

    Today i found out my windows 7 laptop also does the same so i am wondering if it is a driver issue.

    The phone charges ok but i cannot move anything from the phone to my pc as it doesnt connect.

    Can anyone give me some advice its driving me nuts.
  7. Max_Headroom

    Max_Headroom Well-Known Member
    Thread Starter

    Sorted -

    I just tried setting the phone to Camera (PTP) and my problem is sorted, it now connects every time, now when i click start/computer i see a camera listed as a portable device, clicking on it shows two drives phone and card

    I can now move pictures play video and everything i expect i would have been able to do if i had it set on Medis Device (MPT) and it had worked.
  8. Nacos

    Nacos Lurker

    SOLVED! Check this thread
  9. ktroendle70

    ktroendle70 Lurker

    I solved this by downloading the drivers for my Phone directly from Samsung website.

    I did NOT have to uninstall kies.

    I DID have to reboot my computer after driver updates.

    One Tip for Driver download - There were several models listed starting with "SCH-I535" and then some other model number and letters like "I535MBBVZW". I could not find this info for my phone below the battery, however if you select one for the list it will display other info like the color and if the phone is a developer model.

    Window 7 64bit
    Verizon Galaxy s3
  10. dsvendse

    dsvendse Lurker

    Samsung Galaxy S3 - Error "HARDWARE ID MISSING" when plugging phone into computer.

    Simple Fix for Windows 7, 64-bit OS:

    1. Use Control Panel to Uninstall all previous Samsung USB Drivers.
    2. Download Samsung USB Driver v1.4.6.0. from


    3. Reboot computer.
    4. Disconnect computer from the Internet. *This is very important!*
    5. With the phone disconnected, install Samsung USB Driver v1.4.6.0.
    6. Connect the phone to the computer and let Windows install the drivers.
    7. Reestablish the Internet connection.

    This worked flawlessly for me on the first try.

    ***The KEY here is to disconnect from the Internet where indicated, thus forcing Windows to install the older, Samsung USB Driver v1.4.6.0.

    ***Following EVERY Kies update, DISCONNECT the computer from the Internet before plugging in the phone for the first time, or you will have to repeat these steps!

    Have a Nice Day!

  11. PugMilamber

    PugMilamber Lurker

    Finally! My S3 hasn't been connecting to Kies since I rooted it. This method worked perfectly. Thanks dsvendse, you my good man are a star :)
  12. bugcrash

    bugcrash Lurker

    Hi All - I just downloaded the USB drivers from Samsung's support site and re-installed. It told me the drivers were already installed but I proceeded anyway. after the install completed and I plugged my phone back in, Windows popped the message "installing drivers" and at that point I clicked the balloon icon to see the details and when it tried to go to windows update and started downloading those updates I cancelled it. Now the phone is showing up in My Computer again.

Samsung Galaxy S3 Forum

The Samsung Galaxy S3 release date was May 2012. Features and Specs include a 4.8" inch screen, 8MP camera, 1GB RAM, Exynos 4412 Quad processor, and 2100mAh battery.

May 2012
Release Date

Share This Page