1. Download our Official Android App: Forums for Android!

Support Have one answer to fix issue w Galaxy S6 with PC not connecting with MTP

Discussion in 'Android Help' started by Markie55, May 30, 2016.

  1. Markie55

    Markie55 Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    2
    Joined:
    Jan 19, 2015

    Jan 19, 2015
    2
    2
    16
    Male
    Was using Samsung Smart Switch to transfer data between my PC and my Samsung S6.
    All of a sudden (weirdly and maybe connected ) after Verizon update to Android software, when I plugged my phone via cable into PC, Smart Switch came back with Unsupported USB Connection..and change the connection to File Transfer and try connecting again.
    Checked cables, reloaded app and drivers and still the same.. Basically could not transfer data, back up , etc to my PC that always worked and there WAS NO OPTION on phone to change to MTP.

    So I get an excellent support rep from Samsung down in the Philippines and he walked me through fix:

    First had to get into Developers Options: TO do this for the first time:
    Go to Settings- ABOUT DEVICE- BUILD NOTIFICATION and tap 7 times on Build Notification

    Then Developers Options comes up and TURN IT ON.
    Find USB Debugging and TURN to ON
    Find USB Configuration and look at that. Mine said Charging....so I had to tap that and manually change it to MTP to transfer data. Worked fine once I did that.

    Only issue and maybe someone has answer....is that it is not giving me that option to switch to MTP automatically, I have to do it manually, but not a big deal - just follow the info above

    Markie55 Smart Switch - not supported- change connection to File Transfer.JPG
     

    Advertisement

    electricpete likes this.
  2. electricpete

    electricpete Android Expert
    Rank:
     #63
    Points:
    393
    Posts:
    2,073
    Joined:
    Jan 7, 2012

    Jan 7, 2012
    2,073
    1,029
    393
    Male
    Electrical Engineer
    Thanks for sharing your tip, might help someone
    Yeah, it used to be an option or even default on older devices to connect to MTP.

    But recently (Marshmallow, I think) things changed and there's no way to set that as default... always charging first and then have to pull down the notification to switch to MTP. I've looked for a method (root or otherwise) to change that and came up empty.

    Based on the way it evolved, I have a feeling it is a security feature. Perhaps there is fear that files on a locked phone could be accessed by pc... by forcing the user to go through notification this prevents access when locked . Although.... you'd think they could add some double check to see if phone is locked before allowing pc connection rather than forcing users to take that extra step.
     
    #2 electricpete, May 30, 2016
    Last edited: May 30, 2016

Share This Page

Loading...